Trying to access files on my desktop remotely

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Trying to access files on my desktop remotely

Postby Nyron » 18. August 2016 23:45

Hi. In the past I installed XAMPP onto my computer so that I could remotely connect with my phone and sift through files in the "htdocs" folder. I could open them up through my phones web browser and simply view them. No need to transfer or anything like that. It was perfect.

Recently I had to replace my hard drive and upgraded to Windows 10. The XAMPP installation I had unfortunately went with the old drive I pulled out. So now I've reinstalled XAMPP and Apache, but when I go to try and remotely connect, it tells me that access is forbidden. If I remember correctly, the address I need to enter into my phones web browser is "IP Address/XAMPP/htdocs/Folder Name" and that should be it. I'm not sure if it's because we got a new router and there's something I need to change on there, or if it's something with my computers settings, or with XAMPP itself. At the moment I'm assuming it has something to do with the router, but unfortunately I can't remember the username and password for it. I'm trying to find that out at the moment, so any advice you can give in the meantime is greatly appreciated.
Nyron
 
Posts: 1
Joined: 18. August 2016 23:34
XAMPP version: 5.6.23
Operating System: Windows 10 Professional 64-Bit

Re: Trying to access files on my desktop remotely

Postby Nobbie » 19. August 2016 08:59

Nyron wrote:If I remember correctly, the address I need to enter into my phones web browser is "IP Address/XAMPP/htdocs/Folder Name" and that should be it.


I think you are wrong. Usually the DocumentRoot (a setup variable in httpd.conf) already points to xampp/htdocs (i.e. c:/xampp/htdocs) and the correct URL for that location is http://IP/Foldername. Do not specify the DocumentRoot in the URL. Read the appropriate manual about DocumentRoot.

Anyway if you want to access Xampp from outside your LAN, you have to configure your router to do a portforwarding on port 80 to the Xampp PC.
Nobbie
 
Posts: 8770
Joined: 09. March 2008 13:04


Return to XAMPP for Windows

Who is online

Users browsing this forum: JJ_Tagy and 57 guests