Localhost not opening: certificate does NOT include ID

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Localhost not opening: certificate does NOT include ID

Postby pauline » 08. August 2016 14:19

After Windows 10 update I could no loger login to my webpage which I develope. I decided to update my Xampp version, but the problem remains: I get only a white screen when trying to open http://localhost in my browser. http://127.0.0.1 does not work either – same result. :(
I had to remove last files of old Xampp manually, because the uninstall programme did not remove Filezilla, mailoutput and mailtodisk folders. After installation, I have changed the Apache ports from 80 to 1234 and from 443 to 1443 according to given instructions for Windows 10 installation, in order to avoid constant problems with Skype.

Current situation:
Operating system Windows 10 Pro 1511 version, 64bit
Xampp version 5.5.37
Control Panel Version: 3.2.2
Running with Administrator rights
XAMPP Installation Directory: "c:\xampp\"
Apache – running
mysql – running
Filezilla – running
(Mercury & Tomcat also working, but not running at the moment)

Security system F-Secure. Apache, Mysql and Filezilla are allowed by Firewall. Browsers Mozilla Firefox and Microsoft Edge – Edge gives an HTTP 404 error message and Mozilla a blank page
HOST-file contains 127.0.0.1 localhost as it should.
I have rebooted my system over ten times already. That won’t resolve the problem.

Apache error logs announce:
Code: Select all
[Mon Aug 08 15:29:30.318041 2016] [ssl:warn] [pid 6788:tid 560] AH01909: www.example.com:1443:0 server certificate does NOT include an ID which matches the server name
[Mon Aug 08 15:29:30.387515 2016] [core:warn] [pid 6788:tid 560] AH00098: pid file C:/xampp/apache/logs/httpd.pid overwritten -- Unclean shutdown of previous Apache run?
[Mon Aug 08 15:29:30.655099 2016] [ssl:warn] [pid 6788:tid 560] AH01909: www.example.com:1443:0 server certificate does NOT include an ID which matches the server name
[Mon Aug 08 15:29:30.754668 2016] [mpm_winnt:notice] [pid 6788:tid 560] AH00455: Apache/2.4.17 (Win32) OpenSSL/1.0.2d PHP/5.5.37 configured -- resuming normal operations
[Mon Aug 08 15:29:30.754668 2016] [mpm_winnt:notice] [pid 6788:tid 560] AH00456: Apache Lounge VC11 Server built: Oct 13 2015 10:54:13
[Mon Aug 08 15:29:30.754668 2016] [core:notice] [pid 6788:tid 560] AH00094: Command line: 'c:\\xampp\\apache\\bin\\httpd.exe -d C:/xampp/apache'
[Mon Aug 08 15:29:30.766124 2016] [mpm_winnt:notice] [pid 6788:tid 560] AH00418: Parent: Created child process 1340
[Mon Aug 08 15:29:31.795787 2016] [ssl:warn] [pid 1340:tid 528] AH01909: www.example.com:1443:0 server certificate does NOT include an ID which matches the server name
[Mon Aug 08 15:29:32.131843 2016] [ssl:warn] [pid 1340:tid 528] AH01909: www.example.com:1443:0 server certificate does NOT include an ID which matches the server name
[Mon Aug 08 15:29:32.205352 2016] [mpm_winnt:notice] [pid 1340:tid 528] AH00354: Child: Starting 150 worker threads. Mysql has not written error logs after I got It running.


The Apache error log mentions a problem with ID and www.example.com:1443:0 server certificate. How can I fix that? How can get my localhost open? Please help and explain so simply that I can understand. None of the support forum answers I have found in the web have resolved my problem. I am out of ideas. :?
pauline
 
Posts: 1
Joined: 08. August 2016 13:38
XAMPP version: 5.5.37
Operating System: Windows 10

Re: Localhost not opening: certificate does NOT include ID

Postby Altrea » 08. August 2016 15:16

pauline wrote:After installation, I have changed the Apache ports from 80 to 1234 and from 443 to 1443 according to given instructions for Windows 10 installation, in order to avoid constant problems with Skype.


Port 80 is the default HTTP port, 443 is the default HTTPS/SSL port. Skype is not a HTTP or HTTPS server. Tell Skype not to use these ports.

Read this: [Q&A] solving Port 80 & 443 in use by Skype issue
and this: [Q&A] Changing the Apache default ports
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8290
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: Localhost not opening: certificate does NOT include ID

Postby Paindian » 11. August 2016 11:03

Can it be because your new to win10 you are not logged in localy in win10?

Win10 standard is loged in and work on windows servers on internet!?

Grtx,
Paindian
 
Posts: 1
Joined: 11. August 2016 10:49
XAMPP version: 3.2.2
Operating System: win10

Re: Localhost not opening: certificate does NOT include ID

Postby Nobbie » 11. August 2016 18:05

pauline wrote:I have changed the Apache ports from 80 to 1234 and from 443 to 1443 according to given instructions for Windows 10 installation, in order to avoid constant problems with Skype.


We do NOT give such worse instructions, what do you mean by "given instruction"?? You should ask the idiot which gave that instruction..

Anyway, if you followed this horrible advice, your installation does not work any further via "http://localhost", you MUST apply the Port number (in your case 1234) as well: http://localhost:1234
As you can see, this is quite ugly.
Nobbie
 
Posts: 8769
Joined: 09. March 2008 13:04


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 66 guests