Apache will not start after trying everything I know

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Apache will not start after trying everything I know

Postby ibaker » 12. July 2016 02:10

Just installed the latest version o9f xampp on a windows 10 machine and I can't start apache. I tried:
1. Configure HTTP.sys to only bind to IPv6
2. resolve localhost to the IPv4 address 127.0.0.1

The control panel is saying:
11:02:01 AM [Apache] Error: Apache shutdown unexpectedly.
11:02:01 AM [Apache] This may be due to a blocked port, missing dependencies,
11:02:01 AM [Apache] improper privileges, a crash, or a shutdown by another method.
11:02:01 AM [Apache] Press the Logs button to view error logs and check
11:02:01 AM [Apache] the Windows Event Viewer for more clues
11:02:01 AM [Apache] If you need more help, copy and post this
11:02:01 AM [Apache] entire log window on the forums

The error log is saying:
[Tue Jul 12 11:02:01.033729 2016] [ssl:warn] [pid 8204:tid 608] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Tue Jul 12 11:02:01.133990 2016] [ssl:warn] [pid 8204:tid 608] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Tue Jul 12 11:02:01.149617 2016] [mpm_winnt:notice] [pid 8204:tid 608] AH00455: Apache/2.4.18 (Win32) OpenSSL/1.0.2e PHP/7.0.8 configured -- resuming normal operations
[Tue Jul 12 11:02:01.149617 2016] [mpm_winnt:notice] [pid 8204:tid 608] AH00456: Apache Lounge VC14 Server built: Dec 9 2015 10:17:39
[Tue Jul 12 11:02:01.149617 2016] [core:notice] [pid 8204:tid 608] AH00094: Command line: 'C:\\xampp\\apache\\bin\\httpd.exe -d C:/xampp/apache'
[Tue Jul 12 11:02:01.149617 2016] [mpm_winnt:notice] [pid 8204:tid 608] AH00418: Parent: Created child process 6168
[Tue Jul 12 11:02:01.397110 2016] [ssl:warn] [pid 6168:tid 572] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Tue Jul 12 11:02:01.466177 2016] [ssl:warn] [pid 6168:tid 572] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Tue Jul 12 11:02:01.481804 2016] [mpm_winnt:crit] [pid 6168:tid 572] (OS 109)The pipe has been ended. : AH00404: Child: Unable to read socket data from parent
[Tue Jul 12 11:02:01.497445 2016] [mpm_winnt:crit] [pid 8204:tid 608] AH00427: Parent: child process 6168 exited with status 3 -- Aborting.
ibaker
 
Posts: 5
Joined: 12. July 2016 01:58
XAMPP version: xampp-win32-7.0.8-0-VC14
Operating System: Windows 10 Pro

Re: Apache will not start after trying everything I know

Postby Altrea » 12. July 2016 08:56

ibaker wrote:The control panel is saying:
11:02:01 AM [Apache] Error: Apache shutdown unexpectedly.
11:02:01 AM [Apache] This may be due to a blocked port, missing dependencies,
11:02:01 AM [Apache] improper privileges, a crash, or a shutdown by another method.
11:02:01 AM [Apache] Press the Logs button to view error logs and check
11:02:01 AM [Apache] the Windows Event Viewer for more clues
11:02:01 AM [Apache] If you need more help, copy and post this
11:02:01 AM [Apache] entire log window on the forums

This is not enough information: https://community.apachefriends.org/f/viewtopic.php?f=16&t=72518#p247610

Tried any of the other solutions here? [Q&A] Apache won't start
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8290
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: Apache will not start after trying everything I know

Postby ibaker » 12. July 2016 09:01

Thanks...however the time it took for the post to appear I was able to fix it by the FAQ of:


By default, Windows 10 starts Microsoft IIS on port 80, which is the same default port used by Apache in XAMPP. As a result, Apache cannot bind to port 80.

To disable IIS from running on port 80, follow these steps:

Open the Services panel in Computer Management.
Search for the 'World Wide Web Publishing Service' and select it.
Click the link to 'Stop the service'.
Double-click the service name.
In the 'Startup type' field, change the startup type to 'Disabled'.
Click 'OK' to save your changes.

You should now be able to start Apache in XAMPP on port 80.

For more information, refer to the 'Troubleshoot Apache Startup Problems' guide included with XAMPP or this forum post.
ibaker
 
Posts: 5
Joined: 12. July 2016 01:58
XAMPP version: xampp-win32-7.0.8-0-VC14
Operating System: Windows 10 Pro


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 49 guests