Apache won't start. ID-problems

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Apache won't start. ID-problems

Postby HenkvdG » 08. July 2016 22:51

Systeem : Windows 7.
Versie Apache: 5.6.23
Ik heb woensdag 6 juli Apache ingeladen en geïnstalleerd.
Achteraf blijkt dat ik Apache niet als administrator heb geïnstalleerd.
Nu moet ik het programma via “sampp-control” en de rechter muisknop op starten om als administrator in te loggen. Hoe kan ik alsnog vastleggen dat ik de administrator ben. Ik gebruik mijn computer alleen en log ook niet in met een speciale user.
Ik heb Mercury niet geïnstalleerd.
Apache wil niet starten en wordt afgebroken.
Als ik de “Apache”-startknop in druk krijg ik de volgende melding:
23:22:54 [main] Initializing Control Panel
23:22:54 [main] Windows Version: Windows 7 Home Premium SP1 64-bit
23:22:54 [main] XAMPP Version: 5.6.23
23:22:54 [main] Control Panel Version: 3.2.2 [ Compiled: Nov 12th 2015 ]
23:22:54 [main] Running with Administrator rights - good!
23:22:54 [main] XAMPP Installation Directory: "c:\xampp\"
23:22:54 [main] Checking for prerequisites
23:22:54 [main] All prerequisites found
23:22:54 [main] Initializing Modules
23:22:54 [mysql] XAMPP MySQL is already running on port 3306
23:22:54 [filezilla] XAMPP FileZilla is already running on port 21
23:22:54 [filezilla] XAMPP FileZilla is already running on port 14147
23:22:54 [mercury] Problem detected: Mercury Not Found!
23:22:54 [mercury] Disabling Mercury buttons
23:22:54 [mercury] Run this program from your XAMPP root directory!
23:22:54 [main] Starting Check-Timer
23:22:54 [main] Control Panel Ready
23:24:37 [Apache] Attempting to start Apache app...
23:24:37 [Apache] Status change detected: running
23:24:39 [Apache] Status change detected: stopped
23:24:39 [Apache] Error: Apache shutdown unexpectedly.
23:24:39 [Apache] This may be due to a blocked port, missing dependencies,
23:24:39 [Apache] improper privileges, a crash, or a shutdown by another method.
23:24:39 [Apache] Press the Logs button to view error logs and check
23:24:39 [Apache] the Windows Event Viewer for more clues
23:24:39 [Apache] If you need more help, copy and post this
23:24:39 [Apache] entire log window on the forums
Via Apache login krijg ik de volgende foutmelding:

[Fri Jul 08 23:24:38.022025 2016] [ssl:warn] [pid 6404:tid 260] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Fri Jul 08 23:24:38.178026 2016] [ssl:warn] [pid 6404:tid 260] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Fri Jul 08 23:24:38.209226 2016] [mpm_winnt:notice] [pid 6404:tid 260] AH00455: Apache/2.4.17 (Win32) OpenSSL/1.0.2d PHP/5.6.23 configured -- resuming normal operations
[Fri Jul 08 23:24:38.209226 2016] [mpm_winnt:notice] [pid 6404:tid 260] AH00456: Apache Lounge VC11 Server built: Oct 13 2015 10:54:13
[Fri Jul 08 23:24:38.209226 2016] [core:notice] [pid 6404:tid 260] AH00094: Command line: 'c:\\xampp\\apache\\bin\\httpd.exe -d C:/xampp/apache'
[Fri Jul 08 23:24:38.209226 2016] [mpm_winnt:notice] [pid 6404:tid 260] AH00418: Parent: Created child process 11856
[Fri Jul 08 23:24:38.739627 2016] [ssl:warn] [pid 11856:tid 272] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Fri Jul 08 23:24:38.864427 2016] [ssl:warn] [pid 11856:tid 272] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Fri Jul 08 23:24:38.895627 2016] [mpm_winnt:crit] [pid 11856:tid 272] (OS 109)De pipe is beëindigd. : AH00404: Child: Unable to read socket data from parent
[Fri Jul 08 23:24:38.911227 2016] [mpm_winnt:crit] [pid 6404:tid 260] AH00427: Parent: child process 11856 exited with status 3 -- Aborting.

Wat moet ik doen om de juiste ID in te voeren?

Hartelijk dank voor uw hulp.
HenkvdG
 
Posts: 4
Joined: 08. July 2016 22:42
XAMPP version: 5.6.23
Operating System: windows 7

Re: Apache won't start. ID-problems

Postby Nobbie » 09. July 2016 10:43

This is an english board.
Nobbie
 
Posts: 8759
Joined: 09. March 2008 13:04

Re: Apache won't start. ID-problems

Postby HenkvdG » 09. July 2016 11:05

I know, it is an English board.
I wil give my problem in English.
I started with Apache some days ago. I didn't install Apache with the Adminitrator possibility. Now I have to start the program with "samp-controll" and a right mouseclick to get the Administrator function. Then the program starts and I get the above messages about ID-problems. My questions are: How can I still fix the Administrator-function in the program? I am the only user of my computer. How can I sole ID-problem?
Thanks, Henk
HenkvdG
 
Posts: 4
Joined: 08. July 2016 22:42
XAMPP version: 5.6.23
Operating System: windows 7

Re: Apache won't start. ID-problems

Postby Nobbie » 09. July 2016 11:35

HenkvdG wrote:My questions are: How can I still fix the Administrator-function in the program?


Which "Administer-function"?

The messages above only tells, that Apache is already started (maybe you installed and run it as a service?!), simply open your browser and enter http://localhost. When the Xampp Welcome screen appears, everyting is ok.
Nobbie
 
Posts: 8759
Joined: 09. March 2008 13:04

Re: Apache won't start. ID-problems

Postby HenkvdG » 09. July 2016 11:55

Thanks,
When I do http://localhost then I get the IIS7welcome-screen and no more, What do I wrong in my computer?
HenkvdG
 
Posts: 4
Joined: 08. July 2016 22:42
XAMPP version: 5.6.23
Operating System: windows 7

Re: Apache won't start. ID-problems

Postby Nobbie » 09. July 2016 13:38

HenkvdG wrote:Thanks,
When I do http://localhost then I get the IIS7welcome-screen and no more, What do I wrong in my computer?


Then you have another Webserver running, its Microsoft IIS (see http://www.iis.net/, IIS = Internet Information Service). You should stop and deinstall the Microsoft IIS if you want to use Apache (Xampp).
Nobbie
 
Posts: 8759
Joined: 09. March 2008 13:04

Re: Apache won't start. ID-problems

Postby HenkvdG » 10. July 2016 09:17

I blocked IIS7. The result is that apache starts and runs on port 80.

Thank you for your help.

Greetings Henk
HenkvdG
 
Posts: 4
Joined: 08. July 2016 22:42
XAMPP version: 5.6.23
Operating System: windows 7


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 43 guests