httpd-xampp.conf edit and now apache dont start

Problems with the Windows version of XAMPP, questions, comments, and anything related.

httpd-xampp.conf edit and now apache dont start

Postby coconeitor99 » 22. June 2016 16:47

help me, i edit the file httpd-xampp.conf and apache dont start

this is my edit file:
#
# XAMPP settings
#

<IfModule env_module>
SetEnv MIBDIRS "/xampp/php/extras/mibs"
SetEnv MYSQL_HOME

"\\xampp\\mysql\\bin"
SetEnv OPENSSL_CONF "/xampp/apache/bin/openssl.cnf"
SetEnv

PHP_PEAR_SYSCONF_DIR "\\xampp\\php"
SetEnv PHPRC "\\xampp\\php"
SetEnv TMP "\\xampp\\tmp"
</IfModule>

#
# PHP-Module setup
#
LoadFile "/xampp/php/php7ts.dll"
LoadFile "/xampp/php/libpq.dll"
LoadModule php7_module "/xampp/php/php7apache2_4.dll"

<FilesMatch "\.php$">
SetHandler

application/x-httpd-php
</FilesMatch>
<FilesMatch "\.phps$">
SetHandler application/x-httpd-php-

source
</FilesMatch>

#
# PHP-CGI setup
#
#<FilesMatch "\.php$">
# SetHandler application/x-httpd-php-cgi
#</FilesMatch>
#<IfModule actions_module>
# Action application/x-httpd-php-cgi "/php-cgi/php-cgi.exe"
#</IfModule>


<IfModule php7_module>
PHPINIDir "/xampp/php"
</IfModule>

<IfModule mime_module>


AddType text/html .php .phps
</IfModule>

ScriptAlias /php-cgi/ "/xampp/php/"
<Directory "/xampp/php">


Allowdeny None
Options None
Require all denied
<Files "php-cgi.exe">
Require all

granted
</Files>
</Directory>

<Directory "/xampp/cgi-bin">
<FilesMatch "\.php$">
SetHandler

cgi-script
</FilesMatch>
<FilesMatch "\.phps$">
SetHandler None
</FilesMatch>
</Directory>

<Directory "/xampp/htdocs/xampp">
<IfModule php7_module>
<Files "status.php">


php_admin_flag safe_mode off
</Files>
</IfModule>
AllowOverride

AuthConfig
</Directory>

<IfModule alias_module>
Alias /licenses "/xampp/licenses/"
<Directory

"/xampp/licenses">
Options +Indexes
<IfModule autoindex_color_module>


DirectoryIndexTextColor "#000000"
DirectoryIndexBGColor "#f8e8a0"


DirectoryIndexLinkColor "#bb3902"
DirectoryIndexVLinkColor "#bb3902"


DirectoryIndexALinkColor "#bb3902"
</IfModule>
Require local
ErrorDocument 403

/error/XAMPP_FORBIDDEN.html.var
</Directory>

Alias /phpmyadmin "/xampp/phpMyAdmin/"
<Directory

"/xampp/phpMyAdmin">
Allowdeny AuthConfig
Require local
ErrorDocument 403

/error/XAMPP_FORBIDDEN.html.var
</Directory>

Alias /webalizer "/xampp/webalizer/"
<Directory

"/xampp/webalizer">
<IfModule php7_module>
<Files "webalizer.php">


php_admin_flag safe_mode off
</Files>
</IfModule>
Allowdeny

AuthConfig
Require local
ErrorDocument 403 /error/XAMPP_FORBIDDEN.html.var


</Directory>
</IfModule>


please help me, i need a copy of the file
coconeitor99
 
Posts: 4
Joined: 22. June 2016 04:17
XAMPP version: v3.2.2
Operating System: window 7 professional + servic

Re: httpd-xampp.conf edit and now apache dont start

Postby Nobbie » 22. June 2016 19:38

Code: Select all
#
# XAMPP settings
#

<IfModule env_module>
    SetEnv MIBDIRS "C:/xampp/php/extras/mibs"
    SetEnv MYSQL_HOME "\\xampp\\mysql\\bin"
    SetEnv OPENSSL_CONF "C:/xampp/apache/bin/openssl.cnf"
    SetEnv PHP_PEAR_SYSCONF_DIR "\\xampp\\php"
    SetEnv PHPRC "\\xampp\\php"
    SetEnv TMP "\\xampp\\tmp"
</IfModule>

#
# PHP-Module setup
#
LoadFile "C:/xampp/php/php7ts.dll"
LoadFile "C:/xampp/php/libpq.dll"
LoadModule php7_module "C:/xampp/php/php7apache2_4.dll"

<FilesMatch "\.php$">
    SetHandler application/x-httpd-php
</FilesMatch>
<FilesMatch "\.phps$">
    SetHandler application/x-httpd-php-source
</FilesMatch>

#
# PHP-CGI setup
#
#<FilesMatch "\.php$">
#    SetHandler application/x-httpd-php-cgi
#</FilesMatch>
#<IfModule actions_module>
#    Action application/x-httpd-php-cgi "/php-cgi/php-cgi.exe"
#</IfModule>


<IfModule php7_module>
    PHPINIDir "C:/xampp/php"
</IfModule>

<IfModule mime_module>
    AddType text/html .php .phps
</IfModule>

ScriptAlias /php-cgi/ "C:/xampp/php/"
<Directory "C:/xampp/php">
    AllowOverride None
    Options None
    Require all denied
    <Files "php-cgi.exe">
          Require all granted
    </Files>
</Directory>

<Directory "C:/xampp/cgi-bin">
    <FilesMatch "\.php$">
        SetHandler cgi-script
    </FilesMatch>
    <FilesMatch "\.phps$">
        SetHandler None
    </FilesMatch>
</Directory>

<Directory "C:/xampp/htdocs/xampp">
    <IfModule php7_module>
       <Files "status.php">
          php_admin_flag safe_mode off
       </Files>
    </IfModule>
    AllowOverride AuthConfig
</Directory>

<IfModule alias_module>
    Alias /licenses "C:/xampp/licenses/"
    <Directory "C:/xampp/licenses">
        Options +Indexes
        <IfModule autoindex_color_module>
            DirectoryIndexTextColor  "#000000"
            DirectoryIndexBGColor "#f8e8a0"
            DirectoryIndexLinkColor "#bb3902"
            DirectoryIndexVLinkColor "#bb3902"
            DirectoryIndexALinkColor "#bb3902"
        </IfModule>
        Require local
        ErrorDocument 403 /error/XAMPP_FORBIDDEN.html.var
   </Directory>

    Alias /phpmyadmin "C:/xampp/phpMyAdmin/"
    <Directory "C:/xampp/phpMyAdmin">
        AllowOverride AuthConfig
        Require local
        ErrorDocument 403 /error/XAMPP_FORBIDDEN.html.var
    </Directory>

    Alias /webalizer "C:/xampp/webalizer/"
    <Directory "C:/xampp/webalizer">
        <IfModule php7_module>
          <Files "webalizer.php">
             php_admin_flag safe_mode off
          </Files>
        </IfModule>
        AllowOverride AuthConfig
        Require local
        ErrorDocument 403 /error/XAMPP_FORBIDDEN.html.var
    </Directory>
</IfModule>
Nobbie
 
Posts: 8775
Joined: 09. March 2008 13:04


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 24 guests