xamp v3.2.2 phpmyadmin new secirity concept error

Problems with the Windows version of XAMPP, questions, comments, and anything related.

xamp v3.2.2 phpmyadmin new secirity concept error

Postby jlewis » 10. June 2016 17:29

I have this xampp running everything working fine but I cannot access phpmyadmin from other computers within the network. I search for couple weeks but could not find the solution to my answer any file other have told me to change I cannot find that quote in my file. Here is the code listed please help me to let me know what I need to change in order to access it on the network. I cannot find localmatch quote in my file to change and this is what everyone is telling to change.

Code: Select all
#
# XAMPP settings
#

<IfModule env_module>
    SetEnv MIBDIRS "/xampp/php/extras/mibs"
    SetEnv MYSQL_HOME "\\xampp\\mysql\\bin"
    SetEnv OPENSSL_CONF "/xampp/apache/bin/openssl.cnf"
    SetEnv PHP_PEAR_SYSCONF_DIR "\\xampp\\php"
    SetEnv PHPRC "\\xampp\\php"
    SetEnv TMP "\\xampp\\tmp"
</IfModule>

#
# PHP-Module setup
#
LoadFile "/xampp/php/php5ts.dll"
LoadFile "/xampp/php/libpq.dll"
LoadModule php5_module "/xampp/php/php5apache2_4.dll"

<FilesMatch "\.php$">
    SetHandler application/x-httpd-php
</FilesMatch>
<FilesMatch "\.phps$">
    SetHandler application/x-httpd-php-source
</FilesMatch>

#
# PHP-CGI setup
#
#<FilesMatch "\.php$">
#    SetHandler application/x-httpd-php-cgi
#</FilesMatch>
#<IfModule actions_module>
#    Action application/x-httpd-php-cgi "/php-cgi/php-cgi.exe"
#</IfModule>


<IfModule php5_module>
    PHPINIDir "/xampp/php"
</IfModule>

<IfModule mime_module>
    AddType text/html .php .phps
</IfModule>

ScriptAlias /php-cgi/ "/xampp/php/"
<Directory "/xampp/php">
    AllowOverride None
    Options None
    Require all denied
    <Files "php-cgi.exe">
          Require all granted
    </Files>
</Directory>

<Directory "/xampp/cgi-bin">
    <FilesMatch "\.php$">
        SetHandler cgi-script
    </FilesMatch>
    <FilesMatch "\.phps$">
        SetHandler None
    </FilesMatch>
</Directory>

<Directory "/xampp/htdocs/xampp">
    <IfModule php5_module>
       <Files "status.php">
          php_admin_flag safe_mode off
       </Files>
    </IfModule>
    AllowOverride AuthConfig
</Directory>

<IfModule alias_module>
    Alias /licenses "/xampp/licenses/"
    <Directory "/xampp/licenses">
        Options +Indexes
        <IfModule autoindex_color_module>
            DirectoryIndexTextColor  "#000000"
            DirectoryIndexBGColor "#f8e8a0"
            DirectoryIndexLinkColor "#bb3902"
            DirectoryIndexVLinkColor "#bb3902"
            DirectoryIndexALinkColor "#bb3902"
        </IfModule>
        Require local
        ErrorDocument 403 /error/XAMPP_FORBIDDEN.html.var
   </Directory>

    Alias /phpmyadmin "/xampp/phpMyAdmin/"
    <Directory "/xampp/phpMyAdmin">
        AllowOverride AuthConfig
        Require local
        ErrorDocument 403 /error/XAMPP_FORBIDDEN.html.var
    </Directory>

    Alias /webalizer "/xampp/webalizer/"
    <Directory "/xampp/webalizer">
        <IfModule php5_module>
          <Files "webalizer.php">
             php_admin_flag safe_mode off
          </Files>
        </IfModule>
        AllowOverride AuthConfig
        Require local
        ErrorDocument 403 /error/XAMPP_FORBIDDEN.html.var
    </Directory>
</IfModule>

jlewis
 
Posts: 1
Joined: 10. June 2016 17:23
XAMPP version: 3.2.2
Operating System: windows 7

Re: xamp v3.2.2 phpmyadmin new secirity concept error

Postby gsmith » 11. June 2016 22:12

Code: Select all
<Directory "/xampp/phpMyAdmin">
    AllowOverride AuthConfig
    Require local
    ErrorDocument 403 /error/XAMPP_FORBIDDEN.html.var
</Directory>


Require local is what only allows access from the computer Apache is running on. You have to allow all internal computers on your network. It they are for example 192.168.1.xxx , then add a line right below it with;

Require ip 192.168.1

Save your changes and restart Apache.

Just remember that anyone on any of these computers can access phpMyAdmin now. Of course it also allows you the convenience of administering mysql from any internal computer which I assume is why you want this.
gsmith
 
Posts: 194
Joined: 29. November 2013 18:04
Location: San Diego
XAMPP version: 0.0.0
Operating System: Win XP to 2012R2/VS 6,9,11,14

Re: xamp v3.2.2 phpmyadmin new secirity concept error

Postby jad albert » 20. October 2016 08:46

gsmith wrote:
Code: Select all
<Directory "/xampp/phpMyAdmin">
    AllowOverride AuthConfig
    Require local
    ErrorDocument 403 /error/XAMPP_FORBIDDEN.html.var
</Directory>


Require local is what only allows access from the computer Apache is running on. You have to allow all internal computers on your network. It they are for example 192.168.1.xxx , then add a line right below it with;

Require ip 192.168.1

Save your changes and restart Apache.

Just remember that anyone on any of these computers can access phpMyAdmin now. Of course it also allows you the convenience of administering mysql from any internal computer which I assume is why you want this.


Is there any alternate way to do so because i messed up with aforementioned solution.
jad albert
 
Posts: 3
Joined: 20. October 2016 08:38
XAMPP version: NA
Operating System: NA


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 27 guests