First time on XAMPP - MySQL installation error - 2

Problems with the Windows version of XAMPP, questions, comments, and anything related.

First time on XAMPP - MySQL installation error - 2

Postby RossaK » 03. June 2016 12:02

Hi,

Following to the query on My SQL startup help needed, here is the message I get on command line interface on Shell:

<Welcome to MariaDB monitor.
Your MariaDB connection is 2.>

Should it be giving a message as :
<Welcome to MySQL monitor.>

I was referrring to your answers on :
[Q&A] Setting MySQL root password

Please guide.
RossaK
 
Posts: 5
Joined: 03. June 2016 10:34
XAMPP version: 7.0.6
Operating System: Windows

Re: First time on XAMPP - MySQL installation error - 2

Postby Nobbie » 03. June 2016 14:02

I cannot see any error here? You get a different prompt, the documentation seems outdated, as Xampp does not install MySQL but MariaDB instead. But the message (the prompt) looks fine. Simply go on and enter your SQL Statements.
Nobbie
 
Posts: 8772
Joined: 09. March 2008 13:04

Re: First time on XAMPP - MySQL installation error - 2

Postby RossaK » 12. June 2016 10:30

Hi Nobbie,

Thanks for a heads up. However, when I try to access http://localhost/phpmyadmin/
Below message appears:

<Unable to connect

Firefox can't establish a connection to the server at localhost.

The site could be temporarily unavailable or too busy. Try again in a few moments.
If you are unable to load any pages, check your computer's network connection.
If your computer or network is protected by a firewall or proxy, make sure that Firefox is permitted to access the Web.>


and if I try with - http://10.1.13/phpmyadmin/

<The connection has timed out

The server at 10.1.13 is taking too long to respond.

The site could be temporarily unavailable or too busy. Try again in a few moments.
If you are unable to load any pages, check your computer's network connection.
If your computer or network is protected by a firewall or proxy, make sure that Firefox is permitted to access the Web.>

So I am not able to access http://localhost/phpmyadmin/
Everything is fine on the command line till steps 1a.IV. as per the instructions in - [Q&A] Setting MySQL root password
MariaDB connection id is 2
Server Version: 10.1.13
Please help me with what am I missing here.
RossaK
 
Posts: 5
Joined: 03. June 2016 10:34
XAMPP version: 7.0.6
Operating System: Windows

Re: First time on XAMPP - MySQL installation error - 2

Postby Altrea » 12. June 2016 11:26

Is Apache started?
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8293
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: First time on XAMPP - MySQL installation error - 2

Postby JJ_Tagy » 12. June 2016 12:40

RossaK wrote:and if I try with - http://10.1.13/phpmyadmin/

10.1.13 is a server version, not an IP address. That would not have worked anyways.
JJ_Tagy
 
Posts: 678
Joined: 30. January 2012 13:44
Operating System: Windows 10 Pro x64

Re: First time on XAMPP - MySQL installation error - 2

Postby Nobbie » 12. June 2016 16:23

JJ_Tagy wrote:10.1.13 is a server version, not an IP address. That would not have worked anyways.


OMG ... you have good eyes! I did not see that, i thought that this is a LAN IP like 10.1.1.13 or similar, i did not see that there is missing one part...
Nobbie
 
Posts: 8772
Joined: 09. March 2008 13:04

Re: First time on XAMPP - MySQL installation error - 2

Postby RossaK » 15. June 2016 07:37

Altrea wrote:Is Apache started?


HI Altrea/ Nobbie,

No, Apache didn't start. Shows bellow error:

"The Program can't start because api-ms-win-crt-runtime-I1-1-0.dll is missing from your computer. Try re-installing the program to fix this problem."

Few workarounds I did:

>I turned off port 443 from Skype, following instructions given in:
[Q&A] solving Port 80 & 443 in use by Skype issue

> I found one more instruction in query - Error: Apache shutdown unexpectedly.
Here a resolution given takes me to a blog - http://blog.garethjmsaunders.co.uk/2015/12/23/xampp-apache-wont-start-on-windows-10-a-fix/

It suggests to Stop World Wide Web Publishing Service, which I don't seem to have in my list of services.msc

Now, it seems my computer is missing some service which I might need to install. Only that I cannot figure out, what could it be.

JJ_Tagy wrote:
RossaK wrote:and if I try with - http://10.1.13/phpmyadmin/

10.1.13 is a server version, not an IP address. That would not have worked anyways.



JJ - Thanks for making it clear, what I misunderstood.
RossaK
 
Posts: 5
Joined: 03. June 2016 10:34
XAMPP version: 7.0.6
Operating System: Windows

Re: First time on XAMPP - MySQL installation error - 2

Postby Nobbie » 15. June 2016 10:49

RossaK wrote:" Try re-installing the program to fix this problem."

Few workarounds I did:


Instead you should google for that message "The Program can't start because api-ms-win-crt-runtime-I1-1-0.dll is missing from your computer", it will give you tons of hints how to fix that issue. You will have to install the appropriate Visual C++ Redistributable.
Nobbie
 
Posts: 8772
Joined: 09. March 2008 13:04

Re: First time on XAMPP - MySQL installation error - 2

Postby RossaK » 17. June 2016 08:51

Nobbie wrote:
Instead you should google for that message "The Program can't start because api-ms-win-crt-runtime-I1-1-0.dll is missing from your computer", it will give you tons of hints how to fix that issue. You will have to install the appropriate Visual C++ Redistributable.


Well, it seems yet few steps to go to have the Apache ready to work. As getting error 0x80240017 on trying to install Microsoft Visual C++ 2015 Redistributable
Found a helpful blog on handling this error - https://www.reddit.com/r/techsupport/comments/464swn/microsoft_visual_c_2015_redistributable_setup/

I shall get back once I am done. :p
RossaK
 
Posts: 5
Joined: 03. June 2016 10:34
XAMPP version: 7.0.6
Operating System: Windows

Re: First time on XAMPP - MySQL installation error - 2

Postby jad albert » 20. October 2016 08:43

RossaK wrote:Hi,

Following to the query on My SQL startup help needed, here is the message I get on command line interface on Shell:

<Welcome to MariaDB monitor.
Your MariaDB connection is 2.>

Should it be giving a message as :
<Welcome to MySQL monitor.>

I was referrring to your answers on :
[Q&A] Setting MySQL root password

Please guide.


I was getting same error last time but after re-configuration i went away. This error often occurs due to poor configuration.
jad albert
 
Posts: 3
Joined: 20. October 2016 08:38
XAMPP version: NA
Operating System: NA


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 85 guests