mcrypt extension not working

Problems with the Windows version of XAMPP, questions, comments, and anything related.

mcrypt extension not working

Postby xkevin » 13. May 2016 04:08

I am having trouble when I use the mcrypt_encrypt/decrypt function because it is not working on localhost. How can I install and enable it? Any help?
xkevin
 
Posts: 2
Joined: 13. May 2016 04:00
XAMPP version: 7.0.5
Operating System: Windows 7

Re: mcrypt extension not working

Postby Altrea » 13. May 2016 09:10

"not working" is no helpful error reporting.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8291
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: mcrypt extension not working

Postby xkevin » 13. May 2016 09:42

extension of it was not included on xampp installation. function is not installed. I am using XAMPP for Windows version 7.0.5. Help me, the program runs smoothly on live but not on localhost.
xkevin
 
Posts: 2
Joined: 13. May 2016 04:00
XAMPP version: 7.0.5
Operating System: Windows 7

Re: mcrypt extension not working

Postby Nobbie » 13. May 2016 10:48

I have installed xampp 7.0.5 in windows and on my Installation, mcrypt is statically linked into PHP7. Run phpinfo and look for "mcrypt". Here is a screenshot of my PHP7:

Image
Nobbie
 
Posts: 8770
Joined: 09. March 2008 13:04


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 51 guests