Error 400 Bad Request! webserver

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Error 400 Bad Request! webserver

Postby bukowsky75 » 01. May 2016 19:31

Hello all,

please i need help with this issue:

Yesterday I installed Xampp 3.2.2 on my computer, my purpose is create a webserver to host my website.

I am working with the default ports, Main: 80, SSL: 443, both ports are open in my router.

So, my problem is that I can access to my website from the exterior through ssl (typing https://public-ip), but not through the main access (http://...), if i try it i get the typical error 400 Bad Request!

I have turned off my firewall, but the problem persist.

Could you someone help me?

thanks in advance! :)
bukowsky75
 
Posts: 3
Joined: 01. May 2016 19:06
XAMPP version: 3.2.2
Operating System: Windows 7

Re: Error 400 Bad Request! webserver

Postby bukowsky75 » 01. May 2016 20:41

Ok, i solved it with triggering ports!:
from my router, i made a configuration in the way that the port 443(TCP&UDP) active the port 80 (TCP&UDP), and now it works! :)
bukowsky75
 
Posts: 3
Joined: 01. May 2016 19:06
XAMPP version: 3.2.2
Operating System: Windows 7

Re: Error 400 Bad Request! webserver

Postby Altrea » 01. May 2016 20:50

1. There is no XAMPP version 3.2.2.
2. XAMPP is not made for public accessible environments.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8299
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 36 guests

cron