https://localhost works but http://localhost gives blank pag

Problems with the Windows version of XAMPP, questions, comments, and anything related.

https://localhost works but http://localhost gives blank pag

Postby marimokkori » 21. April 2016 09:35

Hi, I got interested in the D3 library and just started to learn HTML (or more like programming in general).
I installed XAMPP v3.2.2 today and set it up, and tried to access my localhost.
I have 2 questions regarding it which I would like to ask you guys for help.

First problem I have is that when I try to access the localhost,
[http://localhost] does not work and gives a blank page,
while [https://localhost] works but with a certificate error.

Now my second problem happened with my very first simple html code shown as follows.

<!doctype html>
<html>
<head>
<title>D3 tutorial </title>
<script src="http://d3js.org/d3.v3.min.js"></script>
</head>
<body>
<p>This is a paragraph</P>
<script>
d3.select("p").text("Hello World!");
</script>
</body>
</html>

With the above code, my [https://localhost/test] shows "This is a paragraph", but with a certificate error showing on the address bar.
If I click "allow all contents to show" and remove the certificate error, then "Hello world!" text shows.

Any suggestion..?
marimokkori
 
Posts: 1
Joined: 21. April 2016 09:21
XAMPP version: 3.2.2
Operating System: Windows10 64bit

Re: https://localhost works but http://localhost gives blank

Postby bukowsky75 » 01. May 2016 19:41

Hi marimokkori,

did you solved your problem?

I have got a problem very simillar, but with external connections, i mean, https://public-ip works but not http://public-ip

I hope that you have found a solution for you problem.

greetings.
bukowsky75
 
Posts: 3
Joined: 01. May 2016 19:06
XAMPP version: 3.2.2
Operating System: Windows 7


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 31 guests