Apache refuse to start

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Apache refuse to start

Postby EFORBEST » 08. April 2016 19:21

Hello,
My mobile computer just moved (without asking it to me) from Windows 7 to Windows 10
My Xampp also, but when providing to start, msql is ok, but Apache will not start
I checked Port adresses of Skype: they are not using port 80 and 443 (already changed during version Windows 7
I tried to change the port adresses, like told, but it doesn't work.
I really don't know where to look after, and ... I have to continue a website in Wordpress.
Errors Log's are ... empty.
Can someone help a lonely belgian cowboy?

Data's ofXampp:
20:05:20 [Apache] Error: Apache shutdown unexpectedly.
20:05:20 [Apache] This may be due to a blocked port, missing dependencies,
20:05:20 [Apache] improper privileges, a crash, or a shutdown by another method.
20:05:20 [Apache] Press the Logs button to view error logs and check
20:05:20 [Apache] the Windows Event Viewer for more clues
20:05:20 [Apache] If you need more help, copy and post this
20:05:20 [Apache] entire log window on the forums
EFORBEST
 
Posts: 2
Joined: 08. April 2016 18:08
Location: Belgium
XAMPP version: 3.2.2
Operating System: Windows 10

Re: Apache refuse to start

Postby lendosgirl » 08. April 2016 23:41

I don't have an answer to your question, but I am having the exact same issue, including the unwanted upgrade to Windows 10.

Apache was working fine prior to the upgrade, but will not start now. MySQL is still working fine.

After a ton of searching on the web I did find someone that suggested to run a prompt in the command line. I did so much last night, I can't remember the prompt, but it did display an error that stated that the "DocumentRoot must be a directory." This is leading me to believe that the it's a problem with the conf file, but I have no idea how to fix it.

If I find a solution I will repost here. Hopefully someone knows the fix.
lendosgirl
 
Posts: 2
Joined: 08. April 2016 23:23
XAMPP version: 3.2.2
Operating System: Windows 10

Re: Apache refuse to start

Postby EFORBEST » 11. April 2016 08:58

I thank you anyway for your help, lendosgirl
EFORBEST
 
Posts: 2
Joined: 08. April 2016 18:08
Location: Belgium
XAMPP version: 3.2.2
Operating System: Windows 10

Re: Apache refuse to start

Postby lendosgirl » 12. April 2016 03:08

Here's what I did that finally worked. I downloaded MSVC C++ runtime libraries from the microsoft website and then had to uninstall and reinstall XAMPP. Apparently this runtime library is required, but not included with the Windows 10 upgrade. Sorry, I'm a student and quite new at this, so I don't entirely understand why a runtime library is required, but it did work. The bad part was that I lost some of my MySQL databases in the process. I copied all of them, but when I tried to copy them back some of the tables were corrupted. Since I'm still a student it was just for class and did not contain any real world data, so I just rebuilt the corrupt tables, but I did have some issues.

Hope that helps.
lendosgirl
 
Posts: 2
Joined: 08. April 2016 23:23
XAMPP version: 3.2.2
Operating System: Windows 10

Re: Apache refuse to start

Postby Cadavan » 12. April 2016 07:39

lendosgirl wrote:Here's what I did that finally worked. I downloaded MSVC C++ runtime libraries from the microsoft website and then had to uninstall and reinstall XAMPP. Apparently this runtime library is required, but not included with the Windows 10 upgrade. Sorry, I'm a student and quite new at this, so I don't entirely understand why a runtime library is required, but it did work. The bad part was that I lost some of my MySQL databases in the process. I copied all of them, but when I tried to copy them back some of the tables were corrupted. Since I'm still a student it was just for class and did not contain any real world data, so I just rebuilt the corrupt tables, but I did have some issues.

Hope that helps.


I'm on a similar issue. I've repeated this solution as well, not with my actual files, but it does get it running. Some tables got corrupted as well. Is there any other way to get this to work without issues? I don't want to sacrifice my work just to make it run. Anyway, I'll be searching for solutions as well from other sites and share them here. Thanks for sharing by the way.
Cadavan
 
Posts: 1
Joined: 12. April 2016 07:31
XAMPP version: 1.7.5
Operating System: os x

Re: Apache refuse to start

Postby Altrea » 12. April 2016 07:56

There is no need to reinstall XAMPP just for the VC runtime. Just install the runtime and start the XAMPP control panel
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8294
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 63 guests