Win Server + XAMPP multisite problem

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Win Server + XAMPP multisite problem

Postby popov593 » 29. March 2016 14:24

First of all thank you for the awesome support forum you run!

Here is my problem:

My OS is Windows Server 2012 and I have installed XAMPP there.

http://localhost (on port 80) opens the Windows Server.
http://localhost:8080 opens D:\xampp\htdocs\

So I want to run multiple sites on Windows Server, and multiple sites on XAMPP (Apache).

I run a Wordpress site, which physical path is D:\xampp\htdocs\brb and so the site opens in http://localhost:8080/brb
I also have a domain, but when I set the domain settings to respond to my IP, opens http://localhost (Windows Server).

What I am trying to do is to set to open my Apache hosted http://localhost:8080/brb .

I've alredy configurated httpd-vhosts.conf with the following settings:

Code: Select all
NameVirtualHosts *:8080

<VirtualHost *:8080>
DocumentRoot "D:\XAMPP\htdocs"
ServerName localhost

<VirtualHost *:8080>
 DocumentRoot "D:\XAMPP\htdocs\brb"
 <Directory "D:\XAMPP\htdocs\brb">
Options Indexes FollowSymLinks Includes ExecCGI
Order allow,deny
 Allow from all

Any help will be highly appreciated!
User avatar
Posts: 1
Joined: 29. March 2016 14:13
Operating System: Windows

Re: Win Server + XAMPP multisite problem

Postby gsmith » 29. March 2016 21:23

I bet works.

Remember the default http port is 80 and unless you tell a browser otherwise, that is what it is going to contact the server on.
Posts: 193
Joined: 29. November 2013 18:04
Location: San Diego
XAMPP version: 0.0.0
Operating System: Win XP to 2012R2/VS 6,9,11,14

Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 53 guests