Port 80 busy, Apache wont start!

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Port 80 busy, Apache wont start!

Postby Seylione » 18. March 2016 12:41

Good morning/evening everybody,

I am trying to install XAMPP on my Windows10 system.
but Apache won't start as port 80 in use by "unable to open process" with PID4
(NT kernel & system) apparently a new 'legal holdup' by MS?

Following some advice, I tried port 8080 (in 3 places: httpd.conf > listen, httpd.conf > servername and in control panel > config > services and port settings) but this blocks Tomcat.

Which port should I use in the three locations and what other changes should I bring to make thigs work smoothly?

Thanks
Seylione
 
Posts: 3
Joined: 16. April 2013 19:51
Operating System: XP SP3, FireFox, Cable

Re: Port 80 busy, Apache wont start!

Postby Altrea » 18. March 2016 14:08

Hi,

Seylione wrote:Apache won't start as port 80 in use by "unable to open process" with PID4
(NT kernel & system) apparently a new 'legal holdup' by MS?

=> [Q&A] solving Port 80 in use by PID 4 (HTTP.sys) issue

Seylione wrote:Following some advice, I tried port 8080 (in 3 places: httpd.conf > listen, httpd.conf > servername and in control panel > config > services and port settings) but this blocks Tomcat.

Do you really need Tomcat?

Seylione wrote:Which port should I use in the three locations and what other changes should I bring to make thigs work smoothly?

a free one. ports up to 1024 are privileged, so don't use this one. Commonly ports with high numbers (32000 - 65000) are free.

best wishes,
Altrea
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8299
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 34 guests