Apache will not start on Windows 10/64 bit

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Apache will not start on Windows 10/64 bit

Postby TechByter » 17. March 2016 01:36

Hello. I'm trying to set up a testing server and have just installed XAMPP on a Windows 10 system.

Skype is running on port 80, so I changed the default port to 8080. In the process of testing, I tried several other ports, but it is now set again at 8080.

Probably unrelated: I used the default installation location (C:\xampp), but the websites are on drive E and I modified httpd.conf to:
ServerRoot "E:/WEBSITES_production/www"
Listen 8080
ServerName localhost:8080
DocumentRoot "E:/WEBSITES_production/www"
<Directory "E:/WEBSITES_production/www">

I also copied (not moved) the contents of C:\xampp\apache to E:\WEBSITES_production\www

The apache error log is empty.

Result of apache_start.bat:
Diese Eingabeforderung nicht waehrend des Running beenden
Bitte erst bei einem gewollten Shutdown schliessen
Please close this command only for Shutdown
Apache 2 is starting ...
(OS 10048)Only one usage of each socket address (protocol/network address/port) is normally permitted. : AH00072: make_sock: could not bind to address 0.0.0.0:443
AH00451: no listening sockets available, shutting down
AH00015: Unable to open logs

Apache konnte nicht gestartet werden
Apache could not be started
Press any key to continue . . .

Install log:
Installing Apache HTTP Server 2.x with
DomainName = example.com
ServerName = www.example.com
ServerAdmin = admin@example.com
ServerPort = 80
ServerSslPort = 443
ServerRoot = c:/Apache24
Rewrote docs/conf/extra/httpd-autoindex.conf.in
to c:/Apache24/conf/original/extra/httpd-autoindex.conf
Rewrote docs/conf/extra/httpd-default.conf.in
to c:/Apache24/conf/original/extra/httpd-default.conf
Rewrote docs/conf/extra/httpd-ssl.conf.in
to c:/Apache24/conf/original/extra/httpd-ssl.conf
Rewrote docs/conf/extra/httpd-multilang-errordoc.conf.in
to c:/Apache24/conf/original/extra/httpd-multilang-errordoc.conf
Rewrote docs/conf/extra/httpd-info.conf.in
to c:/Apache24/conf/original/extra/httpd-info.conf
Rewrote docs/conf/extra/httpd-userdir.conf.in
to c:/Apache24/conf/original/extra/httpd-userdir.conf
Rewrote docs/conf/extra/httpd-mpm.conf.in
to c:/Apache24/conf/original/extra/httpd-mpm.conf
Rewrote docs/conf/httpd.conf.in
to c:/Apache24/conf/original/httpd.conf
Rewrote docs/conf/extra/proxy-html.conf.in
to c:/Apache24/conf/original/extra/proxy-html.conf
Rewrote docs/conf/extra/httpd-vhosts.conf.in
to c:/Apache24/conf/original/extra/httpd-vhosts.conf
Rewrote docs/conf/extra/httpd-dav.conf.in
to c:/Apache24/conf/original/extra/httpd-dav.conf
Rewrote docs/conf/extra/httpd-languages.conf.in
to c:/Apache24/conf/original/extra/httpd-languages.conf
Rewrote docs/conf/extra/httpd-manual.conf.in
to c:/Apache24/conf/original/extra/httpd-manual.conf
Duplicated c:/Apache24/conf/original/extra/httpd-autoindex.conf
to c:/Apache24/conf/extra/httpd-autoindex.conf
Duplicated c:/Apache24/conf/original/extra/httpd-default.conf
to c:/Apache24/conf/extra/httpd-default.conf
Duplicated c:/Apache24/conf/original/extra/httpd-ssl.conf
to c:/Apache24/conf/extra/httpd-ssl.conf
Duplicated c:/Apache24/conf/original/extra/httpd-multilang-errordoc.conf
to c:/Apache24/conf/extra/httpd-multilang-errordoc.conf
Duplicated c:/Apache24/conf/original/extra/httpd-info.conf
to c:/Apache24/conf/extra/httpd-info.conf
Duplicated c:/Apache24/conf/original/extra/httpd-userdir.conf
to c:/Apache24/conf/extra/httpd-userdir.conf
Duplicated c:/Apache24/conf/original/extra/httpd-mpm.conf
to c:/Apache24/conf/extra/httpd-mpm.conf
Duplicated c:/Apache24/conf/original/httpd.conf
to c:/Apache24/conf/httpd.conf
Duplicated c:/Apache24/conf/original/magic
to c:/Apache24/conf/magic
Duplicated c:/Apache24/conf/original/charset.conv
to c:/Apache24/conf/charset.conv
Duplicated c:/Apache24/conf/original/extra/proxy-html.conf
to c:/Apache24/conf/extra/proxy-html.conf
Duplicated c:/Apache24/conf/original/extra/httpd-vhosts.conf
to c:/Apache24/conf/extra/httpd-vhosts.conf
Duplicated c:/Apache24/conf/original/extra/httpd-dav.conf
to c:/Apache24/conf/extra/httpd-dav.conf
Duplicated c:/Apache24/conf/original/mime.types
to c:/Apache24/conf/mime.types
Duplicated c:/Apache24/conf/original/extra/httpd-languages.conf
to c:/Apache24/conf/extra/httpd-languages.conf
Duplicated c:/Apache24/conf/original/extra/httpd-manual.conf
to c:/Apache24/conf/extra/httpd-manual.conf

Please let me know what additional information you need.
Thanks!
TechByter
 
Posts: 5
Joined: 17. March 2016 01:32
Operating System: Windows 10

Re: Apache will not start on Windows 10/64 bit

Postby TechByter » 17. March 2016 01:44

Further information: Following a reboot, I tried again. There's still nothing in the log, but the display was more complete:

8:41:50 PM [main] Initializing Control Panel
8:41:50 PM [main] Windows Version: Pro 64-bit
8:41:50 PM [main] XAMPP Version: 5.6.19
8:41:50 PM [main] Control Panel Version: 3.2.2 [ Compiled: Nov 12th 2015 ]
8:41:50 PM [main] You are not running with administrator rights! This will work for
8:41:50 PM [main] most application stuff but whenever you do something with services
8:41:50 PM [main] there will be a security dialogue or things will break! So think
8:41:50 PM [main] about running this application with administrator rights!
8:41:50 PM [main] XAMPP Installation Directory: "c:\xampp\"
8:41:50 PM [main] Checking for prerequisites
8:41:51 PM [main] All prerequisites found
8:41:51 PM [main] Initializing Modules
8:41:51 PM [Apache] Problem detected!
8:41:51 PM [Apache] Port 443 in use by "C:\Program Files (x86)\Skype\Phone\Skype.exe" with PID 8932!
8:41:51 PM [Apache] Apache WILL NOT start without the configured ports free!
8:41:51 PM [Apache] You need to uninstall/disable/reconfigure the blocking application
8:41:51 PM [Apache] or reconfigure Apache and the Control Panel to listen on a different port
8:41:51 PM [main] Enabling autostart for module "Apache"
8:41:51 PM [main] Enabling autostart for module "MySQL"
8:41:51 PM [main] Starting Check-Timer
8:41:51 PM [main] Control Panel Ready
8:41:51 PM [Apache] Autostart active: starting...
8:41:51 PM [Apache] Problem detected!
8:41:51 PM [Apache] Port 443 in use by "C:\Program Files (x86)\Skype\Phone\Skype.exe" with PID 8932!
8:41:51 PM [Apache] Apache WILL NOT start without the configured ports free!
8:41:51 PM [Apache] You need to uninstall/disable/reconfigure the blocking application
8:41:51 PM [Apache] or reconfigure Apache and the Control Panel to listen on a different port
8:41:51 PM [Apache] Attempting to start Apache app...
8:41:51 PM [mysql] Autostart active: starting...
8:41:51 PM [mysql] Attempting to start MySQL app...
8:41:52 PM [Apache] Status change detected: running
8:41:52 PM [mysql] Status change detected: running
8:41:59 PM [Apache] Status change detected: stopped
8:41:59 PM [Apache] Error: Apache shutdown unexpectedly.
8:41:59 PM [Apache] This may be due to a blocked port, missing dependencies,
8:41:59 PM [Apache] improper privileges, a crash, or a shutdown by another method.
8:41:59 PM [Apache] Press the Logs button to view error logs and check
8:41:59 PM [Apache] the Windows Event Viewer for more clues
8:41:59 PM [Apache] If you need more help, copy and post this
8:41:59 PM [Apache] entire log window on the forums
TechByter
 
Posts: 5
Joined: 17. March 2016 01:32
Operating System: Windows 10

Re: Apache will not start on Windows 10/64 bit

Postby TechByter » 17. March 2016 01:46

One more attempt after changing the SSL port to 4433:

8:44:22 PM [Apache] Error: Apache shutdown unexpectedly.
8:44:22 PM [Apache] This may be due to a blocked port, missing dependencies,
8:44:22 PM [Apache] improper privileges, a crash, or a shutdown by another method.
8:44:22 PM [Apache] Press the Logs button to view error logs and check
8:44:22 PM [Apache] the Windows Event Viewer for more clues
8:44:22 PM [Apache] If you need more help, copy and post this
8:44:22 PM [Apache] entire log window on the forums
8:45:19 PM [mysql] Attempting to stop MySQL app...
8:45:21 PM [mysql] Status change detected: stopped
8:45:22 PM [Apache] Attempting to start Apache app...
8:45:22 PM [Apache] Status change detected: running
8:45:23 PM [Apache] Status change detected: stopped
8:45:23 PM [Apache] Error: Apache shutdown unexpectedly.
8:45:23 PM [Apache] This may be due to a blocked port, missing dependencies,
8:45:23 PM [Apache] improper privileges, a crash, or a shutdown by another method.
8:45:23 PM [Apache] Press the Logs button to view error logs and check
8:45:23 PM [Apache] the Windows Event Viewer for more clues
8:45:23 PM [Apache] If you need more help, copy and post this
8:45:23 PM [Apache] entire log window on the forums
TechByter
 
Posts: 5
Joined: 17. March 2016 01:32
Operating System: Windows 10

Re: Apache will not start on Windows 10/64 bit

Postby TechByter » 17. March 2016 01:50

Final follow-up for this evening. Running as Administrator:

8:48:31 PM [main] Initializing Control Panel
8:48:31 PM [main] Windows Version: Pro 64-bit
8:48:31 PM [main] XAMPP Version: 5.6.19
8:48:31 PM [main] Control Panel Version: 3.2.2 [ Compiled: Nov 12th 2015 ]
8:48:31 PM [main] Running with Administrator rights - good!
8:48:31 PM [main] XAMPP Installation Directory: "c:\xampp\"
8:48:31 PM [main] Checking for prerequisites
8:48:31 PM [main] All prerequisites found
8:48:31 PM [main] Initializing Modules
8:48:31 PM [main] Enabling autostart for module "Apache"
8:48:31 PM [main] Enabling autostart for module "MySQL"
8:48:31 PM [main] Starting Check-Timer
8:48:31 PM [main] Control Panel Ready
8:48:31 PM [Apache] Autostart active: starting...
8:48:31 PM [Apache] Attempting to start Apache app...
8:48:31 PM [mysql] Autostart active: starting...
8:48:31 PM [mysql] Attempting to start MySQL app...
8:48:32 PM [Apache] Status change detected: running
8:48:32 PM [mysql] Status change detected: running
8:48:32 PM [Apache] Status change detected: stopped
8:48:32 PM [Apache] Error: Apache shutdown unexpectedly.
8:48:32 PM [Apache] This may be due to a blocked port, missing dependencies,
8:48:32 PM [Apache] improper privileges, a crash, or a shutdown by another method.
8:48:32 PM [Apache] Press the Logs button to view error logs and check
8:48:32 PM [Apache] the Windows Event Viewer for more clues
8:48:32 PM [Apache] If you need more help, copy and post this
8:48:32 PM [Apache] entire log window on the forums
8:48:38 PM [mysql] Attempting to stop MySQL app...
8:48:40 PM [mysql] Status change detected: stopped
8:48:42 PM [Apache] Attempting to start Apache app...
8:48:42 PM [Apache] Status change detected: running
8:48:43 PM [Apache] Status change detected: stopped
8:48:43 PM [Apache] Error: Apache shutdown unexpectedly.
8:48:43 PM [Apache] This may be due to a blocked port, missing dependencies,
8:48:43 PM [Apache] improper privileges, a crash, or a shutdown by another method.
8:48:43 PM [Apache] Press the Logs button to view error logs and check
8:48:43 PM [Apache] the Windows Event Viewer for more clues
8:48:43 PM [Apache] If you need more help, copy and post this
8:48:43 PM [Apache] entire log window on the forums
8:48:49 PM [mysql] Attempting to start MySQL app...
8:48:49 PM [mysql] Status change detected: running
TechByter
 
Posts: 5
Joined: 17. March 2016 01:32
Operating System: Windows 10

Re: Apache will not start on Windows 10/64 bit

Postby Altrea » 17. March 2016 07:39

Hi,

TechByter wrote:Skype is running on port 80, so I changed the default port to 8080.

Why? You can tell Skype not to use these ports: [Q&A] solving Port 80 & 443 in use by Skype issue

Please rerun apache_start.bat and tell us the results.

best wishes,
Altrea
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8294
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: Apache will not start on Windows 10/64 bit

Postby TechByter » 17. March 2016 22:55

Well, that's pretty embarrassing. I closed Skype and Apache launched properly. So I set Apache back to port 80 and all was well. After setting Skype not to use port 80 and rebooting, Apache continued to run properly. Conclusion: I am an idiot.

Everything is working as expected now. :roll:
TechByter
 
Posts: 5
Joined: 17. March 2016 01:32
Operating System: Windows 10


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 47 guests