apache not run

Problems with the Windows version of XAMPP, questions, comments, and anything related.

apache not run

Postby italo_pm » 09. March 2016 15:01

Hi all... i used in my usb disk (letter I:) a xampp app... i change my usb disk... apache have a problem to run... this is a log when a open xampp control panel:

14.54.21 [main] Initializing Control Panel
14.54.21 [main] Windows Version: Windows 7 Enterprise SP1 64-bit
14.54.21 [main] XAMPP Version: 5.6.14
14.54.21 [main] Control Panel Version: 3.2.1 [ Compiled: May 7th 2013 ]
14.54.21 [main] Running with Administrator rights - good!
14.54.21 [main] XAMPP Installation Directory: "j:\xampp\"
14.54.21 [main] Checking for prerequisites
14.54.21 [main] All prerequisites found
14.54.21 [main] Initializing Modules
14.54.21 [Apache] Apache Service detected with wrong path
14.54.21 [Apache] Change XAMPP Apache and Control Panel settings or
14.54.21 [Apache] Uninstall/disable the other service manually first
14.54.21 [Apache] Found Path: "I:\xampp\apache\bin\httpd.exe" -k runservice
14.54.21 [Apache] Expected Path: "j:\xampp\apache\bin\httpd.exe" -k runservice
14.54.21 [Apache] XAMPP Apache is already running on port 80
14.54.21 [Apache] XAMPP Apache is already running on port 443
14.54.21 [main] The FileZilla module is disabled
14.54.21 [main] The Mercury module is disabled
14.54.21 [Tomcat] Tomcat Service detected with wrong path
14.54.21 [Tomcat] Change XAMPP Tomcat and Control Panel settings or
14.54.21 [Tomcat] Uninstall/disable the other service manually first
14.54.21 [Tomcat] Found Path: I:\xampp\tomcat\bin\tomcat7.exe //RS//Tomcat7
14.54.21 [Tomcat] Expected Path: j:\xampp\tomcat\bin\tomcat7.exe //RS//Tomcat7
14.54.21 [main] Starting Check-Timer
14.54.21 [main] Control Panel Ready


in the windows services apache2.4

description property: Apache/2.4.17 (Win32) OpenSSL/1.0.2d PHP/5.6.14
patch to execute: "I:\xampp\apache\bin\httpd.exe" -k runservice

but now the letter is J: not I: (old letter from usb disk)

how to fix the letter J with I ???

thanks.

Italo
italo_pm
 
Posts: 1
Joined: 09. March 2016 14:52
Operating System: win 64

Re: apache not run

Postby Altrea » 09. March 2016 17:59

Hi,

Best practice for using XAMPP from an USB Device: Don't use Windows Services to start the components. Windows services are drive letter dependend and usb devices can change it's letter.

So unregister the Windows services and start the components with help of the control panel.

best wishes,
Altrea
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8290
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 36 guests