Apache can't start after XAMPP installation

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Apache can't start after XAMPP installation

Postby sbacho » 23. February 2016 16:06

I have downloaded XAMPP latest version and installed it successfully but cannot use it.
Because Apache refuses to start.

I see the following messages in the control panel.

16:48:25 [main] Initializing Control Panel
16:48:25 [main] Windows Version: Windows 7 Professional SP1 64-bit
16:48:25 [main] XAMPP Version: 5.6.15
16:48:25 [main] Control Panel Version: 3.2.2 [ Compiled: Nov 12th 2015 ]
16:48:25 [main] Running with Administrator rights - good!
16:48:25 [main] XAMPP Installation Directory: "d:\xampp\"
16:48:25 [main] Checking for prerequisites
16:48:25 [main] All prerequisites found
16:48:25 [main] Initializing Modules
16:48:25 [main] Starting Check-Timer
16:48:25 [main] Control Panel Ready
16:48:27 [Apache] Attempting to start Apache app...
16:48:27 [Apache] Status change detected: running
16:48:28 [Apache] Status change detected: stopped
16:48:28 [Apache] Error: Apache shutdown unexpectedly.
16:48:28 [Apache] This may be due to a blocked port, missing dependencies,
16:48:28 [Apache] improper privileges, a crash, or a shutdown by another method.
16:48:28 [Apache] Press the Logs button to view error logs and check
16:48:28 [Apache] the Windows Event Viewer for more clues
16:48:28 [Apache] If you need more help, copy and post this
16:48:28 [Apache] entire log window on the forums

I run XAMPP under administrator rights.
Also i have tried to change the Main and SSSL ports for Apache but it do lead to success.
Also I tried to find some information in log files about this issue but without success:
- Apache access and error logs seems do not exist at all
- and I cannot find any records for this issue in Windows logs.

Please, help to solve the problem.
sbacho
 
Posts: 5
Joined: 23. February 2016 15:52
Operating System: Windows 7 Prof 64-bit

Re: Apache can't start after XAMPP installation

Postby Altrea » 23. February 2016 16:13

We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8298
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: Apache can't start after XAMPP installation

Postby sbacho » 23. February 2016 16:28

Thank You for the answer.

I have already saw this post (=> viewtopic.php?f=16&t=72518#p247610).

As I understood from this post it's necessary to switch for more detailed logging to see what can be the problem and such to solve this issue? It is true?

But I did not understand how I can switch more detailed logging.
I understood that it is necessary to change somehow apache_start.bat? But how?
What changes it is necessary to make in this file to switch on a more detailed logging?
sbacho
 
Posts: 5
Joined: 23. February 2016 15:52
Operating System: Windows 7 Prof 64-bit

Re: Apache can't start after XAMPP installation

Postby Altrea » 23. February 2016 16:37

You don't need to change apache_start.bat, you need to execute it by double click and tell us what it responses.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8298
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: Apache can't start after XAMPP installation

Postby sbacho » 23. February 2016 16:55

Here the response:
"
D:\xampp>apache_start.bat
Diese Eingabeforderung nicht waehrend des Running beenden
Bitte erst bei einem gewollten Shutdown schliessen
Please close this command only for Shutdown
Apache 2 is starting ...
(OS 10013)An attempt was made to access a socket in a way forbidden by its acces
s permissions. : AH00072: make_sock: could not bind to address [::]:80
(OS 10013)An attempt was made to access a socket in a way forbidden by its acces
s permissions. : AH00072: make_sock: could not bind to address 0.0.0.0:80
AH00451: no listening sockets available, shutting down
AH00015: Unable to open logs

Apache konnte nicht gestartet werden
Apache could not be started
Press any key to continue . . .
D:\xampp>

"
sbacho
 
Posts: 5
Joined: 23. February 2016 15:52
Operating System: Windows 7 Prof 64-bit

Re: Apache can't start after XAMPP installation

Postby sbacho » 23. February 2016 16:59

Also I have restarted the XAMPP control panel.
I receive the following message in control pane:
"
17:49:18 [main] Initializing Modules
17:49:18 [Apache] Problem detected!
17:49:18 [Apache] Port 80 in use by "Unable to open process" with PID 4!
17:49:18 [Apache] Apache WILL NOT start without the configured ports free!
17:49:18 [Apache] You need to uninstall/disable/reconfigure the blocking application
17:49:18 [Apache] or reconfigure Apache and the Control Panel to listen on a different port
17:49:18 [main] Starting Check-Timer
17:49:18 [main] Control Panel Ready

"
sbacho
 
Posts: 5
Joined: 23. February 2016 15:52
Operating System: Windows 7 Prof 64-bit

Re: Apache can't start after XAMPP installation

Postby Altrea » 23. February 2016 17:53

sbacho wrote:(OS 10013)An attempt was made to access a socket in a way forbidden by its acces
s permissions. : AH00072: make_sock: could not bind to address [::]:80

There is already a process ocupying port 80.
[Q&A] solving Port 80 in use by PID 4 (HTTP.sys) issue
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8298
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: Apache can't start after XAMPP installation

Postby sbacho » 23. February 2016 19:08

Thank You :D

I disabled IIS and Apache has started.
sbacho
 
Posts: 5
Joined: 23. February 2016 15:52
Operating System: Windows 7 Prof 64-bit


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 51 guests

cron