Apache starts then immediately crashes Windows 10

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Apache starts then immediately crashes Windows 10

Postby Ophilias » 06. February 2016 02:40

Here is the control panel output:

5:32:35 PM [main] Initializing Control Panel
5:32:35 PM [main] Windows Version: Pro 64-bit
5:32:35 PM [main] XAMPP Version: 5.6.15
5:32:35 PM [main] Control Panel Version: 3.2.2 [ Compiled: Nov 12th 2015 ]
5:32:35 PM [main] Running with Administrator rights - good!
5:32:35 PM [main] XAMPP Installation Directory: "c:\xampp\"
5:32:35 PM [main] Checking for prerequisites
5:32:35 PM [main] All prerequisites found
5:32:35 PM [main] Initializing Modules
5:32:35 PM [mysql] XAMPP MySQL Service is already running on port 3306
5:32:35 PM [main] Enabling autostart for module "Apache"
5:32:35 PM [main] Enabling autostart for module "MySQL"
5:32:35 PM [main] Starting Check-Timer
5:32:35 PM [main] Control Panel Ready
5:32:36 PM [Apache] Autostart active: starting...
5:32:36 PM [Apache] Attempting to start Apache service...
5:32:37 PM [Apache] Status change detected: running
5:32:37 PM [mysql] Autostart aborted: MySQL is already running
5:32:38 PM [Apache] Status change detected: stopped
5:32:38 PM [Apache] Error: Apache shutdown unexpectedly.
5:32:38 PM [Apache] This may be due to a blocked port, missing dependencies,
5:32:38 PM [Apache] improper privileges, a crash, or a shutdown by another method.
5:32:38 PM [Apache] Press the Logs button to view error logs and check
5:32:38 PM [Apache] the Windows Event Viewer for more clues
5:32:38 PM [Apache] If you need more help, copy and post this
5:32:38 PM [Apache] entire log window on the forums

And here is the error log (sorry if this is excessive information, figured the full file is better than just most recent failure):

[Fri Feb 05 17:14:05.250251 2016] [ssl:warn] [pid 9688:tid 564] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Fri Feb 05 17:14:05.366351 2016] [ssl:warn] [pid 9688:tid 564] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Fri Feb 05 17:14:05.589076 2016] [mpm_winnt:notice] [pid 9688:tid 564] AH00455: Apache/2.4.17 (Win32) OpenSSL/1.0.2d PHP/5.6.15 configured -- resuming normal operations
[Fri Feb 05 17:14:05.589076 2016] [mpm_winnt:notice] [pid 9688:tid 564] AH00456: Apache Lounge VC11 Server built: Oct 13 2015 10:54:13
[Fri Feb 05 17:14:05.589076 2016] [core:notice] [pid 9688:tid 564] AH00094: Command line: 'C:\\xampp\\apache\\bin\\httpd.exe -d C:/xampp/apache'
[Fri Feb 05 17:14:05.589076 2016] [mpm_winnt:notice] [pid 9688:tid 564] AH00418: Parent: Created child process 11164
[Fri Feb 05 17:14:06.020938 2016] [ssl:warn] [pid 11164:tid 540] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Fri Feb 05 17:14:06.120746 2016] [ssl:warn] [pid 11164:tid 540] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Fri Feb 05 17:14:06.152005 2016] [mpm_winnt:crit] [pid 11164:tid 540] (OS 109)The pipe has been ended. : AH00404: Child: Unable to read socket data from parent
[Fri Feb 05 17:14:06.167624 2016] [mpm_winnt:crit] [pid 9688:tid 564] AH00427: Parent: child process 11164 exited with status 3 -- Aborting.
[Fri Feb 05 17:16:26.352778 2016] [ssl:warn] [pid 8240:tid 632] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Fri Feb 05 17:16:26.468667 2016] [ssl:warn] [pid 8240:tid 632] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Fri Feb 05 17:16:26.499924 2016] [mpm_winnt:notice] [pid 8240:tid 632] AH00455: Apache/2.4.17 (Win32) OpenSSL/1.0.2d PHP/5.6.15 configured -- resuming normal operations
[Fri Feb 05 17:16:26.499924 2016] [mpm_winnt:notice] [pid 8240:tid 632] AH00456: Apache Lounge VC11 Server built: Oct 13 2015 10:54:13
[Fri Feb 05 17:16:26.499924 2016] [core:notice] [pid 8240:tid 632] AH00094: Command line: 'C:\\xampp\\apache\\bin\\httpd.exe -d C:/xampp/apache'
[Fri Feb 05 17:16:26.515546 2016] [mpm_winnt:notice] [pid 8240:tid 632] AH00418: Parent: Created child process 7956
[Fri Feb 05 17:16:26.922563 2016] [ssl:warn] [pid 7956:tid 552] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Fri Feb 05 17:16:27.038451 2016] [ssl:warn] [pid 7956:tid 552] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Fri Feb 05 17:16:27.069708 2016] [mpm_winnt:crit] [pid 7956:tid 552] (OS 109)The pipe has been ended. : AH00404: Child: Unable to read socket data from parent
[Fri Feb 05 17:16:27.085329 2016] [mpm_winnt:crit] [pid 8240:tid 632] AH00427: Parent: child process 7956 exited with status 3 -- Aborting.
[Fri Feb 05 17:32:21.011201 2016] [ssl:warn] [pid 3656:tid 604] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Fri Feb 05 17:32:21.127088 2016] [ssl:warn] [pid 3656:tid 604] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Fri Feb 05 17:32:21.158341 2016] [mpm_winnt:notice] [pid 3656:tid 604] AH00455: Apache/2.4.17 (Win32) OpenSSL/1.0.2d PHP/5.6.15 configured -- resuming normal operations
[Fri Feb 05 17:32:21.158341 2016] [mpm_winnt:notice] [pid 3656:tid 604] AH00456: Apache Lounge VC11 Server built: Oct 13 2015 10:54:13
[Fri Feb 05 17:32:21.158341 2016] [core:notice] [pid 3656:tid 604] AH00094: Command line: 'C:\\xampp\\apache\\bin\\httpd.exe -d C:/xampp/apache'
[Fri Feb 05 17:32:21.158341 2016] [mpm_winnt:notice] [pid 3656:tid 604] AH00418: Parent: Created child process 10468
[Fri Feb 05 17:32:21.582130 2016] [ssl:warn] [pid 10468:tid 516] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Fri Feb 05 17:32:21.681437 2016] [ssl:warn] [pid 10468:tid 516] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Fri Feb 05 17:32:21.712693 2016] [mpm_winnt:crit] [pid 10468:tid 516] (OS 109)The pipe has been ended. : AH00404: Child: Unable to read socket data from parent
[Fri Feb 05 17:32:21.728319 2016] [mpm_winnt:crit] [pid 3656:tid 604] AH00427: Parent: child process 10468 exited with status 3 -- Aborting.
[Fri Feb 05 17:32:36.954931 2016] [ssl:warn] [pid 1296:tid 604] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Fri Feb 05 17:32:37.070451 2016] [ssl:warn] [pid 1296:tid 604] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Fri Feb 05 17:32:37.102717 2016] [mpm_winnt:notice] [pid 1296:tid 604] AH00455: Apache/2.4.17 (Win32) OpenSSL/1.0.2d PHP/5.6.15 configured -- resuming normal operations
[Fri Feb 05 17:32:37.102717 2016] [mpm_winnt:notice] [pid 1296:tid 604] AH00456: Apache Lounge VC11 Server built: Oct 13 2015 10:54:13
[Fri Feb 05 17:32:37.102717 2016] [core:notice] [pid 1296:tid 604] AH00094: Command line: 'C:\\xampp\\apache\\bin\\httpd.exe -d C:/xampp/apache'
[Fri Feb 05 17:32:37.104713 2016] [mpm_winnt:notice] [pid 1296:tid 604] AH00418: Parent: Created child process 8124
[Fri Feb 05 17:32:37.519263 2016] [ssl:warn] [pid 8124:tid 528] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Fri Feb 05 17:32:37.619519 2016] [ssl:warn] [pid 8124:tid 528] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Fri Feb 05 17:32:37.650775 2016] [mpm_winnt:crit] [pid 8124:tid 528] (OS 109)The pipe has been ended. : AH00404: Child: Unable to read socket data from parent
[Fri Feb 05 17:32:37.650775 2016] [mpm_winnt:crit] [pid 1296:tid 604] AH00427: Parent: child process 8124 exited with status 3 -- Aborting.


Originally, was having issues with running on port 80, was able to follow instructions on the Q&A for Apache and got it past that issue. Then it went to the non-informative general issue statement. I am running as Admin, so I don't think that is the issue. Any help people can give is much appreciated. :-) I hope I'm not just missing something obvious here, just started using this stuff.
Ophilias
 
Posts: 1
Joined: 06. February 2016 02:29
Operating System: Windows 10

Re: Apache starts then immediately crashes Windows 10

Postby Dave P » 19. February 2016 03:43

Help I am having the same problem.
1:40:58 PM [main] Initializing Control Panel
1:40:58 PM [main] Windows Version: Home 64-bit
1:40:58 PM [main] XAMPP Version: 5.6.15
1:40:58 PM [main] Control Panel Version: 3.2.2 [ Compiled: Nov 12th 2015 ]
1:40:58 PM [main] Running with Administrator rights - good!
1:40:58 PM [main] XAMPP Installation Directory: "c:\xampp\"
1:40:58 PM [main] Checking for prerequisites
1:40:58 PM [main] All prerequisites found
1:40:58 PM [main] Initializing Modules
1:40:58 PM [mysql] XAMPP MySQL is already running on port 3306
1:40:58 PM [main] Enabling autostart for module "Apache"
1:40:58 PM [main] Enabling autostart for module "MySQL"
1:40:58 PM [main] Starting Check-Timer
1:40:58 PM [main] Control Panel Ready
1:40:58 PM [Apache] Autostart active: starting...
1:40:58 PM [Apache] Attempting to start Apache app...
1:40:58 PM [mysql] Autostart aborted: MySQL is already running
1:40:59 PM [Apache] Status change detected: running
1:41:00 PM [Apache] Status change detected: stopped
1:41:00 PM [Apache] Error: Apache shutdown unexpectedly.
1:41:00 PM [Apache] This may be due to a blocked port, missing dependencies,
1:41:00 PM [Apache] improper privileges, a crash, or a shutdown by another method.
1:41:00 PM [Apache] Press the Logs button to view error logs and check
1:41:00 PM [Apache] the Windows Event Viewer for more clues
1:41:00 PM [Apache] If you need more help, copy and post this
1:41:00 PM [Apache] entire log window on the forums
Looks like it is something with Windows 10.
Getting very frustrated.
Dave
Dave P
 
Posts: 1
Joined: 16. February 2016 04:56
Operating System: Windows 10

Re: Apache starts then immediately crashes Windows 10

Postby isobelg » 29. February 2016 23:49

I'm a complete newb and I'm having the exact same problem. Originally I was having a different problem and followed the advice on here: https://community.apachefriends.org/f/viewtopic.php?f=22&t=69784&p=239058#p239059, applying the fix titled "Configure HTTP.sys to only bind to IPv6" and now I can't use google chrome.

So I need help with the same issue Ophilius has described AND if anyone knows how I can make Chrome open up, it would be perfect!
isobelg
 
Posts: 1
Joined: 29. February 2016 23:14
Operating System: Windows 10

Re: Apache starts then immediately crashes Windows 10

Postby Altrea » 01. March 2016 03:40

If you think your problems with Chrome are caused by this change you made than you can simply delete the entry with the command
Code: Select all
netsh http delete iplisten ipaddress=::
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8293
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 85 guests