Apache Stopped Working

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Apache Stopped Working

Postby Julie_R » 24. January 2016 23:37

Hello,

I am working on a Wordpress website and the xampp server just stopped working and I have no idea why.

The Error message on Apache:

[Sun Jan 24 17:01:20.441337 2016] [ssl:warn] [pid 4120:tid 364] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Sun Jan 24 17:01:21.257384 2016] [ssl:warn] [pid 4120:tid 364] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Sun Jan 24 17:01:22.887477 2016] [mpm_winnt:notice] [pid 4120:tid 364] AH00455: Apache/2.4.10 (Win32) OpenSSL/1.0.1i PHP/5.6.3 configured -- resuming normal operations
[Sun Jan 24 17:01:22.887477 2016] [mpm_winnt:notice] [pid 4120:tid 364] AH00456: Apache Lounge VC11 Server built: Jul 17 2014 11:50:08
[Sun Jan 24 17:01:22.887477 2016] [core:notice] [pid 4120:tid 364] AH00094: Command line: 'C:\\xampp\\apache\\bin\\httpd.exe -d C:/xampp/apache'
[Sun Jan 24 17:01:22.893478 2016] [mpm_winnt:notice] [pid 4120:tid 364] AH00418: Parent: Created child process 1572
[Sun Jan 24 17:01:25.987655 2016] [ssl:warn] [pid 1572:tid 264] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Sun Jan 24 17:01:26.521685 2016] [ssl:warn] [pid 1572:tid 264] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Sun Jan 24 17:01:26.677694 2016] [mpm_winnt:notice] [pid 1572:tid 264] AH00354: Child: Starting 150 worker threads.
[Sun Jan 24 22:19:09.380437 2016] [core:error] [pid 1572:tid 1664] [client ::1:58293] AH00124: Request exceeded the limit of 10 internal redirects due to probable configuration error. Use 'LimitInternalRecursion' to increase the limit if necessary. Use 'LogLevel debug' to get a backtrace.
[Sun Jan 24 22:19:09.458437 2016] [core:error] [pid 1572:tid 1664] [client ::1:58293] AH00124: Request exceeded the limit of 10 internal redirects due to probable configuration error. Use 'LimitInternalRecursion' to increase the limit if necessary. Use 'LogLevel debug' to get a backtrace.
[Sun Jan 24 22:22:27.931634 2016] [core:error] [pid 1572:tid 1652] [client ::1:58363] AH00124: Request exceeded the limit of 10 internal redirects due to probable configuration error. Use 'LimitInternalRecursion' to increase the limit if necessary. Use 'LogLevel debug' to get a backtrace.
[Sun Jan 24 22:22:27.931634 2016] [core:error] [pid 1572:tid 1652] [client ::1:58363] AH00124: Request exceeded the limit of 10 internal redirects due to probable configuration error. Use 'LimitInternalRecursion' to increase the limit if necessary. Use 'LogLevel debug' to get a backtrace.

The MySQL error log is:
2016-01-24 17:01:13 504 [Note] Plugin 'FEDERATED' is disabled.
2016-01-24 17:01:13 fec InnoDB: Warning: Using innodb_additional_mem_pool_size is DEPRECATED. This option may be removed in future releases, together with the option innodb_use_sys_malloc and with the InnoDB's internal memory allocator.
2016-01-24 17:01:13 504 [Note] InnoDB: Using atomics to ref count buffer pool pages
2016-01-24 17:01:13 504 [Note] InnoDB: The InnoDB memory heap is disabled
2016-01-24 17:01:13 504 [Note] InnoDB: Mutexes and rw_locks use Windows interlocked functions
2016-01-24 17:01:13 504 [Note] InnoDB: Memory barrier is not used
2016-01-24 17:01:13 504 [Note] InnoDB: Compressed tables use zlib 1.2.3
2016-01-24 17:01:13 504 [Note] InnoDB: Not using CPU crc32 instructions
2016-01-24 17:01:13 504 [Note] InnoDB: Initializing buffer pool, size = 16.0M
2016-01-24 17:01:13 504 [Note] InnoDB: Completed initialization of buffer pool
2016-01-24 17:01:14 504 [Note] InnoDB: Highest supported file format is Barracuda.
2016-01-24 17:01:26 504 [Note] InnoDB: 128 rollback segment(s) are active.
2016-01-24 17:01:26 504 [Note] InnoDB: Waiting for purge to start
2016-01-24 17:01:26 504 [Note] InnoDB: 5.6.21 started; log sequence number 19708260
2016-01-24 17:01:27 504 [Note] Server hostname (bind-address): '*'; port: 3306
2016-01-24 17:01:27 504 [Note] IPv6 is available.
2016-01-24 17:01:27 504 [Note] - '::' resolves to '::';
2016-01-24 17:01:27 504 [Note] Server socket created on IP: '::'.
2016-01-24 17:01:29 504 [Note] Event Scheduler: Loaded 0 events
2016-01-24 17:01:29 504 [Note] C:\xampp\mysql\bin\mysqld.exe: ready for connections.
Version: '5.6.21' socket: '' port: 3306 MySQL Community Server (GPL)

I hope you can help with this.
Julie_R
 
Posts: 5
Joined: 22. January 2016 12:25
Operating System: Windows

Re: Apache Stopped Working

Postby Nobbie » 25. January 2016 10:58

You seems to have an error in .htaccess file or similar, see this error message:

AH00124: Request exceeded the limit of 10 internal redirects due to probable configuration error. Use 'LimitInternalRecursion' to increase the limit if necessary. Use 'LogLevel debug' to get a backtrace.


This usually results from an infinite redirection, which redirects once and once again, until Apache crashes. You have to find out if you changed anything to your installation, which could cause that problem.
Nobbie
 
Posts: 8775
Joined: 09. March 2008 13:04

Re: Apache Stopped Working

Postby Julie_R » 25. January 2016 11:23

Thanks Nobbie,

I have only basic knowledge of Apache.

I was working on a Wordpress theme at the time.

How can I find out if I changed anything to the installation?

Really appreciate any help with this.
Julie_R
 
Posts: 5
Joined: 22. January 2016 12:25
Operating System: Windows

Re: Apache Stopped Working

Postby Nobbie » 25. January 2016 13:45

Sorry, i dont know WordPress. I could only give you a hint about that error message. Maybe there is an error in WordPress.
Nobbie
 
Posts: 8775
Joined: 09. March 2008 13:04

Re: Apache Stopped Working

Postby Julie_R » 26. January 2016 00:08

Yes it turned out to be a WordPress error.
Julie_R
 
Posts: 5
Joined: 22. January 2016 12:25
Operating System: Windows


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 76 guests