APACHE ERRORS WHEN LOADING XAMPP

Problems with the Windows version of XAMPP, questions, comments, and anything related.

APACHE ERRORS WHEN LOADING XAMPP

Postby MAG » 04. January 2016 00:39

Hi,
Happy New Year !!!
Here what appears when the xampp control panel v3.2.2 opens in my pc windows8.1 :
I do not understand as I am the only one to use the pc and I have administrator rights. And I do not know what I can do if the pc does not recognize it. I do not have any password and I regularly install a number of programs. Could you tell me what happens and what I should do to make it works ?
Many thanks in advance.

MESSAGES APPEARING WHEN THE CONTROL BOARD APPEARS JUST AFTER EXECUTING XAMPP :

23:14:54 [main] Initializing Control Panel
23:14:54 [main] Windows Version: Windows 8.1 64-bit
23:14:54 [main] XAMPP Version: 5.6.15
23:14:54 [main] Control Panel Version: 3.2.2 [ Compiled: Nov 12th 2015 ]
23:14:54 [main] You are not running with administrator rights! This will work for
23:14:54 [main] most application stuff but whenever you do something with services
23:14:54 [main] there will be a security dialogue or things will break! So think
23:14:54 [main] about running this application with administrator rights!
23:14:54 [main] XAMPP Installation Directory: "c:\xampp\"
23:14:54 [main] Checking for prerequisites
23:15:43 [main] All prerequisites found
23:15:43 [main] Initializing Modules
23:15:44 [Apache] Problem detected!
23:15:44 [Apache] Port 80 in use by "Unable to open process" with PID 3884!
23:15:44 [Apache] Apache WILL NOT start without the configured ports free!
23:15:44 [Apache] You need to uninstall/disable/reconfigure the blocking application
23:15:44 [Apache] or reconfigure Apache and the Control Panel to listen on a different port
23:15:44 [Apache] Problem detected!
23:15:44 [Apache] Port 443 in use by "Unable to open process" with PID 3884!
23:15:44 [Apache] Apache WILL NOT start without the configured ports free!
23:15:44 [Apache] You need to uninstall/disable/reconfigure the blocking application
23:15:44 [Apache] or reconfigure Apache and the Control Panel to listen on a different port
23:15:44 [main] Starting Check-Timer
23:15:44 [main] Control Panel Ready

Error log :
[Sun Jan 03 23:13:10.589169 2016] [ssl:warn] [pid 3884:tid 400] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Sun Jan 03 23:13:11.011672 2016] [ssl:warn] [pid 3884:tid 400] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Sun Jan 03 23:13:12.199226 2016] [mpm_winnt:notice] [pid 3884:tid 400] AH00455: Apache/2.4.17 (Win32) OpenSSL/1.0.2d PHP/5.6.15 configured -- resuming normal operations
[Sun Jan 03 23:13:12.199226 2016] [mpm_winnt:notice] [pid 3884:tid 400] AH00456: Apache Lounge VC11 Server built: Oct 13 2015 10:54:13
[Sun Jan 03 23:13:12.199226 2016] [core:notice] [pid 3884:tid 400] AH00094: Command line: 'C:\\xampp\\apache\\bin\\httpd.exe -d C:/xampp/apache'
[Sun Jan 03 23:13:12.214852 2016] [mpm_winnt:notice] [pid 3884:tid 400] AH00418: Parent: Created child process 7232
[Sun Jan 03 23:13:13.840195 2016] [ssl:warn] [pid 7232:tid 420] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Sun Jan 03 23:13:14.302951 2016] [ssl:warn] [pid 7232:tid 420] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Sun Jan 03 23:13:14.442048 2016] [mpm_winnt:notice] [pid 7232:tid 420] AH00354: Child: Starting 150 worker threads.


MySQL is green, it seems ok.

AND WHEN I CLICK ON START ON THE APACHE LINE, I GET :

23:14:54 [main] Initializing Control Panel
23:14:54 [main] Windows Version: Windows 8.1 64-bit
23:14:54 [main] XAMPP Version: 5.6.15
23:14:54 [main] Control Panel Version: 3.2.2 [ Compiled: Nov 12th 2015 ]
23:14:54 [main] You are not running with administrator rights! This will work for
23:14:54 [main] most application stuff but whenever you do something with services
23:14:54 [main] there will be a security dialogue or things will break! So think
23:14:54 [main] about running this application with administrator rights!
23:14:54 [main] XAMPP Installation Directory: "c:\xampp\"
23:14:54 [main] Checking for prerequisites
23:15:43 [main] All prerequisites found
23:15:43 [main] Initializing Modules
23:15:44 [Apache] Problem detected!
23:15:44 [Apache] Port 80 in use by "Unable to open process" with PID 3884!
23:15:44 [Apache] Apache WILL NOT start without the configured ports free!
23:15:44 [Apache] You need to uninstall/disable/reconfigure the blocking application
23:15:44 [Apache] or reconfigure Apache and the Control Panel to listen on a different port
23:15:44 [Apache] Problem detected!
23:15:44 [Apache] Port 443 in use by "Unable to open process" with PID 3884!
23:15:44 [Apache] Apache WILL NOT start without the configured ports free!
23:15:44 [Apache] You need to uninstall/disable/reconfigure the blocking application
23:15:44 [Apache] or reconfigure Apache and the Control Panel to listen on a different port
23:15:44 [main] Starting Check-Timer
23:15:44 [main] Control Panel Ready
23:23:17 [main] Executing "c:\xampp\apache\logs"
23:47:05 [mysql] Attempting to start MySQL app...
23:47:05 [mysql] Status change detected: running
23:47:42 [mysql] Attempting to stop MySQL app...
23:47:45 [mysql] Status change detected: stopped
23:47:49 [mysql] Attempting to start MySQL app...
23:47:50 [mysql] Status change detected: running
23:48:08 [mysql] Attempting to stop MySQL app...
23:48:10 [mysql] Status change detected: stopped
23:48:13 [mysql] Attempting to start MySQL app...
23:48:13 [mysql] Status change detected: running
23:48:29 [mysql] Attempting to stop MySQL app...
23:48:31 [mysql] Status change detected: stopped
23:48:52 [mysql] Attempting to start MySQL app...
23:48:53 [mysql] Status change detected: running
23:49:41 [Apache] Problem detected!
23:49:41 [Apache] Port 80 in use by "Unable to open process" with PID 3884!
23:49:41 [Apache] Apache WILL NOT start without the configured ports free!
23:49:41 [Apache] You need to uninstall/disable/reconfigure the blocking application
23:49:41 [Apache] or reconfigure Apache and the Control Panel to listen on a different port
23:49:41 [Apache] Problem detected!
23:49:41 [Apache] Port 443 in use by "Unable to open process" with PID 3884!
23:49:41 [Apache] Apache WILL NOT start without the configured ports free!
23:49:41 [Apache] You need to uninstall/disable/reconfigure the blocking application
23:49:41 [Apache] or reconfigure Apache and the Control Panel to listen on a different port
23:49:41 [Apache] Attempting to start Apache app...
23:49:44 [Apache] Status change detected: running
23:49:45 [Apache] Status change detected: stopped
23:49:45 [Apache] Error: Apache shutdown unexpectedly.
23:49:45 [Apache] This may be due to a blocked port, missing dependencies,
23:49:45 [Apache] improper privileges, a crash, or a shutdown by another method.
23:49:45 [Apache] Press the Logs button to view error logs and check
23:49:45 [Apache] the Windows Event Viewer for more clues
23:49:45 [Apache] If you need more help, copy and post this
23:49:45 [Apache] entire log window on the forums
23:49:47 [Apache] Problem detected!
23:49:47 [Apache] Port 80 in use by "Unable to open process" with PID 3884!
23:49:47 [Apache] Apache WILL NOT start without the configured ports free!
23:49:47 [Apache] You need to uninstall/disable/reconfigure the blocking application
23:49:47 [Apache] or reconfigure Apache and the Control Panel to listen on a different port
23:49:47 [Apache] Problem detected!
23:49:47 [Apache] Port 443 in use by "Unable to open process" with PID 3884!
23:49:47 [Apache] Apache WILL NOT start without the configured ports free!
23:49:47 [Apache] You need to uninstall/disable/reconfigure the blocking application
23:49:47 [Apache] or reconfigure Apache and the Control Panel to listen on a different port
23:49:47 [Apache] Attempting to start Apache app...
23:49:47 [Apache] Status change detected: running
23:49:48 [Apache] Status change detected: stopped
23:49:48 [Apache] Error: Apache shutdown unexpectedly.
23:49:48 [Apache] This may be due to a blocked port, missing dependencies,
23:49:48 [Apache] improper privileges, a crash, or a shutdown by another method.
23:49:48 [Apache] Press the Logs button to view error logs and check
23:49:48 [Apache] the Windows Event Viewer for more clues
23:49:48 [Apache] If you need more help, copy and post this
23:49:48 [Apache] entire log window on the forums

I'm lost. Thanks for your help
Mary
MAG
 
Posts: 4
Joined: 03. January 2016 20:19
Operating System: windows 8.1

Re: APACHE ERRORS WHEN LOADING XAMPP

Postby Altrea » 04. January 2016 00:43

Hi and a happy new year,

start your control panel with enhanced administration rights (rightclick -> run as administrator)

best wishes,
Altrea
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8290
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: APACHE ERRORS WHEN LOADING XAMPP

Postby MAG » 05. January 2016 23:38

Waouh, great ! So simple and magic.
Many thanks Altrea.
Love from Paris
MAG
 
Posts: 4
Joined: 03. January 2016 20:19
Operating System: windows 8.1

Re: APACHE ERRORS WHEN LOADING XAMPP

Postby Altrea » 05. January 2016 23:51

You are welcome.
Greetigs from Germany to France 8)
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8290
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 47 guests