Apache Windows 10 won't run

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Apache Windows 10 won't run

Postby Yellowfin » 31. December 2015 00:02

Hi, I get this error message when I try to rum apache.

[Thu Dec 31 09:41:30.870427 2015] [ssl:warn] [pid 4944:tid 648] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Thu Dec 31 09:41:31.194208 2015] [ssl:warn] [pid 4944:tid 648] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Thu Dec 31 09:41:31.251756 2015] [mpm_winnt:notice] [pid 4944:tid 648] AH00455: Apache/2.4.17 (Win32) OpenSSL/1.0.2d PHP/5.5.30 configured -- resuming normal operations
[Thu Dec 31 09:41:31.251756 2015] [mpm_winnt:notice] [pid 4944:tid 648] AH00456: Apache Lounge VC11 Server built: Oct 13 2015 10:54:13
[Thu Dec 31 09:41:31.251756 2015] [core:notice] [pid 4944:tid 648] AH00094: Command line: 'f:\\xampp\\apache\\bin\\httpd.exe -d F:/xampp/apache'
[Thu Dec 31 09:41:31.268770 2015] [mpm_winnt:notice] [pid 4944:tid 648] AH00418: Parent: Created child process 976
[Thu Dec 31 09:41:32.463799 2015] [ssl:warn] [pid 976:tid 536] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Thu Dec 31 09:41:32.686490 2015] [ssl:warn] [pid 976:tid 536] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Thu Dec 31 09:41:32.749044 2015] [mpm_winnt:crit] [pid 976:tid 536] (OS 109)The pipe has been ended. : AH00404: Child: Unable to read socket data from parent
[Thu Dec 31 09:41:32.757550 2015] [mpm_winnt:crit] [pid 4944:tid 648] AH00427: Parent: child process 976 exited with status 3 -- Aborting.

Can you help please?
Regards
Yellowfin
 
Posts: 6
Joined: 30. December 2015 23:47
Operating System: window 10

Re: Apache Windows 10 won't run

Postby Yellowfin » 01. January 2016 03:58

No one is willing to help me?
Yellowfin
 
Posts: 6
Joined: 30. December 2015 23:47
Operating System: window 10

Re: Apache Windows 10 won't run

Postby Joergi » 01. January 2016 16:22

I _am_ willing to help you. But for me Apache is working under Windows 10.

What I had in older versions was that the SSL module of Apache did not work correctly with the applications, which I am running. I have then disabled SSL in Apache and activated the SSL module in PHP instead.

That way, Apache is no longer listening on port 443, but only on port 80 and SSL stuff is handled by the SSL module of PHP.

However, you do not write that you had any problems running Apache. So is it only the log entry or do you actually have malfunctions because of this?
Joergi
 
Posts: 10
Joined: 16. August 2015 21:12
Operating System: W

Re: Apache Windows 10 won't run

Postby Yellowfin » 01. January 2016 22:06

Thank you for your reply Joegi, When I try to start apache, it starts for a moment then is stops suddenly and I get this message :
8:02:01 AM [Apache] Status change detected: running
8:02:05 AM [Apache] Status change detected: stopped
8:02:05 AM [Apache] Error: Apache shutdown unexpectedly.
8:02:05 AM [Apache] This may be due to a blocked port, missing dependencies,
8:02:05 AM [Apache] improper privileges, a crash, or a shutdown by another method.
8:02:05 AM [Apache] Press the Logs button to view error logs and check
8:02:05 AM [Apache] the Windows Event Viewer for more clues
8:02:05 AM [Apache] If you need more help, copy and post this
8:02:05 AM [Apache] entire log window on the forums
and in my error log, this is what i get:
[Sat Jan 02 08:02:02.944265 2016] [ssl:warn] [pid 9644:tid 540] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Sat Jan 02 08:02:03.404747 2016] [ssl:warn] [pid 9644:tid 540] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Sat Jan 02 08:02:03.649456 2016] [mpm_winnt:notice] [pid 9644:tid 540] AH00455: Apache/2.4.17 (Win32) OpenSSL/1.0.2d PHP/5.5.30 configured -- resuming normal operations
[Sat Jan 02 08:02:03.649456 2016] [mpm_winnt:notice] [pid 9644:tid 540] AH00456: Apache Lounge VC11 Server built: Oct 13 2015 10:54:13
[Sat Jan 02 08:02:03.649456 2016] [core:notice] [pid 9644:tid 540] AH00094: Command line: 'f:\\xampp\\apache\\bin\\httpd.exe -d F:/xampp/apache'
[Sat Jan 02 08:02:03.660965 2016] [mpm_winnt:notice] [pid 9644:tid 540] AH00418: Parent: Created child process 10648
[Sat Jan 02 08:02:04.750222 2016] [ssl:warn] [pid 10648:tid 536] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Sat Jan 02 08:02:04.997448 2016] [ssl:warn] [pid 10648:tid 536] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Sat Jan 02 08:02:05.050992 2016] [mpm_winnt:crit] [pid 10648:tid 536] (OS 109)The pipe has been ended. : AH00404: Child: Unable to read socket data from parent
[Sat Jan 02 08:02:05.060001 2016] [mpm_winnt:crit] [pid 9644:tid 540] AH00427: Parent: child process 10648 exited with status 3 -- Aborting.
Do you have any ideas on what is happening and what I can do to fix it?
Regards
Yellowfin
 
Posts: 6
Joined: 30. December 2015 23:47
Operating System: window 10

Re: Apache Windows 10 won't run

Postby Altrea » 01. January 2016 23:38

We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8291
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: Apache Windows 10 won't run

Postby Yellowfin » 02. January 2016 00:25

Hi Altrea, I have read through the links you posted above, and ran the program as administrator, trusted the ssl certificate, but still i get the same errors as I have posted
Yellowfin
 
Posts: 6
Joined: 30. December 2015 23:47
Operating System: window 10

Re: Apache Windows 10 won't run

Postby Altrea » 02. January 2016 00:44

If you read the threads, you know that the information you provided is incomplete.

Yellowfin wrote:[Sat Jan 02 08:02:05.050992 2016] [mpm_winnt:crit] [pid 10648:tid 536] (OS 109)The pipe has been ended. : AH00404: Child: Unable to read socket data from parent

The most common reason for this error is a port/socket blocking foreign process or service.
That is all we can say with that amount of information.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8291
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: Apache Windows 10 won't run

Postby Yellowfin » 02. January 2016 22:27

Thank you for your help Altrea, here is the full Xampp error:
8:18:23 AM [main] Initializing Control Panel
8:18:23 AM [main] Windows Version: Windows 8 64-bit
8:18:23 AM [main] XAMPP Version: 5.5.30
8:18:23 AM [main] Control Panel Version: 3.2.1 [ Compiled: May 7th 2013 ]
8:18:23 AM [main] Running with Administrator rights - good!
8:18:23 AM [main] XAMPP Installation Directory: "f:\xampp\"
8:18:23 AM [main] Checking for prerequisites
8:18:23 AM [main] All prerequisites found
8:18:23 AM [main] Initializing Modules
8:18:23 AM [main] Starting Check-Timer
8:18:23 AM [main] Control Panel Ready
8:19:51 AM [Apache] Checking default ports...
8:19:51 AM [Apache] Attempting to start Apache app...
8:19:51 AM [Apache] Executing "f:\xampp\apache\bin\httpd.exe"
8:19:51 AM [Apache] Return code: 0
8:19:51 AM [Apache] Status change detected: running
8:19:54 AM [Apache] Status change detected: stopped
8:19:54 AM [Apache] Error: Apache shutdown unexpectedly.
8:19:54 AM [Apache] This may be due to a blocked port, missing dependencies,
8:19:54 AM [Apache] improper privileges, a crash, or a shutdown by another method.
8:19:54 AM [Apache] Press the Logs button to view error logs and check
8:19:54 AM [Apache] the Windows Event Viewer for more clues
8:19:54 AM [Apache] If you need more help, copy and post this
8:19:54 AM [Apache] entire log window on the forums
and the log file:
[Sun Jan 03 08:19:52.299860 2016] [ssl:warn] [pid 9068:tid 564] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Sun Jan 03 08:19:52.562576 2016] [ssl:warn] [pid 9068:tid 564] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Sun Jan 03 08:19:52.600336 2016] [mpm_winnt:notice] [pid 9068:tid 564] AH00455: Apache/2.4.17 (Win32) OpenSSL/1.0.2d PHP/5.5.30 configured -- resuming normal operations
[Sun Jan 03 08:19:52.600336 2016] [mpm_winnt:notice] [pid 9068:tid 564] AH00456: Apache Lounge VC11 Server built: Oct 13 2015 10:54:13
[Sun Jan 03 08:19:52.600336 2016] [core:notice] [pid 9068:tid 564] AH00094: Command line: 'f:\\xampp\\apache\\bin\\httpd.exe -d F:/xampp/apache'
[Sun Jan 03 08:19:52.615968 2016] [mpm_winnt:notice] [pid 9068:tid 564] AH00418: Parent: Created child process 8112
[Sun Jan 03 08:19:53.601378 2016] [ssl:warn] [pid 8112:tid 536] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Sun Jan 03 08:19:53.816720 2016] [ssl:warn] [pid 8112:tid 536] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Sun Jan 03 08:19:53.863617 2016] [mpm_winnt:crit] [pid 8112:tid 536] (OS 109)The pipe has been ended. : AH00404: Child: Unable to read socket data from parent
[Sun Jan 03 08:19:53.863617 2016] [mpm_winnt:crit] [pid 9068:tid 564] AH00427: Parent: child process 8112 exited with status 3 -- Aborting.
Regards
Yellowfin
 
Posts: 6
Joined: 30. December 2015 23:47
Operating System: window 10

Re: Apache Windows 10 won't run

Postby Yellowfin » 03. January 2016 22:10

Hi Altrea, I changed the ports and all is good, thank you for your help.
Cheer's :D
Yellowfin
 
Posts: 6
Joined: 30. December 2015 23:47
Operating System: window 10

Re: Apache Windows 10 won't run

Postby udinha » 05. January 2016 01:57

I'm having the same problems.
This is my error log

[Mon Jan 04 21:43:19.127544 2016] [ssl:warn] [pid 9404:tid 488] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Mon Jan 04 21:43:19.315051 2016] [ssl:warn] [pid 9404:tid 488] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Mon Jan 04 21:43:20.322562 2016] [mpm_winnt:notice] [pid 9404:tid 488] AH00455: Apache/2.4.18 (Win32) OpenSSL/1.0.2e PHP/7.0.1 configured -- resuming normal operations
[Mon Jan 04 21:43:20.322562 2016] [mpm_winnt:notice] [pid 9404:tid 488] AH00456: Apache Lounge VC14 Server built: Dec 9 2015 10:17:39
[Mon Jan 04 21:43:20.322562 2016] [core:notice] [pid 9404:tid 488] AH00094: Command line: 'C:\\xampp\\apache\\bin\\httpd.exe -d C:/xampp/apache'
[Mon Jan 04 21:43:20.353782 2016] [mpm_winnt:notice] [pid 9404:tid 488] AH00418: Parent: Created child process 9492
[Mon Jan 04 21:43:21.103931 2016] [ssl:warn] [pid 9492:tid 512] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Mon Jan 04 21:43:21.383315 2016] [ssl:warn] [pid 9492:tid 512] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Mon Jan 04 21:43:21.477090 2016] [mpm_winnt:crit] [pid 9492:tid 512] (OS 109)Ha terminado la canalización. : AH00404: Child: Unable to read socket data from parent
[Mon Jan 04 21:43:21.492697 2016] [mpm_winnt:crit] [pid 9404:tid 488] AH00427: Parent: child process 9492 exited with status 3 -- Aborting.
[Mon Jan 04 21:44:33.706509 2016] [ssl:warn] [pid 8616:tid 548] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Mon Jan 04 21:44:33.940896 2016] [ssl:warn] [pid 8616:tid 548] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Mon Jan 04 21:44:34.003400 2016] [mpm_winnt:notice] [pid 8616:tid 548] AH00455: Apache/2.4.18 (Win32) OpenSSL/1.0.2e PHP/7.0.1 configured -- resuming normal operations
[Mon Jan 04 21:44:34.003400 2016] [mpm_winnt:notice] [pid 8616:tid 548] AH00456: Apache Lounge VC14 Server built: Dec 9 2015 10:17:39
[Mon Jan 04 21:44:34.003400 2016] [core:notice] [pid 8616:tid 548] AH00094: Command line: 'C:\\xampp\\apache\\bin\\httpd.exe -d C:/xampp/apache'
[Mon Jan 04 21:44:34.003400 2016] [mpm_winnt:notice] [pid 8616:tid 548] AH00418: Parent: Created child process 9780
[Mon Jan 04 21:44:34.753439 2016] [ssl:warn] [pid 9780:tid 516] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Mon Jan 04 21:44:34.925323 2016] [ssl:warn] [pid 9780:tid 516] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Mon Jan 04 21:44:34.965584 2016] [mpm_winnt:crit] [pid 9780:tid 516] (OS 109)Ha terminado la canalización. : AH00404: Child: Unable to read socket data from parent
[Mon Jan 04 21:44:34.965584 2016] [mpm_winnt:crit] [pid 8616:tid 548] AH00427: Parent: child process 9780 exited with status 3 -- Aborting.


Could anyone help me ?
udinha
 
Posts: 1
Joined: 05. January 2016 01:53
Operating System: Windows 10


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 60 guests