Unable to run PHPMyAdmin

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Unable to run PHPMyAdmin

Postby Begadoc » 10. December 2015 18:38

Because of intractable problems with a dynamic web site I was building I decided to start totally afresh. I therefore deleted XAMPP (using the uninstall option) and downloaded the latest version of the installer. That gave me problems with access due to password issues and even though I tried the various things suggested I couldn't sort the problem out. I therefore uninstalled it and went back to the original install package I had (1.83) which had a front end I could understand and which I had been able to use in the past without problems! Using this I got SQL & PHP working . I secured the root access by changing the password. However when I try and run localhost phpMyAdmin I cannot connect due to password issues. The password I am using is correct.
Any help would be appreciated.
Begadoc
 
Posts: 7
Joined: 22. March 2015 23:23
Operating System: Windows 8

Re: Unable to run PHPMyAdmin

Postby Nobbie » 10. December 2015 19:14

Begadoc wrote:I secured the root access by changing the password. However when I try and run localhost phpMyAdmin I cannot connect due to password issues.


Exactly therefore the "suspicous" security feature has been removed in newer releases, as it did not provide any security but many many users destroyed their installation due to password problems. It never had been cleared, what is going wrong there. Nobody could restore the installation.
Nobbie
 
Posts: 8772
Joined: 09. March 2008 13:04

Re: Unable to run PHPMyAdmin

Postby Altrea » 10. December 2015 19:20

Begadoc wrote:I therefore uninstalled it and went back to the original install package I had (1.83) which had a front end I could understand and which I had been able to use in the past without problems! Using this I got SQL & PHP working . I secured the root access by changing the password. However when I try and run localhost phpMyAdmin I cannot connect due to password issues. The password I am using is correct.

That is exactly one of the problems why the old XAMPP security functions was removed from current XAMPP versions.
People without any knowledge using this don't know what they are doing and screwing up their installations.

In local development environments there is really no need to set any root password for the database. This user root can only be used from the same host XAMPP is installed on, so no external program or script can use this user. You should be the only person with full control of the scripts running from this host, so the only person you are securing from is yourself.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8294
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 51 guests