Specific issue with accessing Apache from internet [Static]

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Specific issue with accessing Apache from internet [Static]

Postby Owchy » 04. December 2015 00:58

Hey guys and gals.

Been reading through the forum trying to find the issue that I have but I have not come up with my solution. (or i'm just really bad at searching) I'll label in the most documented way I can.

XAMPP Version: 5.5.19
Modules: Apache & MySQL
Issue: Trying to access from internet and getting reference issues.

Details: I'm trying to access the web page from the outside using a static IP address and using mediawiki for our sister company. Nothing huge, just some documents they want to share with clients. I have set up the firewall to allow access to port 80 and 443 from the outside to the server directly via the static IP. The main issue I'm getting right now is that when I get everything going, it just comes up as: reference/index.php/Main_Page and nothing happens. Just a blank page. When I get to it internally (which they have been using the whole time till now) it's just fine, but when going externally, it will just give me issues.

Now trying not to be too ignorant, I checked trough issues from older versions and checked the vhost file and made the following:

Code: Select all
<VirtualHost *:80>
ServerAdmin XXXXXXXX@XXXXXXX.com
DocumentRoot "C:/xampp/htdocs"
</VirtualHost>


I cannot tell you if this is correct or not, but as I have inherited this issue, I want to make sure everything is correct. When accessing the page from outside it wants to go to: http://reference/index.php/Main_Page, but that obviously is not going to work since it's not displaying as an IP address.

If anyone could help me, I would be more than happy to send you the best of vibes and all that good stuff.

Thanks so much for reading!

EDIT: So, I guess I should mention that it's not putting anything in front of "reference" or even changing over to IPADDRESS/reference/index.php and just goes to reference.
Owchy
 
Posts: 1
Joined: 04. December 2015 00:40
Operating System: Server 2012 R2

Re: Specific issue with accessing Apache from internet [Stat

Postby Nobbie » 04. December 2015 11:24

Owchy wrote:I cannot tell you if this is correct or not


It is badly incorrect as it is missing the most important entry "ServerName". See https://httpd.apache.org/docs/2.4/en/vhosts/ and also see some examples on https://httpd.apache.org/docs/2.4/vhosts/examples.html

Owchy wrote:When accessing the page from outside it wants to go to: http://reference/index.php/Main_Page, but that obviously is not going to work since it's not displaying as an IP address.


This is hard to understand, what do you enter in the browser to access the page and why do you expect or believe that an IP has to be displayed??
Nobbie
 
Posts: 8780
Joined: 09. March 2008 13:04


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 33 guests