Problems starting Apache on Windows 10

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Problems starting Apache on Windows 10

Postby Dilip » 03. December 2015 07:02

Hi guys, i am facing similar issue with Windows 10.
Attempting to start Apache app...
11:21:32 AM [Apache] Status change detected: running
11:21:32 AM [Apache] Status change detected: stopped
11:21:32 AM [Apache] Error: Apache shutdown unexpectedly.
11:21:32 AM [Apache] This may be due to a blocked port, missing dependencies,
11:21:32 AM [Apache] improper privileges, a crash, or a shutdown by another method.
11:21:32 AM [Apache] Press the Logs button to view error logs and check
11:21:32 AM [Apache] the Windows Event Viewer for more clues
11:21:32 AM [Apache] If you need more help, copy and post this
11:21:32 AM [Apache] entire log window on the forums

Can anyone suggest how to resolve this?
Dilip
 
Posts: 2
Joined: 03. December 2015 06:46
Operating System: Windows 10

Re: Problems starting Apache on Windows 10

Postby Nobbie » 03. December 2015 11:51

Did you alread step thru the very first thread (a pinned thread) from this board?

See viewtopic.php?f=16&t=69784
Nobbie
 
Posts: 8762
Joined: 09. March 2008 13:04

Re: Problems starting Apache on Windows 10

Postby Dilip » 03. December 2015 12:57

Hi, i am very new to this. I just installed the latest XAMPP software and opened the controller. But i noticed i couldnt start the Apache but My Sql was able to run. Is there anything that i have missed?
Dilip
 
Posts: 2
Joined: 03. December 2015 06:46
Operating System: Windows 10

Re: Problems starting Apache on Windows 10

Postby Altrea » 03. December 2015 13:35

Maybe Apache is already started by the installer?
Please open your browser and type in http://localhost
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8286
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: Problems starting Apache on Windows 10

Postby Rastamichel » 04. December 2015 11:14

10:57:39 [main] Initializing Control Panel
10:57:39 [main] Windows Version: Pro 64-bit
10:57:39 [main] XAMPP Version: 5.6.14
10:57:39 [main] Control Panel Version: 3.2.2 [ Compiled: Nov 12th 2015 ]
10:57:39 [main] Running with Administrator rights - good!
10:57:39 [main] XAMPP Installation Directory: "c:\xampp\"
10:57:39 [main] Checking for prerequisites
10:57:39 [main] All prerequisites found
10:57:39 [main] Initializing Modules
10:57:39 [Apache] Problem detected!
10:57:39 [Apache] Port 80 in use by "Unable to open process" with PID 4!
10:57:39 [Apache] Apache WILL NOT start without the configured ports free!
10:57:39 [Apache] You need to uninstall/disable/reconfigure the blocking application
10:57:39 [Apache] or reconfigure Apache and the Control Panel to listen on a different port
10:57:39 [mysql] XAMPP MySQL Service is already running on port 3306
10:57:39 [main] The FileZilla module is disabled
10:57:39 [main] The Mercury module is disabled
10:57:39 [main] The Tomcat module is disabled
10:57:39 [main] Starting Check-Timer
10:57:39 [main] Control Panel Ready
Hello friends i got a problem too...i never worked with apache..and i tred too config it but i not recieve it ..could somebody help me ..or explain what to do ..really thanks to you guys...rastamichel
Rastamichel
 
Posts: 1
Joined: 04. December 2015 10:49
Operating System: windows10

Re: Problems starting Apache on Windows 10

Postby Nobbie » 04. December 2015 11:37

Nobbie
 
Posts: 8762
Joined: 09. March 2008 13:04

Re: Problems starting Apache on Windows 10

Postby sundar76 » 15. December 2015 16:06

8:30:00 PM [main] Initializing Control Panel
8:30:01 PM [main] Windows Version: Home 64-bit
8:30:01 PM [main] XAMPP Version: 5.6.15
8:30:01 PM [main] Control Panel Version: 3.2.2 [ Compiled: Nov 12th 2015 ]
8:30:01 PM [main] You are not running with administrator rights! This will work for
8:30:01 PM [main] most application stuff but whenever you do something with services
8:30:01 PM [main] there will be a security dialogue or things will break! So think
8:30:01 PM [main] about running this application with administrator rights!
8:30:01 PM [main] XAMPP Installation Directory: "c:\users\admi\documents\newxampp\"
8:30:01 PM [main] Checking for prerequisites
8:30:14 PM [main] All prerequisites found
8:30:14 PM [main] Initializing Modules
8:30:14 PM [main] Starting Check-Timer
8:30:14 PM [main] Control Panel Ready
8:30:32 PM [Apache] Attempting to start Apache app...
8:30:32 PM [Apache] Status change detected: running
8:30:38 PM [Apache] Status change detected: stopped
8:30:38 PM [Apache] Error: Apache shutdown unexpectedly.
8:30:38 PM [Apache] This may be due to a blocked port, missing dependencies,
8:30:38 PM [Apache] improper privileges, a crash, or a shutdown by another method.
8:30:38 PM [Apache] Press the Logs button to view error logs and check
8:30:38 PM [Apache] the Windows Event Viewer for more clues
8:30:38 PM [Apache] If you need more help, copy and post this
8:30:38 PM [Apache] entire log window on the forums
8:30:39 PM [mysql] Attempting to start MySQL app...
8:30:40 PM [mysql] Status change detected: running
8:30:40 PM [mysql] Status change detected: stopped
8:30:40 PM [mysql] Error: MySQL shutdown unexpectedly.
8:30:40 PM [mysql] This may be due to a blocked port, missing dependencies,
8:30:40 PM [mysql] improper privileges, a crash, or a shutdown by another method.
8:30:40 PM [mysql] Press the Logs button to view error logs and check
8:30:40 PM [mysql] the Windows Event Viewer for more clues
8:30:40 PM [mysql] If you need more help, copy and post this
8:30:40 PM [mysql] entire log window on the forums
8:31:24 PM [Apache] Attempting to start Apache app...
8:31:25 PM [Apache] Status change detected: running
8:31:27 PM [mysql] Attempting to start MySQL app...
8:31:31 PM [Apache] Status change detected: stopped
8:31:31 PM [Apache] Error: Apache shutdown unexpectedly.
8:31:31 PM [Apache] This may be due to a blocked port, missing dependencies,
8:31:31 PM [Apache] improper privileges, a crash, or a shutdown by another method.
8:31:31 PM [Apache] Press the Logs button to view error logs and check
8:31:31 PM [Apache] the Windows Event Viewer for more clues
8:31:31 PM [Apache] If you need more help, copy and post this
8:31:31 PM [Apache] entire log window on the forums
8:31:40 PM [filezilla] Attempting to start FileZilla app...
8:31:40 PM [filezilla] Status change detected: running
8:31:45 PM [mercury] Attempting to start Mercury app...
8:31:45 PM [mercury] Status change detected: running
8:31:48 PM [Tomcat] Attempting to start Tomcat app...
8:32:06 PM [Tomcat] Status change detected: running
8:32:21 PM [Apache] Attempting to start Apache app...
8:32:21 PM [Apache] Status change detected: running
8:32:23 PM [mysql] Attempting to start MySQL app...
8:32:23 PM [mysql] Status change detected: running
8:32:23 PM [mysql] Status change detected: stopped
8:32:23 PM [mysql] Error: MySQL shutdown unexpectedly.
8:32:23 PM [mysql] This may be due to a blocked port, missing dependencies,
8:32:23 PM [mysql] improper privileges, a crash, or a shutdown by another method.
8:32:23 PM [mysql] Press the Logs button to view error logs and check
8:32:23 PM [mysql] the Windows Event Viewer for more clues
8:32:23 PM [mysql] If you need more help, copy and post this
8:32:23 PM [mysql] entire log window on the forums
8:32:27 PM [Apache] Status change detected: stopped
8:32:27 PM [Apache] Error: Apache shutdown unexpectedly.
8:32:27 PM [Apache] This may be due to a blocked port, missing dependencies,
8:32:27 PM [Apache] improper privileges, a crash, or a shutdown by another method.
8:32:27 PM [Apache] Press the Logs button to view error logs and check
8:32:27 PM [Apache] the Windows Event Viewer for more clues
8:32:27 PM [Apache] If you need more help, copy and post this
8:32:27 PM [Apache] entire log window on the forums

This is the issue I have. I did the complete instructions from: "By default, Windows 10 starts Microsoft IIS on port 80, which is the same default port used by Apache in XAMPP. As a result, Apache cannot bind to port 80.  To disable IIS from running on port 80, follow these steps:  
Open the Services panel in Computer Management.
Search for the 'World Wide Web Publishing Service' and select it.
Click the link to 'Stop the service'.
Double-click the service name.
In the 'Startup type' field, change the startup type to 'Disabled'.
Click 'OK' to save your changes.
You should now be able to start Apache in XAMPP on port 80.  
For more information, refer to the 'Troubleshoot Apache Startup Problems'
guide included with XAMPP or this forum post"
Kindly suggest a way to resolve this
sundar
sundar76
 
Posts: 3
Joined: 15. December 2015 15:24
Operating System: windows 10

Re: Problems starting Apache on Windows 10

Postby Altrea » 15. December 2015 20:21

sundar76 wrote:8:30:01 PM [main] XAMPP Installation Directory: "c:\users\admi\documents\newxampp\"

Don't install XAMPP into your users directory. Install it directly to C:\ so that you get a folder C:\xampp\
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8286
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: Problems starting Apache on Windows 10

Postby sundar76 » 16. December 2015 15:52

Hi thanks a lot for your support.
I uninstalled the antivirus, reinstalled xampp in c:\.
Also deactivated uac with msconfig.
Reinstalled xampp. Everything works ie mysql,filezilla,mercury,tomcat excepting apache.


This is the message:
8:05:08 PM [main] Initializing Control Panel
8:05:08 PM [main] Windows Version: Home 64-bit
8:05:08 PM [main] XAMPP Version: 5.6.15
8:05:08 PM [main] Control Panel Version: 3.2.2 [ Compiled: Nov 12th 2015 ]
8:05:08 PM [main] You are not running with administrator rights! This will work for
8:05:08 PM [main] most application stuff but whenever you do something with services
8:05:08 PM [main] there will be a security dialogue or things will break! So think
8:05:08 PM [main] about running this application with administrator rights!
8:05:08 PM [main] XAMPP Installation Directory: "c:\xampp\"
8:05:08 PM [main] Checking for prerequisites
8:05:08 PM [main] All prerequisites found
8:05:08 PM [main] Initializing Modules
8:05:08 PM [Apache] Problem detected!
8:05:08 PM [Apache] Port 80 in use by "Unable to open process" with PID 10332!
8:05:08 PM [Apache] Apache WILL NOT start without the configured ports free!
8:05:08 PM [Apache] You need to uninstall/disable/reconfigure the blocking application
8:05:08 PM [Apache] or reconfigure Apache and the Control Panel to listen on a different port
8:05:08 PM [Apache] Problem detected!
8:05:08 PM [Apache] Port 443 in use by "Unable to open process" with PID 10332!
8:05:08 PM [Apache] Apache WILL NOT start without the configured ports free!
8:05:08 PM [Apache] You need to uninstall/disable/reconfigure the blocking application
8:05:08 PM [Apache] or reconfigure Apache and the Control Panel to listen on a different port
8:05:08 PM [main] Starting Check-Timer
8:05:08 PM [main] Control Panel Ready
8:05:16 PM [Apache] Problem detected!
8:05:16 PM [Apache] Port 80 in use by "Unable to open process" with PID 10332!
8:05:16 PM [Apache] Apache WILL NOT start without the configured ports free!
8:05:16 PM [Apache] You need to uninstall/disable/reconfigure the blocking application
8:05:16 PM [Apache] or reconfigure Apache and the Control Panel to listen on a different port
8:05:16 PM [Apache] Problem detected!
8:05:16 PM [Apache] Port 443 in use by "Unable to open process" with PID 10332!
8:05:16 PM [Apache] Apache WILL NOT start without the configured ports free!
8:05:16 PM [Apache] You need to uninstall/disable/reconfigure the blocking application
8:05:16 PM [Apache] or reconfigure Apache and the Control Panel to listen on a different port
8:05:16 PM [Apache] Attempting to start Apache app...
8:05:16 PM [Apache] Status change detected: running
8:05:20 PM [mysql] Attempting to start MySQL app...
8:05:21 PM [mysql] Status change detected: running
8:05:31 PM [Apache] Status change detected: stopped
8:05:31 PM [Apache] Error: Apache shutdown unexpectedly.
8:05:31 PM [Apache] This may be due to a blocked port, missing dependencies,
8:05:31 PM [Apache] improper privileges, a crash, or a shutdown by another method.
8:05:31 PM [Apache] Press the Logs button to view error logs and check
8:05:31 PM [Apache] the Windows Event Viewer for more clues
8:05:31 PM [Apache] If you need more help, copy and post this
8:05:31 PM [Apache] entire log window on the forums
8:05:52 PM [Apache] Problem detected!
8:05:52 PM [Apache] Port 80 in use by "Unable to open process" with PID 10332!
8:05:52 PM [Apache] Apache WILL NOT start without the configured ports free!
8:05:52 PM [Apache] You need to uninstall/disable/reconfigure the blocking application
8:05:52 PM [Apache] or reconfigure Apache and the Control Panel to listen on a different port
8:05:52 PM [Apache] Problem detected!
8:05:52 PM [Apache] Port 443 in use by "Unable to open process" with PID 10332!
8:05:52 PM [Apache] Apache WILL NOT start without the configured ports free!
8:05:52 PM [Apache] You need to uninstall/disable/reconfigure the blocking application
8:05:52 PM [Apache] or reconfigure Apache and the Control Panel to listen on a different port
8:05:52 PM [Apache] Attempting to start Apache app...
8:05:52 PM [Apache] Status change detected: running
8:05:58 PM [Apache] Status change detected: stopped
8:05:58 PM [Apache] Error: Apache shutdown unexpectedly.
8:05:58 PM [Apache] This may be due to a blocked port, missing dependencies,
8:05:58 PM [Apache] improper privileges, a crash, or a shutdown by another method.
8:05:58 PM [Apache] Press the Logs button to view error logs and check
8:05:58 PM [Apache] the Windows Event Viewer for more clues
8:05:58 PM [Apache] If you need more help, copy and post this
8:05:58 PM [Apache] entire log window on the forums
8:07:58 PM [filezilla] Attempting to start FileZilla app...
8:07:59 PM [filezilla] Status change detected: running
8:08:12 PM [mercury] Attempting to start Mercury app...
8:08:13 PM [mercury] Status change detected: running
8:08:24 PM [Tomcat] Attempting to start Tomcat app...
8:08:39 PM [Tomcat] Status change detected: running
8:08:51 PM [Apache] Problem detected!
8:08:51 PM [Apache] Port 80 in use by "Unable to open process" with PID 10332!
8:08:51 PM [Apache] Apache WILL NOT start without the configured ports free!
8:08:51 PM [Apache] You need to uninstall/disable/reconfigure the blocking application
8:08:51 PM [Apache] or reconfigure Apache and the Control Panel to listen on a different port
8:08:51 PM [Apache] Problem detected!
8:08:51 PM [Apache] Port 443 in use by "Unable to open process" with PID 10332!
8:08:51 PM [Apache] Apache WILL NOT start without the configured ports free!
8:08:51 PM [Apache] You need to uninstall/disable/reconfigure the blocking application
8:08:51 PM [Apache] or reconfigure Apache and the Control Panel to listen on a different port
8:08:51 PM [Apache] Attempting to start Apache app...
8:08:51 PM [Apache] Status change detected: running
8:08:57 PM [Apache] Status change detected: stopped
8:08:57 PM [Apache] Error: Apache shutdown unexpectedly.
8:08:57 PM [Apache] This may be due to a blocked port, missing dependencies,
8:08:57 PM [Apache] improper privileges, a crash, or a shutdown by another method.
8:08:57 PM [Apache] Press the Logs button to view error logs and check
8:08:57 PM [Apache] the Windows Event Viewer for more clues
8:08:57 PM [Apache] If you need more help, copy and post this
8:08:57 PM [Apache] entire log window on the forums
8:09:39 PM [Apache] Problem detected!
8:09:39 PM [Apache] Port 80 in use by "Unable to open process" with PID 10332!
8:09:39 PM [Apache] Apache WILL NOT start without the configured ports free!
8:09:39 PM [Apache] You need to uninstall/disable/reconfigure the blocking application
8:09:39 PM [Apache] or reconfigure Apache and the Control Panel to listen on a different port
8:09:39 PM [Apache] Problem detected!
8:09:39 PM [Apache] Port 443 in use by "Unable to open process" with PID 10332!
8:09:39 PM [Apache] Apache WILL NOT start without the configured ports free!
8:09:39 PM [Apache] You need to uninstall/disable/reconfigure the blocking application
8:09:39 PM [Apache] or reconfigure Apache and the Control Panel to listen on a different port
8:09:39 PM [Apache] Attempting to start Apache app...
8:09:40 PM [Apache] Status change detected: running
8:09:46 PM [Apache] Status change detected: stopped
8:09:46 PM [Apache] Error: Apache shutdown unexpectedly.
8:09:46 PM [Apache] This may be due to a blocked port, missing dependencies,
8:09:46 PM [Apache] improper privileges, a crash, or a shutdown by another method.
8:09:46 PM [Apache] Press the Logs button to view error logs and check
8:09:46 PM [Apache] the Windows Event Viewer for more clues
8:09:46 PM [Apache] If you need more help, copy and post this
8:09:46 PM [Apache] entire log window on the forums

Kindly let me know how to make apache work.
Thanks, sundar76
sundar76
 
Posts: 3
Joined: 15. December 2015 15:24
Operating System: windows 10

Re: Problems starting Apache on Windows 10

Postby sundar76 » 16. December 2015 16:15

Hi,
On restarting the system, Ithe install is perfect I think.
Here is the status:
8:37:18 PM [main] Initializing Control Panel
8:37:18 PM [main] Windows Version: Home 64-bit
8:37:18 PM [main] XAMPP Version: 5.6.15
8:37:18 PM [main] Control Panel Version: 3.2.2 [ Compiled: Nov 12th 2015 ]
8:37:18 PM [main] You are not running with administrator rights! This will work for
8:37:18 PM [main] most application stuff but whenever you do something with services
8:37:18 PM [main] there will be a security dialogue or things will break! So think
8:37:18 PM [main] about running this application with administrator rights!
8:37:18 PM [main] XAMPP Installation Directory: "c:\xampp\"
8:37:18 PM [main] Checking for prerequisites
8:37:54 PM [main] All prerequisites found
8:37:54 PM [main] Initializing Modules
8:37:55 PM [main] Starting Check-Timer
8:37:55 PM [main] Control Panel Ready
8:38:09 PM [Apache] Attempting to start Apache app...
8:38:10 PM [Apache] Status change detected: running
8:38:14 PM [mysql] Attempting to start MySQL app...
8:38:16 PM [mysql] Status change detected: running
8:38:17 PM [filezilla] Attempting to start FileZilla app...
8:38:18 PM [filezilla] Status change detected: running
8:38:21 PM [mercury] Attempting to start Mercury app...
8:38:23 PM [mercury] Status change detected: running
8:38:24 PM [Tomcat] Attempting to start Tomcat app...
8:38:59 PM [Tomcat] Status change detected: running

only issue: Kindly let me know how to run with admin privilege.
thanks a lot guys.
You guys are awesome.
sundar76
sundar76
 
Posts: 3
Joined: 15. December 2015 15:24
Operating System: windows 10

Re: Problems starting Apache on Windows 10

Postby Altrea » 16. December 2015 16:18

sundar76 wrote:only issue: Kindly let me know how to run with admin privilege.

rightclick the xampp-control.exe -> run as Administrator
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8286
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 52 guests