Apache service starts but MySQL fails without error

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Apache service starts but MySQL fails without error

Postby Gerdofal » 17. November 2015 20:17


I just started at this job and I'm trying to clean up a pretty messy install of XAMPP. My current task is to make it start automatically with Windows instead of me having to login each time to run the control panel and make it work.

Using XAMPP Version 1.8.3. I attempted to install both Apache and MySQL as services. Apache worked just fine, but MySQL quit. Here is the log:

Code: Select all
7:40:49 AM  [mysql]    Attempting to start MySQL service...
7:40:50 AM  [mysql]    Status change detected: running
7:40:55 AM  [mysql]    Status change detected: stopped
7:40:55 AM  [mysql]    Error: MySQL shutdown unexpectedly.
7:40:55 AM  [mysql]    This may be due to a blocked port, missing dependencies,
7:40:55 AM  [mysql]    improper privileges, a crash, or a shutdown by another method.
7:40:55 AM  [mysql]    Press the Logs button to view error logs and check
7:40:55 AM  [mysql]    the Windows Event Viewer for more clues
7:40:55 AM  [mysql]    If you need more help, copy and post this
7:40:55 AM  [mysql]    entire log window on the forums

I looked through the event viewer and saw this:

Code: Select all
Can't find messagefile 'C:\xampp\mysql\share\errmsg.sys'

Dince xampp isn't installed on C (It's installed on D) I assume that something is missing from the path or ini setup for MySQL when starting as a service. When started by the control panel, everything works, so I tried looking through the control panel and saw this:

Code: Select all
7:40:33 AM  [main]    Initializing Control Panel
7:40:33 AM  [main]    Windows Version: Windows Server 2012  64-bit
7:40:33 AM  [main]    XAMPP Version: 1.8.3
7:40:33 AM  [main]    Control Panel Version: 3.2.1  [ Compiled: May 7th 2013 ]
7:40:33 AM  [main]    Running with Administrator rights - good!
7:40:33 AM  [main]    XAMPP Installation Directory: "d:\xampp\"
7:40:33 AM  [main]    Checking for prerequisites
7:40:34 AM  [main]    All prerequisites found
7:40:34 AM  [main]    Initializing Modules

What am I missing that would allow the service to figure out it should be using drive D instead of drive C?

Posts: 1
Joined: 17. November 2015 20:04
Operating System: Windows Server 2012 Standard

Re: Apache service starts but MySQL fails without error

Postby Altrea » 19. November 2015 22:51


you could try to unregister and reregister the MySQL service.

best wishes,
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
AF Moderator
Posts: 8243
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Return to XAMPP for Windows

Who is online

Users browsing this forum: hanie2016 and 47 guests