Bitnami Wordpress Question

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Bitnami Wordpress Question

Postby tuzza88 » 17. November 2015 14:24

Hi All

A quick question which I've been unable to find the answer to on the forums.

I've installed Bitnami Wordpress which by default is installed to http://localhost/wordpress/ and then using the Vidalia control panel service settings created an onion address and set the virtual port to 80.

My problem however is that when you browse to either http://localhost/ or u6sp3p7v7dkfyo37.onion it takes you to the XAMPP dashboard, its only when you put /wordpress after both these links that it takes you to the website.

How can I change this so that when you browse to u6sp3p7v7dkfyo37.onion / http://localhost/ that it shows the wordpres site?

Thanks All!
Dan
tuzza88
 
Posts: 3
Joined: 17. November 2015 14:11
Operating System: Windows 7

Re: Bitnami Wordpress Question

Postby Nobbie » 17. November 2015 17:42

Change the DocumentRoot from c:/xampp/htdocs to c:/xampp/htdocs/wordpress in httpd.conf (read appropriate Documentation about Apache and DocumentRoot), and also adapt the <Directory "C:/xampp/htdocs" /> Configuration to Wordpress.

BUT: you also have to adapt Wordpress config correctly (i.e. wp-config.php or similar) and change the URL Path from http://localhost/wordpress to http://localhost, otherwise Wordpress wont run correctly after you changed the DocumentRoot. You may also have to change any pointers to htdocs/wordpress in the Wordpress Configuration, if there are so things (i dont have wordpress installed).

Finally reboot Apache. BUT: after this, the dashboard does not appear anymore on your installation. Instead Wordpress will come up.
Nobbie
 
Posts: 8758
Joined: 09. March 2008 13:04

Re: Bitnami Wordpress Question

Postby Altrea » 17. November 2015 18:18

Bitnami Wordpress is installed by default to \xampp\apps\wordpress and linked by an Alias if i remember correctly.
So if you want to follow Nobbies suggestion, don't use C:\xampp\htdocs\wordpress as target path, but the true wordpress path.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8286
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: Bitnami Wordpress Question

Postby Nobbie » 17. November 2015 22:59

Altrea wrote:Bitnami Wordpress is installed by default to \xampp\apps\wordpress and linked by an Alias if i remember correctly.
So if you want to follow Nobbies suggestion, don't use C:\xampp\htdocs\wordpress as target path, but the true wordpress path.


OMG.

Thats a typical problem caused by a bad description...
Nobbie
 
Posts: 8758
Joined: 09. March 2008 13:04

Re: Bitnami Wordpress Question

Postby tuzza88 » 18. November 2015 13:49

Thank you for your replies.

I've made the changes as per Nobbie's description, and Apache would not start. I then changed the document root and the directory to C:\xampp\apps\wordpress\htdocs and apache was then able to start.

Browsing to localhost now works as intended however the whole site is displayed incorrectly and none of the links work.

For example trying to log in with http://localhost/wp-admin as soon as you press enter it redirects you to http://localhosthttp//localhost/wp-login.php?redirect_to=http%3A%2F%2Flocalhost%2Fwp-admin%2F&reauth=1 and displays the error 'Oops! Internet Explorer could not find localhosthttp'

So There are some loose ends that I now need to find. Any help will be greatly appreciated.

Cheers
Dan
tuzza88
 
Posts: 3
Joined: 17. November 2015 14:11
Operating System: Windows 7

Re: Bitnami Wordpress Question

Postby tuzza88 » 18. November 2015 15:47

I've managed to fix this but unfortunately for anyone else having the same problem, I'm not 100% sure what I did!

I went to phpmyadmin into the bitnami WP options folder and changed the siteurl and home fields from http://127.0.0.1/wordpress to http://127.0.0.1/ which didn't do anything or so I thought and so decided to convert the httpd.conf and wp-config files back to their original states and the above siteurl and home fields back to http://127.0.0.1/wordpress HOWEVER by browsing to http://127.0.0.1/ or http://localhost now it does still display the website and properly with all aspects working as they should be?!

Unfortunately I cant explain any better than that!

Cheers both for your help
Dan
tuzza88
 
Posts: 3
Joined: 17. November 2015 14:11
Operating System: Windows 7

Re: Bitnami Wordpress Question

Postby Nobbie » 18. November 2015 16:25

tuzza88 wrote:So There are some loose ends that I now need to find. Any help will be greatly appreciated.


Thats what i mentioned already:

Nobbie wrote:BUT: you also have to adapt Wordpress config correctly (i.e. wp-config.php or similar) and change the URL Path from http://localhost/wordpress to http://localhost, otherwise Wordpress wont run correctly after you changed the DocumentRoot. You may also have to change any pointers to htdocs/wordpress in the Wordpress Configuration, if there are so things (i dont have wordpress installed).
Nobbie
 
Posts: 8758
Joined: 09. March 2008 13:04


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 47 guests