Running PERL Scripts in XAMPP 1.8.3

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Running PERL Scripts in XAMPP 1.8.3

Postby lerxst » 01. November 2015 14:57

I installed and have been using XAMPP 1.8.3 on Windows 8 since November 2014 and it has worked wonderfully! I'm using Apache, PHP and MySQL. Now, I want to use PERL. So I tried running the scripts that come with the XAMPP installation: cgi.cgi, perltest.cgi, and printenv.pl. All three give me the same error:

***********************
The server encountered an internal error and was unable to complete your request.

Error message:
couldn't create child process: 720002: printenv.pl
**********************

In the Apache error log, I get:

[Sun Nov 01 08:33:34.064744 2015] [cgi:error] [pid 7584:tid 1724] (OS 2)The system cannot find the file specified. : [client ::1:51272] couldn't create child process: 720002: printenv.pl
[Sun Nov 01 08:33:34.064744 2015] [cgi:error] [pid 7584:tid 1724] (OS 2)The system cannot find the file specified. : [client ::1:51272] AH01223: couldn't spawn child process: C:/xampp/cgi-bin/printenv.pl

When I look at the script files, all of them start with:

#!"C:\xampp\perl\bin\perl.exe"

But one glaring problem I have is the perl directory does not exist in my xampp folder. I would have expected it to be there from the installation. So, what did I miss??

Thanks!

TT
lerxst
 
Posts: 3
Joined: 01. November 2015 14:37
Operating System: Windows 8

Re: Running PERL Scripts in XAMPP 1.8.3

Postby Altrea » 01. November 2015 15:58

Did you install the full version or the lite/portable version of XAMPP?
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8286
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: Running PERL Scripts in XAMPP 1.8.3

Postby lerxst » 01. November 2015 20:08

Good question; how can I find out? TT
lerxst
 
Posts: 3
Joined: 01. November 2015 14:37
Operating System: Windows 8

Re: Running PERL Scripts in XAMPP 1.8.3

Postby lerxst » 01. November 2015 21:05

Ok...however it happened, the PERL directory is not there. So I downloaded 1.8.3-5, pulled the PERL directory from it and placed it in my XAMPP directory. Perl seems to be working fine now.

Strangeness. And I thought Halloween was over today! :twisted:

Thanks for letting me bounce this off the forum!

TT
lerxst
 
Posts: 3
Joined: 01. November 2015 14:37
Operating System: Windows 8


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 51 guests