Problems and Solutions (well, kind of) for XAMPP 5.6.14

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Problems and Solutions (well, kind of) for XAMPP 5.6.14

Postby TomXampp » 28. October 2015 08:42

Whenever there's a new version of PHP or PhpMyAdmin I will upgrade it in isolation within XAMPP, leaving the rest of the installation untouched. But whenever there's an update to Apache, I've found the only real solution is to upgrade XAMPP altogether, and I've gotten the upgrade process down to a science. However, I encountered two unusual problems upgrading XAMPP to the new version 5.6.14, and in case someone else encounters these same problems, here they are and the solutions I found (and one is only a partial solution).

The first would seem to be a bug in PhpMyAdmin vis-a-vis the new Apache, as my version of PhpMyAdmin was not changed in the updating of XAMPP, only Apache was (and whatever other dependencies there are in XAMPP). After successfully creating and importing my databases, I discovered I could not recreate the previous users or add new users to the databases using the standard set of controls in the "Privileges" tab. The only way to bring the current user credentials into the database was to return to the previous version of XAMPP, export the users to a SQL file, and then read in that SQL within the new XAMPP. That worked for the existing users.

However, I am still unable to create new users for the databases. For example, when I try to create a new user named "kalan" on localhost with a password and full permissions, using the standard controls in the "add user account" screen (which is where you're redirected when the [add user account] button is pressed), the following error messages are generated:

Code: Select all
#1065 - Query was empty

CREATE USER 'kalan'@'localhost' IDENTIFIED WITH mysql_native_password BY '***';GRANT ALL PRIVILEGES ON *.* TO 'kalan'@'localhost' REQUIRE NONE WITH GRANT OPTION MAX_QUERIES_PER_HOUR 0 MAX_CONNECTIONS_PER_HOUR 0 MAX_UPDATES_PER_HOUR 0 MAX_USER_CONNECTIONS 0;

Edit privileges: User account 'kalan'@'localhost' - Databases my_database

The selected user was not found in the privilege table.


I've tried specifying the specific table as opposed to localhost, and various other permutations of the prompts on the screen, but to no avail...it still throws error messages like the one above. And, of course, it *can't* find the "selected user in the privilege table" precisely because I'm trying to add one.

This has not happened with prior versions of XAMPP; I've always been able to use the standard controls in the "Privileges" tab to create users. Is this a bug, or is there a new protocol that I did not notice in the documentation of the new version?

The other problem was that when I then ran my sites and checked the mysql_error.log, it reported:

Code: Select all
[ERROR] Missing system table mysql.roles_mapping; please run mysql_upgrade to create it


...followed by many error statements.

This has never happened before. Unlike the creation of new users, though, I found that this was easily correctable by navigating with a CMD prompt to c:\xampp\mysql\bin (as \xampp is installed directly off the root of c: on my machines) and executing:

Code: Select all
mysql_upgrade


After running this program/utility, I restarted XAMPP, put my websites through their paces, and the mysql_error.log file was free of any of the errors that had been reported previously.

I'm happy to supply additional information to help sort out the first problem, which would seem to be severe if others are experiencing it, and of course, I'm curious what the cause and solution will be, as I seemingly cannot create new users on my databases using the new XAMPP 5.6.14
TomXampp
 
Posts: 28
Joined: 12. March 2015 03:58
Operating System: Windows 8.1

Re: Problems and Solutions (well, kind of) for XAMPP 5.6.14

Postby Altrea » 28. October 2015 10:43

The first one is a known phpmyadmin problem with MariaDB. Phpmyadmin solved that with version 4.5.1
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8294
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: Problems and Solutions (well, kind of) for XAMPP 5.6.14

Postby TomXampp » 28. October 2015 15:55

Thank you, Altrea...I hadn't noticed that! The current XAMPP download for Windows includes a slightly earlier version, 4.5.0.x. I checked my previous XAMPP set-up (which I had archived) and I had version 4.5.1 on it, presumably because I installed 4.5.1 on it when I noticed it became available, but before I noticed the new version of Apache and did the fresh install of XAMPP. Perhaps the XAMPP folks should be notified that their current download needs to be revised to include 4.5.1. Thanks again.
TomXampp
 
Posts: 28
Joined: 12. March 2015 03:58
Operating System: Windows 8.1


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 74 guests