Can't run Apache

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Can't run Apache

Postby Salsj » 27. October 2015 14:16

Hello,
I'm very new to this, I just installed XAMPP v3.2.1 to start php & mysql code writing. However, it won't work. It shows the following message:
5:58:13 AM [main] Initializing Control Panel
5:58:13 AM [main] Windows Version: Windows 8 32-bit
5:58:13 AM [main] XAMPP Version: 5.6.14
5:58:13 AM [main] Control Panel Version: 3.2.1 [ Compiled: May 7th 2013 ]
5:58:13 AM [main] You are not running with administrator rights! This will work for
5:58:13 AM [main] most application stuff but whenever you do something with services
5:58:13 AM [main] there will be a security dialogue or things will break! So think
5:58:13 AM [main] about running this application with administrator rights!
5:58:13 AM [main] XAMPP Installation Directory: "c:\xampp\"
5:58:13 AM [main] Checking for prerequisites
5:58:14 AM [main] All prerequisites found
5:58:14 AM [main] Initializing Modules
5:58:14 AM [Apache] Problem detected!
5:58:14 AM [Apache] Port 80 in use by "Unable to open process" with PID 4668!
5:58:14 AM [Apache] Apache WILL NOT start without the configured ports free!
5:58:14 AM [Apache] You need to uninstall/disable/reconfigure the blocking application
5:58:14 AM [Apache] or reconfigure Apache and the Control Panel to listen on a different port
5:58:14 AM [Apache] Problem detected!
5:58:14 AM [Apache] Port 443 in use by "Unable to open process" with PID 4668!
5:58:14 AM [Apache] Apache WILL NOT start without the configured ports free!
5:58:14 AM [Apache] You need to uninstall/disable/reconfigure the blocking application
5:58:14 AM [Apache] or reconfigure Apache and the Control Panel to listen on a different port
5:58:14 AM [main] Starting Check-Timer
5:58:14 AM [main] Control Panel Ready
5:58:22 AM [Apache] Problem detected!
5:58:22 AM [Apache] Port 80 in use by "Unable to open process" with PID 4668!
5:58:22 AM [Apache] Apache WILL NOT start without the configured ports free!
5:58:22 AM [Apache] You need to uninstall/disable/reconfigure the blocking application
5:58:22 AM [Apache] or reconfigure Apache and the Control Panel to listen on a different port
5:58:22 AM [Apache] Problem detected!
5:58:22 AM [Apache] Port 443 in use by "Unable to open process" with PID 4668!
5:58:22 AM [Apache] Apache WILL NOT start without the configured ports free!
5:58:22 AM [Apache] You need to uninstall/disable/reconfigure the blocking application
5:58:22 AM [Apache] or reconfigure Apache and the Control Panel to listen on a different port
5:58:22 AM [Apache] Attempting to start Apache app...
5:58:22 AM [Apache] Status change detected: running
5:58:22 AM [Apache] Status change detected: stopped
5:58:22 AM [Apache] Error: Apache shutdown unexpectedly.
5:58:22 AM [Apache] This may be due to a blocked port, missing dependencies,
5:58:22 AM [Apache] improper privileges, a crash, or a shutdown by another method.
5:58:22 AM [Apache] Press the Logs button to view error logs and check
5:58:22 AM [Apache] the Windows Event Viewer for more clues
5:58:22 AM [Apache] If you need more help, copy and post this
5:58:22 AM [Apache] entire log window on the forums
5:58:25 AM [Apache] Problem detected!
5:58:25 AM [Apache] Port 80 in use by "Unable to open process" with PID 4668!
5:58:25 AM [Apache] Apache WILL NOT start without the configured ports free!
5:58:25 AM [Apache] You need to uninstall/disable/reconfigure the blocking application
5:58:25 AM [Apache] or reconfigure Apache and the Control Panel to listen on a different port
5:58:25 AM [Apache] Problem detected!
5:58:25 AM [Apache] Port 443 in use by "Unable to open process" with PID 4668!
5:58:25 AM [Apache] Apache WILL NOT start without the configured ports free!
5:58:25 AM [Apache] You need to uninstall/disable/reconfigure the blocking application
5:58:25 AM [Apache] or reconfigure Apache and the Control Panel to listen on a different port
5:58:25 AM [Apache] Attempting to start Apache app...
5:58:25 AM [Apache] Status change detected: running
5:58:26 AM [Apache] Status change detected: stopped
5:58:26 AM [Apache] Error: Apache shutdown unexpectedly.
5:58:26 AM [Apache] This may be due to a blocked port, missing dependencies,
5:58:26 AM [Apache] improper privileges, a crash, or a shutdown by another method.
5:58:26 AM [Apache] Press the Logs button to view error logs and check
5:58:26 AM [Apache] the Windows Event Viewer for more clues
5:58:26 AM [Apache] If you need more help, copy and post this
5:58:26 AM [Apache] entire log window on the forums
5:58:29 AM [mysql] Attempting to start MySQL app...
5:58:30 AM [mysql] Status change detected: running
5:58:39 AM [filezilla] Attempting to start FileZilla app...
5:58:39 AM [filezilla] Status change detected: running
5:58:40 AM [filezilla] Attempting to stop FileZilla app...
5:58:41 AM [filezilla] Status change detected: stopped
5:59:17 AM [Apache] Problem detected!
5:59:17 AM [Apache] Port 80 in use by "Unable to open process" with PID 4668!
5:59:17 AM [Apache] Apache WILL NOT start without the configured ports free!
5:59:17 AM [Apache] You need to uninstall/disable/reconfigure the blocking application
5:59:17 AM [Apache] or reconfigure Apache and the Control Panel to listen on a different port
5:59:17 AM [Apache] Problem detected!
5:59:17 AM [Apache] Port 443 in use by "Unable to open process" with PID 4668!
5:59:17 AM [Apache] Apache WILL NOT start without the configured ports free!
5:59:17 AM [Apache] You need to uninstall/disable/reconfigure the blocking application
5:59:17 AM [Apache] or reconfigure Apache and the Control Panel to listen on a different port
5:59:17 AM [Apache] Attempting to start Apache app...

Any kind of help is much appreciated!
Salsj
 
Posts: 8
Joined: 27. October 2015 14:11
Operating System: Windows 10

Re: Can't run Apache

Postby Nobbie » 27. October 2015 14:24

These are the main problems:

5:58:14 AM [Apache] Port 80 in use by "Unable to open process" with PID 4668!


and

5:58:14 AM [Apache] Port 443 in use by "Unable to open process" with PID 4668!


Find out, which programm runs with ProcessID (= PID) 4668 and configure that program not to use Port 80 & 443. It also happens, that users try to start Apache twice (they start it, even it already has started), this leads to the same error message.
Nobbie
 
Posts: 8770
Joined: 09. March 2008 13:04

Re: Can't run Apache

Postby Salsj » 27. October 2015 14:34

and How can I do that?
Salsj
 
Posts: 8
Joined: 27. October 2015 14:11
Operating System: Windows 10

Re: Can't run Apache

Postby Altrea » 27. October 2015 16:24

With help of the netstat button in your control panel for example
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8293
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: Can't run Apache

Postby Salsj » 27. October 2015 17:05

Any code examples?
Salsj
 
Posts: 8
Joined: 27. October 2015 14:11
Operating System: Windows 10

Re: Can't run Apache

Postby Altrea » 27. October 2015 17:53

There is no code.
Netstat is a little helper program which can get started in the control panel.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8293
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: Can't run Apache

Postby Salsj » 27. October 2015 18:10

Nothing in the control Panel. However, when I type Netstat in CMD, it shows different active connections, but then I don't know where to go from there
Salsj
 
Posts: 8
Joined: 27. October 2015 14:11
Operating System: Windows 10

Re: Can't run Apache

Postby Nobbie » 27. October 2015 18:11

Salsj wrote:and How can I do that?


As already said, a simple click on the "Netstat" button, or simply start the Windows Taskmanager.
Nobbie
 
Posts: 8770
Joined: 09. March 2008 13:04

Re: Can't run Apache

Postby Altrea » 27. October 2015 18:14

Image
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8293
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: Can't run Apache

Postby Salsj » 27. October 2015 18:26

Thanks for the pic, I opened netstat, but It's just a display menu. When I clicked on the items nothing happened
Salsj
 
Posts: 8
Joined: 27. October 2015 14:11
Operating System: Windows 10

Re: Can't run Apache

Postby Altrea » 27. October 2015 18:33

Don't expect that something happens, search the process with the PID 4668 or the processes capturing ports 80 and 443.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8293
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: Can't run Apache

Postby Salsj » 27. October 2015 19:59

After I find them, what's the next step?
Salsj
 
Posts: 8
Joined: 27. October 2015 14:11
Operating System: Windows 10

Re: Can't run Apache

Postby Altrea » 27. October 2015 20:24

Depending on what process it is there are different solving strategies.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8293
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: Can't run Apache

Postby Salsj » 27. October 2015 20:50

That's what I got :

Address port pid name
0.0.0.0 80 4668 httpd.exe
0.0.0.0 443 4668 httpd.exe
Salsj
 
Posts: 8
Joined: 27. October 2015 14:11
Operating System: Windows 10

Re: Can't run Apache

Postby Altrea » 27. October 2015 21:02

Thats great. Seems like Apache is already started.
Maybe this is already the Apache shipped with XAMPP.

Please close your control panel and restart it with elevated administration rights (rightclick -> run as administrator)
And tell us what the log window outputs
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8293
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Next

Return to XAMPP for Windows

Who is online

Users browsing this forum: DrSeussFreak and 55 guests