Error Accessing "User Accounts" from phpmyadmin

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Error Accessing "User Accounts" from phpmyadmin

Postby linuxs » 23. October 2015 16:24

Hello.
I installed the "new" XAMPP (5.6.14) - Fresh install - uninstall the old version and then installed this one.
Both (Apache and MySQL) run without any problem in XAMPP Control Panel.
When i go to User Accounts in phpmyadmin i can access it without any problem but when i restart my computer, run Apache and MySQL then go to phpmyadmin User Accounts it gives me SQL Query error:

Image

It never happened before.

I have already installed this XAMPP version on 3 pc's - Windows 10 home and all of them have the same error.

What could it be ? Thanks

UPDATE I have updated my phpmyadmin to the latest version (4.5.1.0 (2015-10-23)) and the problem continues.
linuxs
 
Posts: 12
Joined: 23. October 2015 16:03
Operating System: Windows 10 Home

Re: Error Accessing "User Accounts" from phpmyadmin

Postby coder1 » 26. October 2015 00:07

I have had the same issue with the latest XAMPP version 5.6.14.

I set up an issue thread at GitHub https://github.com/phpmyadmin/phpmyadmin/issues/11602

You can see in the thread there that lem9, one of the creators of phpMyAdmin project thinks the table db in MySQL database is corrupted and I could not repair it.

At least I'm not the only one with this bug. Would have put the screen shot in this but couldn't figure out how to do that. And the GitHub link I could not make a url address since it says it is OFF. New to this forum but the bug is out there and hope it gets fixed. Real problem not getting to User accounts and good luck adding new User accounts it took me forever, very unstable release.
coder1
 
Posts: 13
Joined: 25. October 2015 23:31
Operating System: Windows 8.1

Re: Error Accessing "User Accounts" from phpmyadmin

Postby NoMoreTears » 26. October 2015 01:15

You aren't using MySQL anymore. You are using MariaDB pretending to be MySQL.

Un-ironically, the two diverge in terms of commands and processes.

https://mariadb.com/
NoMoreTears
 
Posts: 6
Joined: 11. January 2011 03:57

Re: Error Accessing "User Accounts" from phpmyadmin

Postby coder1 » 26. October 2015 03:52

Notwithstanding what NoMoreTears notes, MariaDB version 10.0.17, the version in the current XAMPP stack, has table corruption issues whereas MariaDB version 10.0.21 does not have corruption issues and corruption of table likely db is the heart of this thread.

As I noted above, an issue thread I established in GitHub https://github.com/phpmyadmin/phpmyadmin/issues/11602 fully discusses this problem in that the MariaDB demo used in phpMyAdmin is MariaDB version 10.0.21 and it does not produce the SQL error that MariaDB version 10.0.17, provided in the current XAMPP stack, is occurring as noted in this thread.
coder1
 
Posts: 13
Joined: 25. October 2015 23:31
Operating System: Windows 8.1

Re: Error Accessing "User Accounts" from phpmyadmin

Postby linuxs » 29. October 2015 18:34

Well i still have this issue with this xampp stack.

And something i din't mention = When i restart my PC and try to run MySQL it just stops, (the Windows process stops working, cant even run it as a service, it wont run ).

What i did was uninstall everything and install the Bitnami stack = " https://bitnami.com/stack/wamp/installer " (WAMP Stack 5.6.14-0 Dev) and everything works great, but ofc i dont have MariaBD so you must be right, it is a "bug" in MariaBD.

Another thing, why is it that they don't include the newest version of MariaBD ( 10.1.8 ) in the stack ? Incompatibility issues ?
linuxs
 
Posts: 12
Joined: 23. October 2015 16:03
Operating System: Windows 10 Home

Re: Error Accessing "User Accounts" from phpmyadmin

Postby Nobbie » 29. October 2015 18:44

linuxs wrote:Another thing, why is it that they don't include the newest version of MariaBD ( 10.1.8 ) in the stack ?


Ask "them".
Nobbie
 
Posts: 8761
Joined: 09. March 2008 13:04

Re: Error Accessing "User Accounts" from phpmyadmin

Postby Beltran » 29. October 2015 22:06

Hi,

We are working on upgrading phpMyAdmin to the recently released 4.5.1.0 version that fixes this issue as soon as possible, thanks for posting it. We also ship the latest MariaDB 10.0.x stable version because it was safer to maintain the compatibility with MySQL server but we will also update to the latest 10.1.x if pass all our tests.
User avatar
Beltran
Power-User
 
Posts: 108
Joined: 22. March 2013 12:29
Operating System: Windows, Linux, OS X

Re: Error Accessing "User Accounts" from phpmyadmin

Postby linuxs » 29. October 2015 22:14

Beltran wrote:Hi,

We are working on upgrading phpMyAdmin to the recently released 4.5.1.0 version that fixes this issue as soon as possible, thanks for posting it. We also ship the latest MariaDB 10.0.x stable version because it was safer to maintain the compatibility with MySQL server but we will also update to the latest 10.1.x if pass all our tests.


Hi Beltran, thank you but when i update my phpMyAdmin to 4.5.1.0 the same error happens so i think "we" have to wait for the 4.5.2.0 or something, i dont know :mrgreen:
linuxs
 
Posts: 12
Joined: 23. October 2015 16:03
Operating System: Windows 10 Home

Re: Error Accessing "User Accounts" from phpmyadmin

Postby linuxs » 29. October 2015 22:31

Nobbie wrote:
linuxs wrote:Another thing, why is it that they don't include the newest version of MariaBD ( 10.1.8 ) in the stack ?


Ask "them".


Thanks for the contribution :D :D
linuxs
 
Posts: 12
Joined: 23. October 2015 16:03
Operating System: Windows 10 Home

Re: Error Accessing "User Accounts" from phpmyadmin

Postby coder1 » 30. October 2015 01:44

I'm running phpMyAdmin 4.5.1 and have loaded MariaDB 10.1.8 in my XAMPP stack to replace 10.0.17.

The whole thing's a complete train wreck.

Table db in database MySQL is completely unstable. I cannot add a user with PMA so I had to install HeidiSQL and only then could I add a user but could not drill down to give a user privileges to a particular database; thus, could only provide privileges at the global level. However, being the db table bug that it is, table db will, on occasion, populate with the users I've created and also the global privileges I've given them. However, when table db does show the users, that is when you get the error noted by linuxs in his original screen shot. And of course when that screen shot error appears you're not going to get to the PMA User accounts tab/page. And again, if the screen shot error does not present itself, one can access the User accounts tab/page and see the users you've created. However, clicking on the edit privileges is useless since table db is empty and thus you get an SQL error noting something to the effect that the MyISAM table was expecting more data than provided (i.e. no data is in the table db, duh).

Again, MairaDB, no matter what "stable" release is apparently doing a number on database MySQL and it seems in particular table db. I know lem9 has the demo in PMA working with MariaDB 10.0.21 and does have one user pma in table db of database MySQL. Yet, some of us are having serious problems with regard to User Management with the presence of MariaDB. And MariaDB is becoming a more widely used database server, the inclusion of said in the new stacks.
coder1
 
Posts: 13
Joined: 25. October 2015 23:31
Operating System: Windows 8.1

Re: Error Accessing "User Accounts" from phpmyadmin

Postby Nobbie » 30. October 2015 16:03

coder1 wrote:I'm running phpMyAdmin 4.5.1 and have loaded MariaDB 10.1.8 in my XAMPP stack to replace 10.0.17.

The whole thing's a complete train wreck.


Why do you use it? You have replaced phpmyadmin and as well MariaDB - so this is YOUR train wreck, it is not Xampp anymore. Replace Apache and PHP and nothing is left over....

Forget WIndows, get a nice Linux distribution and install everything from the repositories.
Nobbie
 
Posts: 8761
Joined: 09. March 2008 13:04

Re: Error Accessing "User Accounts" from phpmyadmin

Postby linuxs » 30. October 2015 17:10

Nobbie wrote:
coder1 wrote:I'm running phpMyAdmin 4.5.1 and have loaded MariaDB 10.1.8 in my XAMPP stack to replace 10.0.17.

The whole thing's a complete train wreck.


Why do you use it? You have replaced phpmyadmin and as well MariaDB - so this is YOUR train wreck, it is not Xampp anymore. Replace Apache and PHP and nothing is left over....

Forget WIndows, get a nice Linux distribution and install everything from the repositories.



I guess he was trying to solve the problem updating Xampp "components" (just testing) - The problem started not because he did this but because there is something wrong with this MariaBD- PhpMyAdmin stack.

Why would he forget Windows ??? Why would I forget Windows- If there is a Xampp stack where everything is pack and ready to install for windows and i WANT-NEED to use Windows just because there is some sort of problem i just have to give up and run Linux ?? For me that logic doesn't make sense.

Have you something that can- could be actually helpful to sort THIS out ?
linuxs
 
Posts: 12
Joined: 23. October 2015 16:03
Operating System: Windows 10 Home

Re: Error Accessing "User Accounts" from phpmyadmin

Postby coder1 » 30. October 2015 18:50

I think the sole focus of this thread, started by linuxs, is the very critical issue of efficient creation and administration of Users and their privileges both global as well as database and table specific. And this function needs to be effectively done primarily using PMA since it is in the stack.

To recap, for the people that hopefully can solve our very serious problem.

The week of October 19th I installed XAMPP v5.6.14. Made no component changes to the stack. It took four attempts to create new users with PMA version in the stack. Eventually the user got created and I could click on the link edit privileges to remove global privileges and assign privileges database specific. Also I had to click on the link edit privileges the fourth time in order to assign passwords to the user even though I put the password in when I created the user, the password would not stick until the fourth attempt. Table db in database MySQL did consistently retain the user data. At times the linuxs screen shot would appear when attempting to access the User accounts by clicking on the User accounts tab in PMA and other times powering up MySQL using XAMPP Control Panel v3.2.1 I could get into User accounts in PMA and could actually get through to the edit privileges function.

Because of the problems with XAMPP v5.6.14 and that lem9, one of the developers of PMA, noted my table db in database MySQL could be corrupted and I could not, based on his instructions, repair it. I installed MariaDB version 10.1.8. And I upgraded PMA to the current version. MariaDB version 10.1.8 has more bugs than the MariaDB version (10.0.17) that is in XAMPP v5.6.14. The table db does not consistently retain the user data. At times it is there and other times it is not. And, as I explained in my prior post, whether the table db is populated that determines which SQL error you get. I can not get to the edit user privileges function with MariaDB version 10.1.8 in the stack because you are going to get one SQL error if table db is populated (i.e. linxus screen shot) or the error noting the table is empty. Thus, it could be a function of my limited skill set, or the fact that compatibility of MariaDB and MySQL server are drifting away like two ships in the night.

And since MariaDB is going to be a significant database presence going forward, I certainly hope these problems can be quickly fixed.
coder1
 
Posts: 13
Joined: 25. October 2015 23:31
Operating System: Windows 8.1

Re: Error Accessing "User Accounts" from phpmyadmin

Postby Beltran » 30. October 2015 19:27

Hi,

We updated phpMyAdmin to 4.5.1 and MariaDB to 10.1.8. We also fixed this issue fixing the database and it seems it is working properly now. Could you check is working properly now on your side? We will release this version next week:


https://www.apachefriends.org/xampp-files/5.5.30/xampp-win32-5.5.30-1-VC11-installer.exe

md5: 31d36890dcf42168a0e5268ad2db1d72

https://www.apachefriends.org/xampp-files/5.6.14/xampp-win32-5.6.14-1-VC11-installer.exe

md5: 979b40e5ca6edb49f093666e807c41f3

Please post your feedback in this thread and we will be happy to improve next XAMPP versions. We continue working on the full integration of the phpMyAdmin advanced configuration to remove the error message.

Thanks!
User avatar
Beltran
Power-User
 
Posts: 108
Joined: 22. March 2013 12:29
Operating System: Windows, Linux, OS X

Re: Error Accessing "User Accounts" from phpmyadmin

Postby Nobbie » 30. October 2015 19:38

linuxs wrote:Why would he forget Windows ??? Why would I forget Windows


This is a well known basic question and i will not provide an answer to that. It is your problem to use Windows furthermore.

linuxs wrote:Have you something that can- could be actually helpful to sort THIS out ?


No, i am not interested in a WIndows solution.

I have a linux distribution including a Xampp installation and everything runs fine. There was the User Bug in PhpMyAdmin, but this is not disturbant, because i could create and administrate the User step by step. I just replaced PhpMyAdmin with the newest release 4.5.1 (but did not run any tests).
Nobbie
 
Posts: 8761
Joined: 09. March 2008 13:04

Next

Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 54 guests