Windows service pack 2

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Windows service pack 2

Postby Yana » 29. August 2004 09:14

I just installed Service pack 2 for Windows XP on my computer.
The XAMPP 1.3 is still working after updating windows, but only for localhost. Other virtual domains doesn't work. I tryed either names, either numbers (127.0.0.5 for example). I checked files hosts and httpd.conf but all show OK.

Before SP2 all were good
Yana
 
Posts: 11
Joined: 10. March 2004 16:34

Postby Wiedmann » 29. August 2004 09:37

You must open port 80 (and 443) for incomming connections in the Windows firewall.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby tonym » 29. August 2004 13:08

Also after installing SP2 it needed "NTOSKRNL.EXE" to be allowed unrestricted internet access with Bitgaurd firewall.
This had been turned off with the install of SP2
tonym
User avatar
tonym
 
Posts: 22
Joined: 15. February 2004 21:39

Postby Yana » 30. August 2004 10:22

Wiedmann wrote:You must open port 80 (and 443) for incomming connections in the Windows firewall.


How can I do it?
Also after installing SP2 it needed "NTOSKRNL.EXE" to be allowed unrestricted internet access with Bitgaurd firewall.
This had been turned off with the install of SP2

And how can I do that?

Please
Yana
 
Posts: 11
Joined: 10. March 2004 16:34

Postby tonym » 30. August 2004 10:44

Yana wrote:
Wiedmann wrote:You must open port 80 (and 443) for incomming connections in the Windows firewall.



And how can I do that?
Please


Yana, SP2 was designed to make windows more secure by default, therefore turns on the windows firewall by default and quite possibly turns other things off.

People would need to know the firewall that you are using, and I can only help with Bitguard, but I do know that before SP2 was installed
NTOSKRNL.EXE needed unrestricted access to allow incoming connections.
After SP2 was installed, I found that this had been changed to "allow Internet access" which means 1 way "out". Hence no incoming connections

Resetting this to "unrestricted" or "in/out" allowed incoming connections to the apache server as well.

I hope someone can help with your particlar firewall.
tonym
User avatar
tonym
 
Posts: 22
Joined: 15. February 2004 21:39

Postby Wiedmann » 30. August 2004 11:16

Yana wrote:
Wiedmann wrote:You must open port 80 (and 443) for incomming connections in the Windows firewall.


How can I do it?

Add Port:
http://www.microsoft.com/technet/commun ... 7121120120
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Yana » 30. August 2004 12:27

Add Port:

I did it. It didn't help
Then I turned my windows firewall OFF. It didn't help!
Yana
 
Posts: 11
Joined: 10. March 2004 16:34

Postby tonym » 30. August 2004 12:55

Yana wrote:
Add Port:

I did it. It didn't help
Then I turned my windows firewall OFF. It didn't help!


Did you try rebooting the system
tonym
User avatar
tonym
 
Posts: 22
Joined: 15. February 2004 21:39

Postby Yana » 30. August 2004 14:17

Of course!!!
Yana
 
Posts: 11
Joined: 10. March 2004 16:34

Postby Yana » 31. August 2004 12:36

Please, help me!
I have my firewall turned OFF. But I have the same problem.
Another problem - nobody now can't see my localhost (by local IP) from intranet, but before sevice pack they did see...
Yana
 
Posts: 11
Joined: 10. March 2004 16:34

Postby Golyc » 01. September 2004 02:14

they pc´s are runing sp2 too ???
Golyc
 
Posts: 25
Joined: 11. August 2004 01:48

Postby Yana » 01. September 2004 10:18

First - yes, second - no. Both have Windows XP Pro
________________

I have found something from Microsoft...
A lot of programms have a problem with Service Pack 2
http://support.microsoft.com/default.aspx?scid=kb;en-us;842242
Yana
 
Posts: 11
Joined: 10. March 2004 16:34

Postby Golyc » 02. September 2004 19:20

i think that if you diseble the firewall at the other pcs can hel ... didi you tried that ??? (DO it olny if the is the ower of internet conection ...)
Golyc
 
Posts: 25
Joined: 11. August 2004 01:48

Postby tHarry » 03. September 2004 09:34

hi!

at first MS sp2 does only allow 127.0.0.1.. all other (127.0.0.*) are not working! this has to do with security reasons.
Microsoft have had a Path to download for resolve this problem.
Now you only get it anymore by call with MS-Support-Center.
I found this patch with P2P.. but my System always freeze when i wan't to install... and in admin-account i get blue-screens and pc does reboot.
For more Information for 127.*: kb884020

secondly... The localhost must be reachable in the Intranet!
You just need to open Port 80 (or the port you defined in htdocs) in your Windows Firewall, and all will work fine.. there are 2 possibilities!
1.. you could open it in exeptions
2.. you could open it in advanced and select the networkcard witch is connected to the intranet.

greetz, harry
Whistler/Sp2, AMD2000+, Xampp 1.5.2,
Whistler/Sp2, P4/2Ghz, Xampp 1.5.2,
Apache und MySQL als Service
---------------
Max OS X 10.4 - iBook G4 - Xampp 0.5
tHarry
 
Posts: 54
Joined: 19. April 2003 17:58

Postby Yana » 07. September 2004 16:09

I can't call to microsoft support...
Is there another way to resolve problem with virtual domains?
Yana
 
Posts: 11
Joined: 10. March 2004 16:34

Next

Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 53 guests