Apache & mySQL running but not as service

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Apache & mySQL running but not as service

Postby tcloud » 24. September 2015 20:53

I had to reinstall Windows 10 from scratch and just used the control panel (xampp-control.exe) to start apache and mySQL. Everything seems to work okay but, when the computer is restarted, they are not running.

Running services.msc -- neither apache or mySQL show as a service.

Running the localhost - status (http://localhost/xampp/status.php) shows

Code: Select all
MySQL database    DEACTIVATED       
PHP    ACTIVATED       
HTTPS (SSL)    ACTIVATED       
Common Gateway Interface (CGI)    ACTIVATED       
Server Side Includes (SSI)    ACTIVATED       
SMTP Service    DEACTIVATED       
FTP Service    DEACTIVATED       
Tomcat Service    DEACTIVATED


But phpMyAdmin runs and I can access my databases just fine. (I don't use SMTP, FTP or Tomcat.)

What should I do? Do I install apache and mySQL as a service and, if so, how?

thanks,
Tom
tcloud
 
Posts: 17
Joined: 05. January 2012 15:14
Operating System: windows 7 64

Re: Apache & mySQL running but not as service

Postby melius2 » 25. September 2015 22:15

Use msconfig in order to configure it as a service and run it on startup.
.
melius2
 
Posts: 14
Joined: 21. September 2015 02:16
XAMPP version: 5.5.34
Operating System: Windows 8

Re: Apache & mySQL running but not as service

Postby Altrea » 25. September 2015 23:14

Start your control panel with enhanced administration rights (rightclick -> run as Administrator) and click on the red crosses to register services for specific modules.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8291
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: Apache & mySQL running but not as service

Postby tcloud » 25. September 2015 23:48

thanks, Altrea. I figured that out after reading the zip version install instructions. All is well now.
tcloud
 
Posts: 17
Joined: 05. January 2012 15:14
Operating System: windows 7 64


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 64 guests