I am unable to get Localhost to open in my browser

Problems with the Windows version of XAMPP, questions, comments, and anything related.

I am unable to get Localhost to open in my browser

Postby lazarus_om » 17. September 2015 07:04

Ever since I upgraded to WIN10 I have had issues with XAMPP. I have gone through a couple of the port management tutorials that talk about APACHE and needing port 80 to be free and I now have APACHE running according to the XAMPP control panel.

The Apache error log shows this:

Code: Select all
[Thu Sep 17 07:16:25.696603 2015] [ssl:warn] [pid 11020:tid 684] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Thu Sep 17 07:16:26.144900 2015] [ssl:warn] [pid 11020:tid 684] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Thu Sep 17 07:16:26.541345 2015] [mpm_winnt:notice] [pid 11020:tid 684] AH00455: Apache/2.4.16 (Win32) OpenSSL/1.0.1p PHP/5.6.12 configured -- resuming normal operations
[Thu Sep 17 07:16:26.541345 2015] [mpm_winnt:notice] [pid 11020:tid 684] AH00456: Apache Lounge VC11 Server built: Jul 12 2015 10:56:48
[Thu Sep 17 07:16:26.541345 2015] [core:notice] [pid 11020:tid 684] AH00094: Command line: 'C:\\xampp\\apache\\bin\\httpd.exe -d C:/xampp/apache'
[Thu Sep 17 07:16:26.559357 2015] [mpm_winnt:notice] [pid 11020:tid 684] AH00418: Parent: Created child process 7888
[Thu Sep 17 07:16:27.938273 2015] [ssl:warn] [pid 7888:tid 724] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Thu Sep 17 07:16:28.271494 2015] [ssl:warn] [pid 7888:tid 724] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Thu Sep 17 07:16:28.345543 2015] [mpm_winnt:notice] [pid 7888:tid 724] AH00354: Child: Starting 150 worker threads.
[Thu Sep 17 07:50:23.078405 2015] [ssl:warn] [pid 9916:tid 604] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Thu Sep 17 07:50:23.195182 2015] [core:warn] [pid 9916:tid 604] AH00098: pid file C:/xampp/apache/logs/httpd.pid overwritten -- Unclean shutdown of previous Apache run?
[Thu Sep 17 07:50:23.317268 2015] [ssl:warn] [pid 9916:tid 604] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Thu Sep 17 07:50:27.037484 2015] [mpm_winnt:notice] [pid 9916:tid 604] AH00455: Apache/2.4.16 (Win32) OpenSSL/1.0.1p PHP/5.6.12 configured -- resuming normal operations
[Thu Sep 17 07:50:27.037484 2015] [mpm_winnt:notice] [pid 9916:tid 604] AH00456: Apache Lounge VC11 Server built: Jul 12 2015 10:56:48
[Thu Sep 17 07:50:27.037484 2015] [core:notice] [pid 9916:tid 604] AH00094: Command line: 'c:\\xampp\\apache\\bin\\httpd.exe -d C:/xampp/apache'
[Thu Sep 17 07:50:27.040489 2015] [mpm_winnt:notice] [pid 9916:tid 604] AH00418: Parent: Created child process 10128
[Thu Sep 17 07:50:27.712249 2015] [ssl:warn] [pid 10128:tid 672] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Thu Sep 17 07:50:27.985501 2015] [ssl:warn] [pid 10128:tid 672] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Thu Sep 17 07:50:28.032227 2015] [mpm_winnt:notice] [pid 10128:tid 672] AH00354: Child: Starting 150 worker threads.


And the MySQL error log shows this:
Code: Select all
2015-09-17 07:17:53 7232 [Note] Plugin 'FEDERATED' is disabled.
2015-09-17 07:17:53 2acc InnoDB: Warning: Using innodb_additional_mem_pool_size is DEPRECATED. This option may be removed in future releases, together with the option innodb_use_sys_malloc and with the InnoDB's internal memory allocator.
2015-09-17 07:17:53 7232 [Note] InnoDB: Using atomics to ref count buffer pool pages
2015-09-17 07:17:53 7232 [Note] InnoDB: The InnoDB memory heap is disabled
2015-09-17 07:17:53 7232 [Note] InnoDB: Mutexes and rw_locks use Windows interlocked functions
2015-09-17 07:17:53 7232 [Note] InnoDB: Memory barrier is not used
2015-09-17 07:17:53 7232 [Note] InnoDB: Compressed tables use zlib 1.2.3
2015-09-17 07:17:53 7232 [Note] InnoDB: Not using CPU crc32 instructions
2015-09-17 07:17:53 7232 [Note] InnoDB: Initializing buffer pool, size = 16.0M
2015-09-17 07:17:53 7232 [Note] InnoDB: Completed initialization of buffer pool
2015-09-17 07:17:53 7232 [Note] InnoDB: Highest supported file format is Barracuda.
2015-09-17 07:17:53 7232 [Note] InnoDB: 128 rollback segment(s) are active.
2015-09-17 07:17:53 7232 [Note] InnoDB: Waiting for purge to start
2015-09-17 07:17:53 7232 [Note] InnoDB: 5.6.26 started; log sequence number 1665234
2015-09-17 07:17:53 7232 [Note] Server hostname (bind-address): '*'; port: 3306
2015-09-17 07:17:53 7232 [Note] IPv6 is available.
2015-09-17 07:17:53 7232 [Note]   - '::' resolves to '::';
2015-09-17 07:17:53 7232 [Note] Server socket created on IP: '::'.
2015-09-17 07:50:32 8312 [Note] Plugin 'FEDERATED' is disabled.
2015-09-17 07:50:32 22c8 InnoDB: Warning: Using innodb_additional_mem_pool_size is DEPRECATED. This option may be removed in future releases, together with the option innodb_use_sys_malloc and with the InnoDB's internal memory allocator.
2015-09-17 07:50:32 8312 [Note] InnoDB: Using atomics to ref count buffer pool pages
2015-09-17 07:50:32 8312 [Note] InnoDB: The InnoDB memory heap is disabled
2015-09-17 07:50:32 8312 [Note] InnoDB: Mutexes and rw_locks use Windows interlocked functions
2015-09-17 07:50:32 8312 [Note] InnoDB: Memory barrier is not used
2015-09-17 07:50:32 8312 [Note] InnoDB: Compressed tables use zlib 1.2.3
2015-09-17 07:50:32 8312 [Note] InnoDB: Not using CPU crc32 instructions
2015-09-17 07:50:32 8312 [Note] InnoDB: Initializing buffer pool, size = 16.0M
2015-09-17 07:50:32 8312 [Note] InnoDB: Completed initialization of buffer pool
2015-09-17 07:50:33 8312 [Note] InnoDB: Highest supported file format is Barracuda.
2015-09-17 07:50:33 8312 [Note] InnoDB: The log sequence numbers 1665234 and 1665234 in ibdata files do not match the log sequence number 1665244 in the ib_logfiles!
2015-09-17 07:50:33 8312 [Note] InnoDB: Database was not shutdown normally!
2015-09-17 07:50:33 8312 [Note] InnoDB: Starting crash recovery.
2015-09-17 07:50:33 8312 [Note] InnoDB: Reading tablespace information from the .ibd files...
2015-09-17 07:50:33 8312 [Note] InnoDB: Restoring possible half-written data pages
2015-09-17 07:50:33 8312 [Note] InnoDB: from the doublewrite buffer...
2015-09-17 07:50:34 8312 [Note] InnoDB: 128 rollback segment(s) are active.
2015-09-17 07:50:34 8312 [Note] InnoDB: Waiting for purge to start
2015-09-17 07:50:34 8312 [Note] InnoDB: 5.6.26 started; log sequence number 1665244
2015-09-17 07:50:34 8312 [Note] Server hostname (bind-address): '*'; port: 3306
2015-09-17 07:50:34 8312 [Note] IPv6 is available.
2015-09-17 07:50:34 8312 [Note]   - '::' resolves to '::';
2015-09-17 07:50:34 8312 [Note] Server socket created on IP: '::'.


Again, the XAMPP control panel shows everything running fine, but I get this:

This webpage is not available

ERR_CONNECTION_REFUSED


Everytime I try to go to Localhost on my browser. Can anyone help?
lazarus_om
 
Posts: 5
Joined: 17. September 2015 05:24
Operating System: Windows 10

Re: I am unable to get Localhost to open in my browser

Postby lazarus_om » 18. September 2015 12:59

So I checked the other possible solutions such as the other services that normally interfere with port 80. Everything seems to be running according to the XAMPP control panel. There is no indicator of why this thing won't display the homepage.
lazarus_om
 
Posts: 5
Joined: 17. September 2015 05:24
Operating System: Windows 10

Re: I am unable to get Localhost to open in my browser

Postby Altrea » 18. September 2015 14:19

full XAMPP control panel log?
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8294
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: I am unable to get Localhost to open in my browser

Postby lazarus_om » 18. September 2015 18:31

Code: Select all
6:37:29 AM  [main]    Initializing Control Panel
6:37:29 AM  [main]    Windows Version: Windows 8  64-bit
6:37:29 AM  [main]    XAMPP Version: 5.6.12
6:37:29 AM  [main]    Control Panel Version: 3.2.1  [ Compiled: May 7th 2013 ]
6:37:29 AM  [main]    You are not running with administrator rights! This will work for
6:37:29 AM  [main]    most application stuff but whenever you do something with services
6:37:29 AM  [main]    there will be a security dialogue or things will break! So think
6:37:29 AM  [main]    about running this application with administrator rights!
6:37:29 AM  [main]    XAMPP Installation Directory: "c:\xampp\"
6:37:29 AM  [main]    Checking for prerequisites
6:37:29 AM  [main]    All prerequisites found
6:37:29 AM  [main]    Initializing Modules
6:37:29 AM  [main]    Starting Check-Timer
6:37:29 AM  [main]    Control Panel Ready
6:37:33 AM  [Apache]    Attempting to start Apache app...
6:37:33 AM  [Apache]    Status change detected: running
6:38:16 AM  [mysql]    Attempting to start MySQL app...
6:38:16 AM  [mysql]    Status change detected: running
6:38:17 AM  [filezilla]    Attempting to start FileZilla app...
6:38:17 AM  [filezilla]    Status change detected: running
6:38:18 AM  [mercury]    Attempting to start Mercury app...
6:38:18 AM  [mercury]    Status change detected: running
6:38:18 AM  [Tomcat]    Attempting to start Tomcat app...
6:38:23 AM  [Tomcat]    Status change detected: running


I hope this is what you mean.
lazarus_om
 
Posts: 5
Joined: 17. September 2015 05:24
Operating System: Windows 10

Re: I am unable to get Localhost to open in my browser

Postby lazarus_om » 18. September 2015 18:35

Is there any other logs I should attempt to port over to this venue? Chrome seems to think that there's a firewall between my hard-drive and my browser.
lazarus_om
 
Posts: 5
Joined: 17. September 2015 05:24
Operating System: Windows 10


Return to XAMPP for Windows

Who is online

Users browsing this forum: dogmatic and 35 guests