Apache problem under Windows 10

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Apache problem under Windows 10

Postby DeVrije » 12. August 2015 15:37

After the automatic migration from Windows 7 to Windows 10 I got the Apache start problem according to the XAMPP Control Panel:
16:25:28 [main] Initializing Control Panel
16:25:28 [main] Windows Version: Windows 8 64-bit
16:25:28 [main] XAMPP Version: 5.6.8
16:25:28 [main] Control Panel Version: 3.2.1 [ Compiled: May 7th 2013 ]
16:25:28 [main] You are not running with administrator rights! This will work for
16:25:28 [main] most application stuff but whenever you do something with services
16:25:28 [main] there will be a security dialogue or things will break! So think
16:25:28 [main] about running this application with administrator rights!
16:25:28 [main] XAMPP Installation Directory: "c:\xampp\"
16:25:28 [main] Checking for prerequisites
16:25:31 [main] All prerequisites found
16:25:31 [main] Initializing Modules
16:25:31 [Apache] Problem detected!
16:25:31 [Apache] Port 80 in use by "Unable to open process" with PID 4!
16:25:31 [Apache] Apache WILL NOT start without the configured ports free!
16:25:31 [Apache] You need to uninstall/disable/reconfigure the blocking application
16:25:31 [Apache] or reconfigure Apache and the Control Panel to listen on a different port
16:25:31 [main] The FileZilla module is disabled
16:25:31 [main] The Mercury module is disabled
16:25:31 [main] The Tomcat module is disabled
16:25:31 [main] Starting Check-Timer
16:25:31 [main] Control Panel Ready

That problem does however NOT occur at my other pc which has been migrated from Windows 8 (eight) to Windows 10!

What should I to do in order to fix the above mentioned problem at my pc which has been migrated from Windows 7 (seven) to Windows 10!
DeVrije
 
Posts: 31
Joined: 26. April 2006 19:34

Re: Apache problem under Windows 10

Postby Nobbie » 12. August 2015 21:34

>Port 80 in use by "Unable to open process" with PID 4!

http://lmgtfy.com/?q=Port+80+in+use+by+ ... with+PID+4!
Nobbie
 
Posts: 8770
Joined: 09. March 2008 13:04

Re: Apache problem under Windows 10

Postby gustavo1976 » 19. August 2015 16:44

Los solucionaste? a mi me pasa lo mismo y no se que puede ser, despues de actualizar a windows 10 me da el mismo error
gustavo1976
 
Posts: 2
Joined: 19. August 2015 16:42
Operating System: windows 10

Re: Apache problem under Windows 10

Postby Nobbie » 19. August 2015 17:33

Write in English, no support for Spain.
Nobbie
 
Posts: 8770
Joined: 09. March 2008 13:04

Re: Apache problem under Windows 10

Postby gustavo1976 » 19. August 2015 18:30

Did you solved it? I have the samp problem when I updates to Windows 10
gustavo1976
 
Posts: 2
Joined: 19. August 2015 16:42
Operating System: windows 10

Re: Apache problem under Windows 10

Postby Altrea » 19. August 2015 20:04

We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8293
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: Apache problem under Windows 10

Postby DeVrije » 19. August 2015 20:48

To avoid some complex adaptations I have adapted only the file 'C:\Xampp\apache\conf\httpd.conf' by the replacement of the command 'Listen 80' by 'Listen 8080' (so using the other port). In order to process 'localhost/...' I used the command 'localhost:8080/...'. Then it does perfectly work! And the Skype does perfectly work as well.
DeVrije
 
Posts: 31
Joined: 26. April 2006 19:34

Re: Apache problem under Windows 10

Postby Altrea » 19. August 2015 21:58

Reasons why we don't recommend to change the Apache ports and a step by step tutorial about how to do it right (if still want to) can be found here:
[FGA] Changing the Apache default ports

Skype should not be a problem because you can configure Skype not to use port 80 and 443 as fallback in 99,9% without any negative influences (which is the recommend solution because Skype is not a webserver program so why should it capture webserver specific ports?). A step by step tutorial how to configure Skype that way can be found here:
[FGA] solving Port 80 & 443 in use by Skype issue
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8293
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: Apache problem under Windows 10

Postby berich56 » 21. August 2015 16:31

I found this on the windows 10 help forums. It solves the port 80 conflict issue. Control panel - Systems and Security - Programs - Turn windows features on or off.

It sounds like you enabled IIS during the upgrade. You can disable it by going to Programs and Features. Click on Turn Windows features on or off. Uncheck Internet Information Services and also Internet Information Services Hostable Web Core if it is checked. Click OK to remove those applications.
berich56
 
Posts: 1
Joined: 21. August 2015 16:24
Operating System: Windws 10


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 63 guests