Xampp keeps on crashing

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Xampp keeps on crashing

Postby perenboom » 06. August 2015 06:03

I have a new installation of Xampp running on a PC with Windows 10 and a laptop with Windows 10.
On both machines the first problem arrived with Apache unable to reach port 80 which was excluded by changing this port to 808.
So that problem is fixed.

But the major problem shows up in the Joomla!-installation.
When I try to make a categorie or try to save a module or even change language on the front end side of the website, the connection with localhost is gone!
The site is "offline" what is quite strange when you are working local...
It is impossible to say what is causing this and with which frequency. Sometimes everything goes fine for over 1 hour and the next moment it goes wrong 3 times in 1 minute.

Data:
Joomla!-version: 3.4.3
Template: JoomSpirit Full Screen 9
Plug-ins used: JCE 2.5.2

Has anyone got an idea how to fix this issue?
perenboom
 
Posts: 2
Joined: 06. August 2015 05:55
Operating System: Windows 10

Re: Xampp keeps on crashing

Postby Nobbie » 06. August 2015 22:12

perenboom wrote:which was excluded by changing this port to 808.
So that problem is fixed.


That does not fix the problem, it makes it even worse, Instead you should find out, why Port 80 is blocked (its Microsoft Internet Services) and stop that services.

perenboom wrote:When I try to make a categorie or try to save a module or even change language on the front end side of the website, the connection with localhost is gone!


Of course, because on "localhost" still listens Microsoft IIS, but Joomla/Xampp is now running on localhost:808. You must apply "localhost:808" in Joomla setup as host, not only "localhost". But as you can see, it is getting uglier and uglier. Never change Apache Port from 80 to another Port, even if some sites are recommending that. Its wrong.
Nobbie
 
Posts: 8779
Joined: 09. March 2008 13:04

Re: Xampp keeps on crashing

Postby perenboom » 07. August 2015 08:45

I have been searching for the cause of port 80 being taken by another service of Windows but I haven't found it.
So that is why I changed the port to 808.

Nobbie wrote:
perenboom wrote:
When I try to make a categorie or try to save a module or even change language on the front end side of the website, the connection with localhost is gone!


Of course, because on "localhost" still listens Microsoft IIS, but Joomla/Xampp is now running on localhost:808. You must apply "localhost:808" in Joomla setup as host, not only "localhost". But as you can see, it is getting uglier and uglier. Never change Apache Port from 80 to another Port, even if some sites are recommending that. Its wrong.


When you read this in the right way :wink: , you'll see that I am already logged in to Joomla!.
Otherwise, how would I be able to save a module or categorie.
So yes: I have changed "localhost" to "localhost:808". But that wasn't the reason of the crashes.

Instead it had to do with JCE.
The problem of the crashing Xampp installation is solved by changing the option Compress CSS in JCE from 'Yes' to 'No'.
After this, the crashing of Xampp is history.

So this thread can be closed.
perenboom
 
Posts: 2
Joined: 06. August 2015 05:55
Operating System: Windows 10


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 43 guests