Open website in Joomla article

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Open website in Joomla article

Postby bollenboer » 04. August 2015 12:50

Hello forum,
Using Joomla 3.4.3 and xampp 5.6.8

Making an article on my pc I try to open the frontend of the website to see the result.
But that is not possible: the message Page can not be found is coming up.
When saving and closing the article the website is visible.

I did the same on my laptop and got the same result.
This does not work very pleasant of course.

What is going wrong ?
bollenboer
 
Posts: 6
Joined: 29. July 2015 21:23
Operating System: windows 7

Re: Open website in Joomla article

Postby Nobbie » 04. August 2015 13:29

Probably a Joomla issue.
Nobbie
 
Posts: 8775
Joined: 09. March 2008 13:04

Re: Open website in Joomla article

Postby bollenboer » 05. August 2015 10:57

Hello Nobbis,
I made the same site on a subdomain of my host. No problem at all.
So I don't think it is caused bij Joomla.
It must have something to do with Xampp. Apache configuration may be ?
bollenboer
 
Posts: 6
Joined: 29. July 2015 21:23
Operating System: windows 7

Re: Open website in Joomla article

Postby Nobbie » 05. August 2015 11:18

The problem may also be caused by different Operating Systems, most hosts are based on Linux Systems, whereas your Xampp is running under Windows.

The main problem is, that nobody here can help you about that, because we would have to install Joomla (which i even dont know) and to debug it, what is going wrong.

Did you look into the access log and into the error log? This will probably give you quite more informations about what is going wrong.
Nobbie
 
Posts: 8775
Joined: 09. March 2008 13:04

Re: Open website in Joomla article

Postby bollenboer » 11. August 2015 21:45

Hello Nobbie,
I cannot find the solution. Joomla writes problem is Xampp. Xampp writes problem is Joomla. :(
bollenboer
 
Posts: 6
Joined: 29. July 2015 21:23
Operating System: windows 7

Re: Open website in Joomla article

Postby Altrea » 11. August 2015 22:08

It is 99,9% a Joomla problem.

How do you install Joomla?
Is this a fresh installation or a migration of a live server Joomla installation?
Which URL does your Browser show for a working Joomla request?
Which URL does your browser show at the time you get the 404 not found error?
What does your Apache access.log show?
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8294
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: Open website in Joomla article

Postby bollenboer » 15. August 2015 10:59

Hi Altrea,
Sorry for the late answer> But here are the stadia of making / showing an article on the frontend:

1 Url fort he whole content:
http://localhost/keukenprins/administrator/index.php?option=com_content
2 Url for a new article
http://localhost/keukenprins/administrator/index.php?option=com_content&view=article&layout=edit
3 Url after saving article
http://localhost/keukenprins/administrator/index.php?option=com_content&view=article&layout=edit&id=17
4 Url for looking at the frontend :
http://localhost/keukenprins/
Result:
Deze pagina kan niet worden weergegeven ( = page cannot be found)
No 404 error ! just this message
5 Url after saving and closing
http://localhost/keukenprins/administrator/index.php?option=com_content&view=articles

6 Url for looking at the frontend of the website ( now showing the complete content normally)
http://localhost/keukenprins/
bollenboer
 
Posts: 6
Joined: 29. July 2015 21:23
Operating System: windows 7


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 55 guests