port 80 being used Apache wont start

Problems with the Windows version of XAMPP, questions, comments, and anything related.

port 80 being used Apache wont start

Postby JonL92 » 19. July 2015 22:06

Heres what it says '

4:57:13 PM [main] Initializing Control Panel
4:57:13 PM [main] Windows Version: Windows 7 Home Premium SP1 64-bit
4:57:13 PM [main] XAMPP Version: 5.6.8
4:57:13 PM [main] Control Panel Version: 3.2.1 [ Compiled: May 7th 2013 ]
4:57:13 PM [main] You are not running with administrator rights! This will work for
4:57:13 PM [main] most application stuff but whenever you do something with services
4:57:13 PM [main] there will be a security dialogue or things will break! So think
4:57:13 PM [main] about running this application with administrator rights!
4:57:13 PM [main] XAMPP Installation Directory: "c:\xampp\"
4:57:13 PM [main] Checking for prerequisites
4:57:14 PM [main] All prerequisites found
4:57:14 PM [main] Initializing Modules
4:57:14 PM [Apache] Problem detected!
4:57:14 PM [Apache] Port 80 in use by "Unable to open process" with PID 6356!
4:57:14 PM [Apache] Apache WILL NOT start without the configured ports free!
4:57:14 PM [Apache] You need to uninstall/disable/reconfigure the blocking application
4:57:14 PM [Apache] or reconfigure Apache and the Control Panel to listen on a different port
4:57:14 PM [Apache] Problem detected!
4:57:14 PM [Apache] Port 443 in use by "Unable to open process" with PID 6356!
4:57:14 PM [Apache] Apache WILL NOT start without the configured ports free!
4:57:14 PM [Apache] You need to uninstall/disable/reconfigure the blocking application
4:57:14 PM [Apache] or reconfigure Apache and the Control Panel to listen on a different port
4:57:14 PM [main] Starting Check-Timer
4:57:14 PM [main] Control Panel Ready
4:57:27 PM [Apache] Problem detected!
4:57:27 PM [Apache] Port 80 in use by "Unable to open process" with PID 6356!
4:57:27 PM [Apache] Apache WILL NOT start without the configured ports free!
4:57:27 PM [Apache] You need to uninstall/disable/reconfigure the blocking application
4:57:27 PM [Apache] or reconfigure Apache and the Control Panel to listen on a different port
4:57:27 PM [Apache] Problem detected!
4:57:27 PM [Apache] Port 443 in use by "Unable to open process" with PID 6356!
4:57:27 PM [Apache] Apache WILL NOT start without the configured ports free!
4:57:27 PM [Apache] You need to uninstall/disable/reconfigure the blocking application
4:57:27 PM [Apache] or reconfigure Apache and the Control Panel to listen on a different port
4:57:27 PM [Apache] Attempting to start Apache app...
4:57:27 PM [Apache] Status change detected: running
4:57:27 PM [Apache] Status change detected: stopped
4:57:27 PM [Apache] Error: Apache shutdown unexpectedly.
4:57:27 PM [Apache] This may be due to a blocked port, missing dependencies,
4:57:27 PM [Apache] improper privileges, a crash, or a shutdown by another method.
4:57:27 PM [Apache] Press the Logs button to view error logs and check
4:57:27 PM [Apache] the Windows Event Viewer for more clues
4:57:27 PM [Apache] If you need more help, copy and post this
4:57:27 PM [Apache] entire log window on the forums
4:57:29 PM [mysql] Attempting to start MySQL app...
4:57:31 PM [mysql] Status change detected: running
4:57:38 PM [Apache] Problem detected!
4:57:38 PM [Apache] Port 80 in use by "Unable to open process" with PID 6356!
4:57:38 PM [Apache] Apache WILL NOT start without the configured ports free!
4:57:38 PM [Apache] You need to uninstall/disable/reconfigure the blocking application
4:57:38 PM [Apache] or reconfigure Apache and the Control Panel to listen on a different port
4:57:39 PM [Apache] Problem detected!
4:57:39 PM [Apache] Port 443 in use by "Unable to open process" with PID 6356!
4:57:39 PM [Apache] Apache WILL NOT start without the configured ports free!
4:57:39 PM [Apache] You need to uninstall/disable/reconfigure the blocking application
4:57:39 PM [Apache] or reconfigure Apache and the Control Panel to listen on a different port
4:57:39 PM [Apache] Attempting to start Apache app...
4:57:39 PM [Apache] Status change detected: running
4:57:39 PM [Apache] Status change detected: stopped
4:57:39 PM [Apache] Error: Apache shutdown unexpectedly.
4:57:39 PM [Apache] This may be due to a blocked port, missing dependencies,
4:57:39 PM [Apache] improper privileges, a crash, or a shutdown by another method.
4:57:39 PM [Apache] Press the Logs button to view error logs and check
4:57:39 PM [Apache] the Windows Event Viewer for more clues
4:57:39 PM [Apache] If you need more help, copy and post this
4:57:39 PM [Apache] entire log window on the forums


how do i get Apache to start
JonL92
 
Posts: 1
Joined: 19. July 2015 22:03
Operating System: Windows 7

Re: port 80 being used Apache wont start

Postby nasrin » 19. July 2015 22:18

Hey

So port 80 is blocked
JonL92 wrote:Heres what it says '
4:57:14 PM [Apache] Port 80 in use by "Unable to open process" with PID 6356!
4:57:14 PM [Apache] Apache WILL NOT start without the configured ports free!


This problem happens if you are using skype as skype uses the same port. Dont run skype for now then retry apache should work. if not try changing ports. my port 80 was also blocked and i stopped skype and re opened xampp, didnt really work so i changed my port to 81 which is working now.
configure the port no.80 to 81 (or to any other port) on apache (httpd.conf) file. This will fix the problem
nasrin
 
Posts: 6
Joined: 19. July 2015 20:58
Operating System: windows 7

Re: port 80 being used Apache wont start

Postby Altrea » 20. July 2015 01:35

There is a frequently given answer for it
=> [FGA] Apache won't start
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8286
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 50 guests