Tomcat Service and Kerberos

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Tomcat Service and Kerberos

Postby bma1 » 08. July 2015 18:29

Hi,

I am looking into configuring Kerberos authentication with my Apache server on a Windows 2008 R2 box. I have installed Heimdal Kerberos version from this link: https://www.secure-endpoints.com/heimdal/#download
I am trying to use this site for mod_auth_kerb, http://modauthkerb.sourceforge.net/install.html, but have gotten stuck. I have Codeblocks set to GNU GCC compiler. Running configure does not do anything. Does anyone have a direction they can point me in? Or a guide that would be helpful? Most of the searches I have done refers to Linux with Apache, not Windows. The few Windows one I found loop back to http://modauthkerb.sourceforge.net/install.html

On another note I just recently noticed something for the XAMPP control panel. I can start Tomcat with no issues, but once I install it as a service Tomcat doesn't start.

12:22:38 PM [Tomcat] Attempting to start Tomcat app...
12:22:40 PM [Tomcat] Status change detected: running
12:22:50 PM [Tomcat] Attempting to stop Tomcat
12:22:51 PM [Tomcat] Status change detected: stopped
12:22:57 PM [Tomcat] Installing service...
12:22:58 PM [Tomcat] Successful!
12:23:04 PM [Tomcat] Attempting to start Tomcat service...

I did open the XAMPP control panel as an admin and have tried setting the environment PATH variable, but no hits. Would anyone be able to point me in the direction of this issue for this?

Thanks
bma1
 
Posts: 9
Joined: 06. July 2015 19:12
Operating System: Windows 2008 R2

Re: Tomcat Service and Kerberos

Postby bma1 » 13. July 2015 17:24

After a lot research I discovered mod_auth_kerb is hard and a pain to use for Windows. SSPI mod_authnz_sspi.so is much easier to integrate for Windows Apache. It seems to work fine. Just need to properly configure it.

As for the Tomcat Service issue, I have not been able to resolve that. I guess no one has encountered this issue. Not sure what I did wrong with the XAMPP installation.
bma1
 
Posts: 9
Joined: 06. July 2015 19:12
Operating System: Windows 2008 R2


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 72 guests