Apache won't start after removing encryption

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Apache won't start after removing encryption

Postby zisdienst » 08. July 2015 11:13

We have XAMPP version 5.6.8 (which was not in the list when i just registered)

After installing XAMPP all directories were green, which means they where encrypted. Everything worked, but backup failed due to this encryption.

After removing the encryption Apache won't start again :(

12:05:22 [Apache] Status change detected: running
12:05:23 [Apache] Status change detected: stopped
12:05:23 [Apache] Error: Apache shutdown unexpectedly.
12:05:23 [Apache] This may be due to a blocked port, missing dependencies,
12:05:23 [Apache] improper privileges, a crash, or a shutdown by another method.
12:05:23 [Apache] Press the Logs button to view error logs and check
12:05:23 [Apache] the Windows Event Viewer for more clues
12:05:23 [Apache] If you need more help, copy and post this
12:05:23 [Apache] entire log window on the forums

Can anyone help to start Apache again please ? I'm totally new in XAMPP

Thx
zisdienst
 
Posts: 5
Joined: 08. July 2015 10:50
Operating System: w7

Re: Apache won't start after removing encryption

Postby glitzi85 » 08. July 2015 11:51

Please post at least the error.log from apache
User avatar
glitzi85
 
Posts: 1920
Joined: 05. March 2004 23:26
Location: Dahoim

Re: Apache won't start after removing encryption

Postby zisdienst » 08. July 2015 12:55

The Apache error.log only goes back till the moment it didn't start anymore ...

Maybe another log ? Any suggestions ?
zisdienst
 
Posts: 5
Joined: 08. July 2015 10:50
Operating System: w7

Re: Apache won't start after removing encryption

Postby Altrea » 08. July 2015 15:17

response of apache_start.bat?
entire contents of control panel log window?
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8286
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: Apache won't start after removing encryption

Postby zisdienst » 08. July 2015 16:04

This is the entire contents ...

Diese Eingabeforderung nicht waehrend des Running beenden
Bitte erst bei einem gewollten Shutdown schliessen
Please close this command only for Shutdown
Apache 2 is starting ...
(OS 5)Toegang geweigerd. : AH00091: httpd.exe: could not open error log file G:
/IntranetNIEUW/apache/logs/error.log.
AH00015: Unable to open logs

Apache konnte nicht gestartet werden
Apache could not be started
Druk op een toets om door te gaan. . .

13:45:28 [main] Initializing Control Panel
13:45:28 [main] Windows Version: Windows 7 Professional SP1 64-bit
13:45:28 [main] XAMPP Version: 5.6.8
13:45:28 [main] Control Panel Version: 3.2.1 [ Compiled: May 7th 2013 ]
13:45:28 [main] Running with Administrator rights - good!
13:45:28 [main] XAMPP Installation Directory: "g:\intranetnieuw\"
13:45:28 [main] Checking for prerequisites
13:45:30 [main] All prerequisites found
13:45:30 [main] Initializing Modules
13:45:30 [main] The FileZilla module is disabled
13:45:30 [main] The Mercury module is disabled
13:45:30 [main] Starting Check-Timer
13:45:30 [main] Control Panel Ready
13:45:35 [Apache] Attempting to start Apache app...
13:45:35 [Apache] Status change detected: running
13:45:36 [Apache] Status change detected: stopped
13:45:36 [Apache] Error: Apache shutdown unexpectedly.
13:45:36 [Apache] This may be due to a blocked port, missing dependencies,
13:45:36 [Apache] improper privileges, a crash, or a shutdown by another method.
13:45:36 [Apache] Press the Logs button to view error logs and check
13:45:36 [Apache] the Windows Event Viewer for more clues
13:45:36 [Apache] If you need more help, copy and post this
13:45:36 [Apache] entire log window on the forums

Thx
zisdienst
 
Posts: 5
Joined: 08. July 2015 10:50
Operating System: w7

Re: Apache won't start after removing encryption

Postby Altrea » 08. July 2015 19:45

zisdienst wrote:(OS 5)Toegang geweigerd. : AH00091: httpd.exe: could not open error log file G:

Windows error 5 is a authentication error. The user Apache tries to start with does not have the permission to access that ressource.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8286
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: Apache won't start after removing encryption

Postby zisdienst » 09. July 2015 09:11

Thx

Any idea where i can find this user Apache ? And where i can't change it's rights ?
zisdienst
 
Posts: 5
Joined: 08. July 2015 10:50
Operating System: w7

Re: Apache won't start after removing encryption

Postby zisdienst » 16. July 2015 16:37

completely started over with reinstalling xammp without encryption this time (this came after unzipping files on a W7 which had been zipped on a Mac)

thx for trying to solve my problem

case closed
zisdienst
 
Posts: 5
Joined: 08. July 2015 10:50
Operating System: w7


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 35 guests