phpMyAdmin

Problems with the Windows version of XAMPP, questions, comments, and anything related.

phpMyAdmin

Postby Maureenjones » 22. June 2015 12:14

Hello Everyone

I need to use phpMYAdmin.

I am using XAMPP v3.2.1

This is what I have done so far.
I have started Apache then, started MySQL then, click on "admin" to the right of MySQL to access phpMyAdmin.

I get the message that "this page can't be displayed". After trouble shooting, I get the message " the remote device or service won't accept the connection"

When I set XAMPP I had to use port 81 instead of the 3306. (my college needs to use SKYPE for consultation and training as I am an online student. Skype uses the same ports (it has been a monumental pest) Never-the-less I am stuck with this otherwise I don't get any practical help from the teachers.

XAMPP Localhost:81 is definitely working I can bring up any html page on which I am currently working (Dreamweaver or Visual Studio)
Would someone tell me how I can access phpMyAdmin given the above problems please? Or, what else can I do to access phpMyAdmin.
Thank you
Kind regards
Maureen Jones
Maureenjones
 
Posts: 3
Joined: 22. June 2015 11:28
Operating System: Windows 7 professional

Re: phpMyAdmin

Postby mark.mcdonald » 22. June 2015 15:19

Maureenjones wrote:I am using XAMPP v3.2.1

This version of xampp does not exist as the versions jumped from v1.8 to v5.5 / v5.6 with no other versions in between . Please see the versions listed here https://en.wikipedia.org/wiki/XAMPP
Maureenjones wrote:When I set XAMPP I had to use port 81 instead of the 3306.

XAMPP uses 2 ports. The conflicting one would be port 80. This is the same port skype uses and would cause you pain. However port 3306 is used for mysql (database and phpmyadmin)
If you changed 3306 at all this will cause you all database and phpmyadmin related problems.

You could set xampp to use port 8080 or port 81 instead of 80. 3306 should be left alone and dedicated to mysql for xampp.
However you can set skype to run on different ports so its still usable while allowing xampp to use the default ports viewtopic.php?f=22&t=69784&p=239058#p239060
mark.mcdonald
 
Posts: 160
Joined: 13. March 2015 15:48
Location: Edmonton
Operating System: Windows Server 2012 R2

Re: phpMyAdmin

Postby Maureenjones » 23. June 2015 06:32

Thank you Mark for your reply
Yes you are right. I was mistaken about what I said. I changed the port from 80 to 81 and everything has been working fine.

I have double checked through my.ini and mysql is still 3306.

However, I have checked Apache and MySQL AND FILEZILLA AND TOMCAT and after clicking on Admin - "fix connection problems" - says " the remote device or resource won't accept the connection, with a yellow triangle.
Kind regards
Maureen Jones
Maureenjones
 
Posts: 3
Joined: 22. June 2015 11:28
Operating System: Windows 7 professional

Re: phpMyAdmin

Postby mark.mcdonald » 23. June 2015 14:34

Have you done anything in xampp? Have you changed anything besides installing it? Are both apache and mysql green when trying to go to localhost? What have you done prior to getting this message? Did you change anything?
mark.mcdonald
 
Posts: 160
Joined: 13. March 2015 15:48
Location: Edmonton
Operating System: Windows Server 2012 R2

Re: phpMyAdmin

Postby Maureenjones » 23. June 2015 23:33

Hello Mark McDonald
Thank you again for your swift reply. You have no idea how much having someone reply like this is appreciated.
However,
I am running out of time to get my assessments in to keep trying to find where I went wrong. So, I took the easy way out and I shifted my files out of XAMPP and deleated it completely and downloaded it again and everything is now working sweetly. This later version doesn't seem to be bothered by SKYPE.
Kind regards
Maureen Jones
Maureenjones
 
Posts: 3
Joined: 22. June 2015 11:28
Operating System: Windows 7 professional


Return to XAMPP for Windows

Who is online

Users browsing this forum: JJ_Tagy and 79 guests