Apache keep crashing without any special behavior

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Apache keep crashing without any special behavior

Postby shayt » 14. June 2015 09:06

Hi,
i have recently installed XAMPP ver 5.6.8.
operating system win7 64.

this server runs Apache and MYSQL.
this server runs, LIVEZILLA chat server system.

so,
this is the deal,
once in a while, i see that Apache is down. when i log on to the windows server all i see is the windows error window. "Apache has stop responding"
when i click OK everything gets up again.

it can happen few times in 1 hour, and it cannot happen for a few days.

i have changed to this settings in the Apache conf file, as i saw here that it might be the solution....
EnableMMAP off
EnableSendfile off
AcceptFilter http none
AcceptFilter https none

but it's still the same...

the only thing that i see in the Error log is happening after i restart the service:
[Sat Jun 13 17:16:11.495972 2015] [authz_core:error] [pid 1960:tid 1536] [client 185.11.146.233:58602] AH01630: client denied by server configuration: C:/xampp/htdocs/xampp/phpmyadmin
[Sat Jun 13 17:16:12.057573 2015] [authz_core:error] [pid 1960:tid 1624] [client 185.11.146.233:58946] AH01630: client denied by server configuration: C:/xampp/htdocs/phpMyAdmin-2
[Sat Jun 13 17:16:13.289975 2015] [authz_core:error] [pid 1960:tid 1616] [client 185.11.146.233:59588] AH01630: client denied by server configuration: C:/xampp/phpMyAdmin/scripts/setup.php
[Sat Jun 13 17:16:13.414776 2015] [authz_core:error] [pid 1960:tid 1648] [client 185.11.146.233:59677] AH01630: client denied by server configuration: C:/xampp/htdocs/phpMyAdmin2
[Sat Jun 13 17:16:13.555176 2015] [authz_core:error] [pid 1960:tid 1608] [client 185.11.146.233:59768] AH01630: client denied by server configuration: C:/xampp/htdocs/phpMyAdmin3
[Sat Jun 13 18:31:49.699943 2015] [authz_core:error] [pid 1960:tid 1632] [client 186.151.122.4:62886] AH01630: client denied by server configuration: C:/xampp/htdocs/phpMyAdmin
[Sun Jun 14 10:29:16.659111 2015] [mpm_winnt:notice] [pid 3280:tid 252] AH00428: Parent: child process 1960 exited with status 3221225477 -- Restarting.
[Sun Jun 14 10:29:17.033512 2015] [ssl:warn] [pid 3280:tid 252] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Sun Jun 14 10:29:17.080312 2015] [mpm_winnt:notice] [pid 3280:tid 252] AH00455: Apache/2.4.12 (Win32) OpenSSL/1.0.1l PHP/5.6.8 configured -- resuming normal operations
[Sun Jun 14 10:29:17.080312 2015] [mpm_winnt:notice] [pid 3280:tid 252] AH00456: Apache Lounge VC11 Server built: Jan 28 2015 16:48:40
[Sun Jun 14 10:29:17.080312 2015] [core:notice] [pid 3280:tid 252] AH00094: Command line: 'c:\\xampp\\apache\\bin\\httpd.exe -d C:/xampp/apache'
[Sun Jun 14 10:29:17.080312 2015] [mpm_winnt:notice] [pid 3280:tid 252] AH00418: Parent: Created child process 700
[Sun Jun 14 10:29:17.704313 2015] [ssl:warn] [pid 700:tid 264] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Sun Jun 14 10:29:17.907113 2015] [ssl:warn] [pid 700:tid 264] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Sun Jun 14 10:29:17.953913 2015] [mpm_winnt:notice] [pid 700:tid 264] AH00354: Child: Starting 150 worker threads.


any Idea ?

thanks,
shay.
shayt
 
Posts: 3
Joined: 14. June 2015 08:46
Operating System: win 7

Re: Apache keep crashing without any special behavior

Postby gsmith » 14. June 2015 19:46

I think you should check the windows event log in your administrator tools. You should see something similar to this in there somewhere.
Description:
Faulting application httpd.exe, version 2.4.13.0, faulting module mod_telemetry.so, version 1.0.5.0, fault address 0x00001004.

This should give you some idea as to what is crashing. The access log then may lead you to what request is crashing it at the timestamp just before the error log note about child exiting. Look back through a few of them and you should have a pretty decent picture.

My guess is some third party module doesn't like something.
gsmith
 
Posts: 194
Joined: 29. November 2013 18:04
Location: San Diego
XAMPP version: 0.0.0
Operating System: Win XP to 2012R2/VS 6,9,11,14

Re: Apache keep crashing without any special behavior

Postby shayt » 15. June 2015 09:35

gsmith wrote:I think you should check the windows event log in your administrator tools. You should see something similar to this in there somewhere.
Description:
Faulting application httpd.exe, version 2.4.13.0, faulting module mod_telemetry.so, version 1.0.5.0, fault address 0x00001004.

This should give you some idea as to what is crashing. The access log then may lead you to what request is crashing it at the timestamp just before the error log note about child exiting. Look back through a few of them and you should have a pretty decent picture.

My guess is some third party module doesn't like something.


Hi,
thank you,

i have found this:

Faulting application name: httpd.exe, version: 2.4.12.0, time stamp: 0x54c90386
Faulting module name: ntdll.dll, version: 6.1.7601.17514, time stamp: 0x4ce7ba58
Exception code: 0xc0000005
Fault offset: 0x0002e39e
Faulting process id: 0x7a8
Faulting application start time: 0x01d0a1e832bfaef7
Faulting application path: C:\xampp\apache\bin\httpd.exe
Faulting module path: C:\Windows\SysWOW64\ntdll.dll
Report Id: 8c6f0701-11ee-11e5-bd87-005056b36612

any idea how to proceed ?

time stamp is 6/13/2015 8:06:37 PM (before the restart)
but i think that this is the real time that the server went down. (the Apache log only updated after i approved the windows message )
shayt
 
Posts: 3
Joined: 14. June 2015 08:46
Operating System: win 7

Re: Apache keep crashing without any special behavior

Postby Nobbie » 15. June 2015 13:11

shayt wrote:any idea how to proceed ?



http://pcsupport.about.com/od/fixthepro ... dlldll.htm
Nobbie
 
Posts: 8775
Joined: 09. March 2008 13:04

Re: Apache keep crashing without any special behavior

Postby shayt » 25. June 2015 13:32

hi,
thanks, but i couldn't find any help there or anywhere else.
also, it was actually stable for more then a week and then it started crashing again :\

i read somewhere that this is a known bug form earlier versions (httpd.exe crashing ntdll.dll) and that there is no answer to this.


is that true ?
is it caused by xampp ? will a standalone Apche also suffer this error ?


thanks,
shay,
shayt
 
Posts: 3
Joined: 14. June 2015 08:46
Operating System: win 7

Re: Apache keep crashing without any special behavior

Postby glitzi85 » 28. June 2015 16:52

You could try disabling all modules you are not using (in apache & php). Did you install any modules that are not shipped with XAMPP? Are you using the ldap or a special database module of php? I think I've had problems like that when using ldap (that was really long ago, can't remember in detail).

2.4.12 is the current stable version, so it is very unlikely that another build (except if you downgrad to an older version) will help.

ntdll is the core api for windows, so unfortunately there is really no easy way to determine which part of Apache or PHP caused this crash.
User avatar
glitzi85
 
Posts: 1920
Joined: 05. March 2004 23:26
Location: Dahoim


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 53 guests