Can't install dependencies via composer using XAMPP

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Can't install dependencies via composer using XAMPP

Postby Verax » 13. June 2015 08:58

Hi!

I'm trying to install some dependencies using composer. However, I get an error saying that I don't have the required PHP version (it says I have PHP 5.3.28 and that I need at least PHP 5.5.9), even though my XAMPP control panel says I have PHP 5.6.8. I have tried reinstalling XAMPP without any luck. Any ideas on how to fix this?
Verax
 
Posts: 4
Joined: 13. June 2015 08:54
Operating System: Windows

Re: Can't install dependencies via composer using XAMPP

Postby glitzi85 » 13. June 2015 11:01

Did you install PHP separately from XAMPP? Please execute this commands in a command prompt:
Code: Select all
php -v
echo %PATH%

and post the output here
User avatar
glitzi85
 
Posts: 1920
Joined: 05. March 2004 23:26
Location: Dahoim

Re: Can't install dependencies via composer using XAMPP

Postby Verax » 13. June 2015 14:09

No, I didn't install PHP seperately.

php -v result:

Code: Select all
PHP 5.3.28 (cli) (built: Dec 10 2013 22:06:17)
Copyright (c) 1997-2013 The PHP Group
Zend Engine v2.3.0, Copyright (c) 1998-2013 Zend Technologies


echo %PATH% result:

Code: Select all
C:\Program Files (x86)\iis express\PHP\v5.3;C:\ProgramData\Oracle\Java\javapath;
C:\Program Files (x86)\AMD APP\bin\x86_64;C:\Program Files (x86)\AMD APP\bin\x86
;C:\Program Files (x86)\Intel\iCLS Client\;C:\Program Files\Intel\iCLS Client\;C
:\Windows\system32;C:\Windows;C:\Windows\System32\Wbem;C:\Windows\System32\Windo
wsPowerShell\v1.0\;C:\Program Files\Intel\Intel(R) Management Engine Components\
DAL;C:\Program Files\Intel\Intel(R) Management Engine Components\IPT;C:\Program
Files (x86)\Intel\Intel(R) Management Engine Components\DAL;C:\Program Files (x8
6)\Intel\Intel(R) Management Engine Components\IPT;C:\Program Files (x86)\ATI Te
chnologies\ATI.ACE\Core-Static;C:\Program Files\Intel\WiFi\bin\;C:\Program Files
\Common Files\Intel\WirelessCommon\;C:\Program Files\Microsoft SQL Server\110\To
ols\Binn\;C:\Program Files\Microsoft SQL Server\120\Tools\Binn\;C:\Program Files
\Intel\WiFi\bin\;C:\Program Files\Common Files\Intel\WirelessCommon\;;C:\Windows
\System32\WindowsPowerShell\v1.0\;C:\Windows\System32\WindowsPowerShell\v1.0\;C:
\Program Files (x86)\Skype\Phone\;C:\Program Files (x86)\Windows Kits\8.1\Window
s Performance Toolkit\;C:\Program Files (x86)\Microsoft SDKs\TypeScript\1.0\;C:\
Program Files (x86)\Brackets\command;C:\Program Files\Intel\WiFi\bin\;C:\Program
 Files\Common Files\Intel\WirelessCommon\
Verax
 
Posts: 4
Joined: 13. June 2015 08:54
Operating System: Windows

Re: Can't install dependencies via composer using XAMPP

Postby Nobbie » 13. June 2015 15:28

Verax wrote:No, I didn't install PHP seperately.


Yes, you did.

As you can see in the PATH Variable, there is no Xampp folder included. Therefore "php.exe" is found somewhere else. The first entry of PATH looks very "suspicous": C:\Program Files (x86)\iis express\PHP\v5.3
That product is called "PHP53ForIISExpress'" and you must have enabled that in Microsoft WebMatrix or similar.
Nobbie
 
Posts: 8767
Joined: 09. March 2008 13:04

Re: Can't install dependencies via composer using XAMPP

Postby Verax » 13. June 2015 21:17

Ah.

I uninstalled ISS Express and removed the PHP folder from the program files (x86), and when I run the php -v command it says that it doesn't recognize PHP. echo %PATH% still gives me the same, even though program files (x86) iss express doesn't exists.
Verax
 
Posts: 4
Joined: 13. June 2015 08:54
Operating System: Windows

Re: Can't install dependencies via composer using XAMPP

Postby Altrea » 13. June 2015 21:29

XAMPP does not set any PATH variables, but there is a handy cli/cmd that enhanced the existing PATH variable temporary.
Open your XAMPP control panel and click the Shell Button to open it.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8288
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: Can't install dependencies via composer using XAMPP

Postby Verax » 13. June 2015 21:52

Altrea wrote:XAMPP does not set any PATH variables, but there is a handy cli/cmd that enhanced the existing PATH variable temporary.
Open your XAMPP control panel and click the Shell Button to open it.


Thanks :D
Verax
 
Posts: 4
Joined: 13. June 2015 08:54
Operating System: Windows


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 56 guests