Joomla Disappeared!

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Joomla Disappeared!

Postby tms » 29. May 2015 04:20

I've installed XAMPP and checked the box to install Joomla on top of XAMPP. It worked the first day but after a shutdown and reboot the next day Joomla seems to have disappeared?

I started the XAMPP control panel (v 3.2.1) and started both Apache and MySQL before trying:

http://localhost/joomlearn (what I named the database) but then nothing!

Sorry for the rookie question, but what am I doing wrong!

Thanks
tms
 
Posts: 2
Joined: 29. May 2015 04:05
Operating System: Windows 8

Re: Joomla Disappeared!

Postby Altrea » 29. May 2015 12:18

You must not add the name of the database to the url but the name of the application.

Don't know which alias bitnami gives these apps.
Try http://localhost/joomla
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8290
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: Joomla Disappeared!

Postby Nobbie » 29. May 2015 13:49

You must apply the name of the subfolder (which must be beyond c:/xampp/htdocs), where you installed Joomla. For example, if you installed Joomla to c:/xampp/htdocs/joomla, you have to enter http://localhost/joomla

If you installed it directly into htdocs (without subfolder), only enter http://localhost
Nobbie
 
Posts: 8768
Joined: 09. March 2008 13:04

Re: Joomla Disappeared!

Postby Altrea » 29. May 2015 14:29

Nobbie wrote:You must apply the name of the subfolder (which must be beyond c:/xampp/htdocs), where you installed Joomla.

Badly not. AFAIK Bitnami Apps install itself to \xampp\apps\ and will be routed by an alias.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8290
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: Joomla Disappeared!

Postby Nobbie » 29. May 2015 15:04

Altrea wrote: AFAIK Bitnami Apps install itself to \xampp\apps\ and will be routed by an alias.


Oh - AFAIK Bitnami Joomla comes with a standalone fully configured Webserver environment (we had an issue here that a Bitnami Joomla collides with a Xampp installation a few weeks ago). I would not install Joomla from Bitnami.

See viewtopic.php?f=16&t=70742&p=242280#p242280

(and inside there see the error message: "Port 80 in use by ""C:\Bitnami\JOOMLA~1.0-0\apache2\bin\httpd.exe" -k runservice" with PID 1908!", that is a clear hint that Bitnami already installs another Apache under Joomla!).
Nobbie
 
Posts: 8768
Joined: 09. March 2008 13:04

Re: Joomla Disappeared!

Postby Altrea » 29. May 2015 15:14

There is a difference between bitnami Joomla module installer (for XAMPP) (https://bitnami.com/stack/xampp#joomla ~18MB) and Bitnami Joomla installer (https://bitnami.com/stack/joomla/installer ~76MB). First one is linked on the orange XAMPP Administration page and installed like i described and second one comes with a full webserver environment.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8290
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: Joomla Disappeared!

Postby Nobbie » 29. May 2015 15:17

I would not use Bitnami Joomla in ANY case...
Nobbie
 
Posts: 8768
Joined: 09. March 2008 13:04

Re: Joomla Disappeared!

Postby Altrea » 29. May 2015 15:27

Nor me
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8290
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: Joomla Disappeared!

Postby tms » 29. May 2015 19:53

Thanks for the replies!

If I'm reading the replies correctly, the best course of action now is to uninstall Bitnami and then install Joomla right from Joomla.org?

Thanks.
tms
 
Posts: 2
Joined: 29. May 2015 04:05
Operating System: Windows 8

Re: Joomla Disappeared!

Postby Nobbie » 29. May 2015 20:02

Yes!
Nobbie
 
Posts: 8768
Joined: 09. March 2008 13:04


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 55 guests