XAMPP apache win 7 64 bit - running SLOW

Problems with the Windows version of XAMPP, questions, comments, and anything related.

XAMPP apache win 7 64 bit - running SLOW

Postby tomi.aurednik » 28. May 2015 13:46

Hi,

XAMPP apache win 7 64 bit - running SLOW
HP ProLiant M310, Intel Xeon 3065, 2,33GH, HDD 250GB 7,2k RAID 1
XAMPP CP v3.2.1, Apache/2.4.9 (Win32) OpenSSL/1.0.1g PHP/5.5.11 Server at 8000plus.si Port 80
More data: http://8000plus.si/version.php
Line: 50/10 MB , speedtest cofirm the speed. (http://www.speedtest.net/my-result/4391856690)

For test I use:
http://tools.pingdom.com/fpt/
https://developers.google.com/speed/pagespeed/insights/

I'm using xampp for production and works slow!
The Task Manager shows "Apache.exe *32" running twice. "mysqld.exe *32" is also running.

I checked:

1. AVG antivirus & firewall has no effect to speed.
2. Windows Defender and Security Essentials disabled on the Win7 machine
3. I set The DWORD values (64 bit) (https://community.apachefriends.org/f/viewtopic.php?f=16&t=47453&p=192011&hilit=slow#p192011)
4. I set host (127.0.0.1 127.0.0.1; 127.0.0.1 localhost)
5. Trace rout are fine. (tracert 8000plus.si)

I change next lines in next files:
Apache httpd.conf

EnableMMAP On
EnableSendfile Off


Php.ini
Set nex lines:

memory_limit = 256M
max_execution_time=300;
max_input_time=-1
upload_max_filesize=25M;
post_max_size=20M;
max_input_vars=10000

Zlib.output_compression = 4096
zend_extension = "C:\xampp\php\ext\php_eaccelerator_ts.dll"
Comment the lines with XDEBUG:
display_errors=On to =Off

instal memcache
extension=php_memcache.dll
[Memcache]
memcache.allow_failover = 1
memcache.max_failover_attempts=20
memcache.chunk_size =8192
memcache.default_port = 11211

My.ini

[mysqld]
port= 3306
socket = "C:/xampp/mysql/mysql.sock"
basedir = "C:/xampp/mysql"
tmpdir = "C:/xampp/tmp"
datadir = "C:/xampp/mysql/data"
pid_file = "mysql.pid"
# enable-named-pipe
key_buffer = 16M
max_allowed_packet = 1M
sort_buffer_size = 512K
net_buffer_length = 8K
read_buffer_size = 256K
read_rnd_buffer_size = 512K
myisam_sort_buffer_size = 8M
log_error = "mysql_error.log"
max_connections=500


Web sites works, but responsiv time from server is very bad.
Any help will be appreciated

Br,
Tomi Aurednik
tomi.aurednik
 
Posts: 4
Joined: 27. May 2015 20:04
Operating System: win 7 64 bit

Re: XAMPP apache win 7 64 bit - running SLOW

Postby Nobbie » 28. May 2015 14:23

When i call http://8000plus.si/ its pretty fast. Nothing to worry about.

When i enter that site in http://tools.pingdom.com/fpt/, it tells me, the Performance Grade is 81/100 (very good) and finally it says: "Your website is faster than 86% of all tested websites".
Nobbie
 
Posts: 8775
Joined: 09. March 2008 13:04

Re: XAMPP apache win 7 64 bit - running SLOW

Postby tomi.aurednik » 28. May 2015 15:00

Hi,
You shold test: http://vodnar-letral.si or s-bazeni.si
problem is that load time is very poor ... I test on one difrent server and load time was less then 1 sec for bouth this pages.
Here I have load time 5 - 10s ...
Thank you
tomi.aurednik
 
Posts: 4
Joined: 27. May 2015 20:04
Operating System: win 7 64 bit

Re: XAMPP apache win 7 64 bit - running SLOW

Postby gsmith » 29. May 2015 03:01

Well, your speedtest result says 10Mb, megabit not megabyte. 8 bits to a byte so you have ~ 1.25 megabytes per second. Also, to get a better idea it's good to do a couple tests from different locations, this will more reflect a real world scenario. If I test at ~50 miles it's much much faster than say ~5,000 miles.

Those large images above the menu are the slowest thing to load for me, for instance, the wire wheel one. It's 746KB and takes about a second to load for me. All in all I think the site loads up nice but for those large images.
gsmith
 
Posts: 194
Joined: 29. November 2013 18:04
Location: San Diego
XAMPP version: 0.0.0
Operating System: Win XP to 2012R2/VS 6,9,11,14

Re: XAMPP apache win 7 64 bit - running SLOW

Postby tomi.aurednik » 29. May 2015 08:15

speed test 50/10 Mb , you are correct (my mistake, sorry)
~50 miles it's much much faster than say ~5,000 miles.
It's also true.
Large image, I know ... I did optimization in PS, but I do not know how to more optimized without losing the size and quality?
Thank you
tomi.aurednik
 
Posts: 4
Joined: 27. May 2015 20:04
Operating System: win 7 64 bit

Re: XAMPP apache win 7 64 bit - running SLOW

Postby Nobbie » 29. May 2015 11:18

tomi.aurednik wrote:You shold test: http://vodnar-letral.si or s-bazeni.si


Both no problem here, load time approx. 1 or 2 seconds, a short wait and then the site "flashes" into the screen. Nothing to worry about. The are two things which takes quite long:

a) the Google Map on http://vodnar-letral.si, which shows up in the bottom. But i think you iframed that one, so its not an server issue from your PC.

b) a "ressource" (i did not analyze, what it is) from fcdn*profile***.net (or similar, i think its advertising, I could not read that quick enough), i dont know what it is.

But all in all, its not slow.

The Pingdom Website Speedtest tells me for s-bazeni.si, that its performance grade is 76/100, 66 Requests, 4,18s Load Time and 2,2MB total Page Size. That results in approx. 4-5 Mb/s speed, absolutely Ok for a private server. Anyway, I do not recommend to run Xampp on a private PC, a hosted Webspace is connected by far faster and it is maintained by a professional hoster. You also do not save money with your own PC, as you need lots of power for running your PC 24/7.
Nobbie
 
Posts: 8775
Joined: 09. March 2008 13:04

Re: XAMPP apache win 7 64 bit - running SLOW

Postby tomi.aurednik » 29. May 2015 12:16

Thanks for your reply.

But I'm hosting pro websites.
tomi.aurednik
 
Posts: 4
Joined: 27. May 2015 20:04
Operating System: win 7 64 bit


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 45 guests