XAMPP error message

Problems with the Windows version of XAMPP, questions, comments, and anything related.

XAMPP error message

Postby mugger1952 » 26. May 2015 18:27

I am trying to set up and start xampp.

In the control panel, when I attempt to start the Apache module, I get the following error:

1:23:10 PM [Apache] Attempting to start Apache service...
1:23:11 PM [Apache] Status change detected: running
1:23:14 PM [Apache] Status change detected: stopped
1:23:14 PM [Apache] Error: Apache shutdown unexpectedly.
1:23:14 PM [Apache] This may be due to a blocked port, missing dependencies,
1:23:14 PM [Apache] improper privileges, a crash, or a shutdown by another method.
1:23:14 PM [Apache] Press the Logs button to view error logs and check
1:23:14 PM [Apache] the Windows Event Viewer for more clues
1:23:14 PM [Apache] If you need more help, copy and post this
1:23:14 PM [Apache] entire log window on the forums

OK, so Here is the error log:

[Tue May 26 13:04:19.342292 2015] [ssl:warn] [pid 4976:tid 340] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Tue May 26 13:04:19.749315 2015] [ssl:warn] [pid 4976:tid 340] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Tue May 26 13:04:19.951327 2015] [mpm_winnt:notice] [pid 4976:tid 340] AH00455: Apache/2.4.12 (Win32) OpenSSL/1.0.1l PHP/5.6.8 configured -- resuming normal operations
[Tue May 26 13:04:19.951327 2015] [mpm_winnt:notice] [pid 4976:tid 340] AH00456: Apache Lounge VC11 Server built: Jan 28 2015 16:48:40
[Tue May 26 13:04:19.952327 2015] [core:notice] [pid 4976:tid 340] AH00094: Command line: 'C:\\xampp\\apache\\bin\\httpd.exe -d C:/xampp/apache'
[Tue May 26 13:04:19.958327 2015] [mpm_winnt:notice] [pid 4976:tid 340] AH00418: Parent: Created child process 6784
[Tue May 26 13:04:21.043389 2015] [ssl:warn] [pid 6784:tid 240] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Tue May 26 13:04:21.464413 2015] [ssl:warn] [pid 6784:tid 240] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Tue May 26 13:04:21.581420 2015] [mpm_winnt:crit] [pid 6784:tid 240] (OS 109)The pipe has been ended. : AH00404: Child: Unable to read socket data from parent
[Tue May 26 13:04:21.781431 2015] [mpm_winnt:crit] [pid 4976:tid 340] AH00427: Parent: child process 6784 exited with status 3 -- Aborting.

I am not a wizbang programmer type, so I need a little guidance in what this means and how to solve it. Can anyone help or do I need to delete xampp and try another solution?
mugger1952
 
Posts: 1
Joined: 26. May 2015 18:16
Operating System: WIN 7

Re: XAMPP error message

Postby mark.mcdonald » 26. May 2015 18:49

mugger1952 wrote:1:23:14 PM [Apache] Error: Apache shutdown unexpectedly.
1:23:14 PM [Apache] This may be due to a blocked port, missing dependencies,
1:23:14 PM [Apache] improper privileges, a crash, or a shutdown by another method.
1:23:14 PM [Apache] Press the Logs button to view error logs and check
1:23:14 PM [Apache] the Windows Event Viewer for more clues
1:23:14 PM [Apache] If you need more help, copy and post this
1:23:14 PM [Apache] entire log window on the forums
[Tue May 26 13:04:21.581420 2015] [mpm_winnt:crit] [pid 6784:tid 240] (OS 109)The pipe has been ended. : AH00404: Child: Unable to read socket data from parent
[Tue May 26 13:04:21.781431 2015] [mpm_winnt:crit] [pid 4976:tid 340] AH00427: Parent: child process 6784 exited with status 3 -- Aborting.

These times don't line up. These errors in the log are before you tried starting apache service and before it shut down. But here are some things to look at to help solve this:
-> Go to Control Panel -> Administrative Tools -> Services. Find "Web Deployment Agent Service" right click and stop. Start up Apache and see if it sticks. If so, right click on Web Deployment Agent again and go to properties and set the startup type to Manual.
-> viewtopic.php?f=16&t=69784
mark.mcdonald
 
Posts: 160
Joined: 13. March 2015 15:48
Location: Edmonton
Operating System: Windows Server 2012 R2


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 53 guests