Portable XAMPP

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Portable XAMPP

Postby dpuk44 » 20. May 2015 21:20

Hi everyone,

I am trying to set up XAMPP on my external hard drive. I have tried installing it from the exe file and using the zip folder, but when I open xampp-control I get the following:

21:18:40 [main] All prerequisites found
21:18:40 [main] Initializing Modules
21:18:40 [mysql] Problem detected!
21:18:40 [mysql] Port 3306 in use by "c:\xampp\mysql\bin\mysqld.exe"!
21:18:40 [mysql] MySQL WILL NOT start without the configured ports free!
21:18:40 [mysql] You need to uninstall/disable/reconfigure the blocking application
21:18:40 [mysql] or reconfigure MySQL and the Control Panel to listen on a different port
21:18:40 [main] Starting Check-Timer
21:18:40 [main] Control Panel Ready

I also have a local copy of XAMPP (not running at the same time). Is that what seems to be causing the error?
dpuk44
 
Posts: 8
Joined: 14. May 2015 20:02
Operating System: Windows 7

Re: Portable XAMPP

Postby mark.mcdonald » 20. May 2015 21:29

dpuk44 wrote:21:18:40 [mysql] Port 3306 in use by "c:\xampp\mysql\bin\mysqld.exe"!

Make sure your local copy is not running mysql and if installed as a service that the service is not running. Notice Apache's ports are not being used but MySQL's are (point being it is possible to install to external hard drive). Otherwise I would type cmd in your windows search bar and bring up Command Prompt then type netstat -o and see what's using that port. Try this and message back if you are still experiencing this problem or if it was resolved.
mark.mcdonald
 
Posts: 160
Joined: 13. March 2015 15:48
Location: Edmonton
Operating System: Windows Server 2012 R2

Re: Portable XAMPP

Postby dpuk44 » 21. May 2015 13:19

Hi,

Thanks for your reply. OK I did as you said and still no luck :( really want this to work.

Below is what netstat -o produces. I can't see that port number in use.

Microsoft Windows [Version 6.1.7601]
Copyright (c) 2009 Microsoft Corporation. All rights reserved.

C:\Users\Daley>netstat -o

Active Connections

Proto Local Address Foreign Address State PID
TCP 127.0.0.1:49174 Daley-SamsungS3:52001 ESTABLISHED 3740
TCP 127.0.0.1:49175 Daley-SamsungS3:52001 ESTABLISHED 3740
TCP 127.0.0.1:49176 Daley-SamsungS3:52001 ESTABLISHED 3740
TCP 127.0.0.1:49177 Daley-SamsungS3:52001 ESTABLISHED 3740
TCP 127.0.0.1:52001 Daley-SamsungS3:49174 ESTABLISHED 3740
TCP 127.0.0.1:52001 Daley-SamsungS3:49175 ESTABLISHED 3740
TCP 127.0.0.1:52001 Daley-SamsungS3:49176 ESTABLISHED 3740
TCP 127.0.0.1:52001 Daley-SamsungS3:49177 ESTABLISHED 3740
TCP 192.168.0.4:49354 yv-in-f188:5228 ESTABLISHED 2152
TCP 192.168.0.4:49381 mia07s24-in-f10:https TIME_WAIT 0
TCP 192.168.0.4:49415 NUS2000:netbios-ssn ESTABLISHED 4
TCP 192.168.0.4:49422 mia07s26-in-f13:https TIME_WAIT 0
TCP 192.168.0.4:49423 yv-in-f104:https ESTABLISHED 2152
TCP 192.168.0.4:49424 mia07s27-in-f14:https ESTABLISHED 2152
TCP 192.168.0.4:49427 mia07s27-in-f14:https ESTABLISHED 2152
TCP 192.168.0.4:49429 mia07s34-in-f4:http ESTABLISHED 2152
TCP 192.168.0.4:49432 mia07s25-in-f8:https ESTABLISHED 2152
TCP 192.168.0.4:49448 mia07s27-in-f6:https ESTABLISHED 2152
TCP 192.168.0.4:49464 a23-210-165-57:https ESTABLISHED 2152
TCP 192.168.0.4:49465 62.67.193.41:https ESTABLISHED 2152
TCP 192.168.0.4:49468 a23-210-167-168:https ESTABLISHED 2152
TCP 192.168.0.4:49471 a23-210-165-8:https ESTABLISHED 2152
TCP 192.168.0.4:49473 mia07s27-in-f2:https ESTABLISHED 2152
TCP 192.168.0.4:49474 208.71.123.98:https ESTABLISHED 2152
TCP 192.168.0.4:49479 mia07s24-in-f6:https ESTABLISHED 2152
TCP 192.168.0.4:49480 mia07s27-in-f2:https ESTABLISHED 2152
TCP 192.168.0.4:49487 mia07s25-in-f3:https ESTABLISHED 2152
TCP 192.168.0.4:49491 74.121.142.74:https ESTABLISHED 2152
TCP 192.168.0.4:49499 rproxy1:https ESTABLISHED 2152
TCP 192.168.0.4:49504 a23-13-73-26:https ESTABLISHED 2152
TCP 192.168.0.4:49508 mia07s26-in-f14:https ESTABLISHED 2152
TCP 192.168.0.4:49509 mia07s34-in-f14:https ESTABLISHED 2152
TCP 192.168.0.4:49545 a-g01s02:https ESTABLISHED 2152
TCP 192.168.0.4:49548 mia07s27-in-f8:https ESTABLISHED 2152
TCP 192.168.0.4:49550 ec2-54-72-91-65:https ESTABLISHED 2152
TCP 192.168.0.4:49551 mia07s25-in-f2:https ESTABLISHED 2152
TCP 192.168.0.4:49552 mia07s26-in-f14:https ESTABLISHED 2152
TCP 192.168.0.4:49553 64.233.176.154:https ESTABLISHED 2152
TCP 192.168.0.4:49554 64.233.177.141:https ESTABLISHED 2152
TCP 192.168.0.4:49555 server-54-230-206-118:https ESTABLISHED 215
2
TCP 192.168.0.4:49557 ec2-107-21-255-215:https TIME_WAIT 0
TCP 192.168.0.4:49558 edge-star-shv-01-mia1:https ESTABLISHED 215
2
TCP 192.168.0.4:49559 ec2-54-235-197-8:https TIME_WAIT 0
TCP 192.168.0.4:49560 ec2-54-235-197-8:https TIME_WAIT 0
TCP 192.168.0.4:49563 ec2-54-197-237-227:https FIN_WAIT_2 2152
TCP 192.168.0.4:49565 ec2-54-92-194-87:https TIME_WAIT 0
TCP 192.168.0.4:49566 136.147.133.16:https ESTABLISHED 2152
TCP 192.168.0.4:49567 ec2-54-243-59-158:https ESTABLISHED 2152
TCP 192.168.0.4:49569 ec2-54-235-84-193:https ESTABLISHED 2152
TCP 192.168.0.4:49570 199.16.156.73:https ESTABLISHED 2152
TCP 192.168.0.4:49571 199.16.156.11:https ESTABLISHED 2152
TCP 192.168.0.4:49572 ec2-54-235-84-193:https ESTABLISHED 2152
TCP 192.168.0.4:49573 ec2-54-235-84-193:https ESTABLISHED 2152
TCP 192.168.0.4:49574 ec2-54-235-84-193:https ESTABLISHED 2152
TCP 192.168.0.4:49575 ec2-54-235-84-193:https ESTABLISHED 2152
TCP 192.168.0.4:49576 ec2-54-235-84-193:https ESTABLISHED 2152
TCP 192.168.0.4:49581 ec2-54-210-200-97:https ESTABLISHED 2152
TCP 192.168.0.4:49583 ec2-54-197-237-227:https FIN_WAIT_2 2152
TCP 192.168.0.4:49584 ec2-54-92-194-87:https TIME_WAIT 0
TCP 192.168.0.4:49585 ec2-54-92-194-87:https TIME_WAIT 0
TCP 192.168.0.4:49586 ec2-54-197-237-227:https FIN_WAIT_2 2152
TCP 192.168.0.4:49588 ec2-54-197-237-227:https FIN_WAIT_2 2152
TCP 192.168.0.4:49591 ec2-54-92-194-87:https TIME_WAIT 0
TCP 192.168.0.4:49593 108.174.10.10:https ESTABLISHED 2152
TCP 192.168.0.4:49594 a23-210-172-116:https ESTABLISHED 2152
TCP 192.168.0.4:49596 ec2-54-197-237-227:https FIN_WAIT_2 2152
TCP 192.168.0.4:49598 ec2-54-92-194-87:https TIME_WAIT 0
TCP 192.168.0.4:49599 ec2-54-197-237-227:https FIN_WAIT_2 2152
TCP 192.168.0.4:49601 ec2-54-92-194-87:https TIME_WAIT 0
TCP 192.168.0.4:49602 ec2-54-197-237-227:https FIN_WAIT_2 2152
TCP 192.168.0.4:49608 ec2-54-235-197-8:https TIME_WAIT 0
TCP 192.168.0.4:49613 ec2-54-92-194-87:https TIME_WAIT 0
TCP 192.168.0.4:49617 ec2-54-197-237-227:https FIN_WAIT_2 2152
TCP 192.168.0.4:49618 ec2-54-92-194-87:https TIME_WAIT 0
TCP 192.168.0.4:49619 ec2-54-197-237-227:https FIN_WAIT_2 2152
TCP 192.168.0.4:49620 ec2-54-92-194-87:https TIME_WAIT 0
TCP 192.168.0.4:49623 r5:https ESTABLISHED 2152
TCP 192.168.0.4:49624 ec2-54-235-197-8:https TIME_WAIT 0
TCP 192.168.0.4:49630 ec2-54-235-197-8:https TIME_WAIT 0
TCP 192.168.0.4:49631 ec2-54-197-237-227:https FIN_WAIT_2 2152
TCP 192.168.0.4:49632 ec2-54-235-197-8:https TIME_WAIT 0
TCP 192.168.0.4:49634 ec2-54-197-237-227:https FIN_WAIT_2 2152
TCP 192.168.0.4:49635 ec2-54-92-194-87:https TIME_WAIT 0
TCP 192.168.0.4:49636 ec2-54-92-194-87:https TIME_WAIT 0

C:\Users\Daley>
dpuk44
 
Posts: 8
Joined: 14. May 2015 20:02
Operating System: Windows 7

Re: Portable XAMPP

Postby dpuk44 » 21. May 2015 13:20

and I am now getting this when I start the control panel

13:19:49 [main] Initializing Control Panel
13:19:49 [main] Windows Version: Windows 7 Home Premium SP1 64-bit
13:19:49 [main] XAMPP Version: 5.6.8
13:19:49 [main] Control Panel Version: 3.2.1 [ Compiled: May 7th 2013 ]
13:19:49 [main] You are not running with administrator rights! This will work for
13:19:49 [main] most application stuff but whenever you do something with services
13:19:49 [main] there will be a security dialogue or things will break! So think
13:19:49 [main] about running this application with administrator rights!
13:19:49 [main] XAMPP Installation Directory: "\\nus2000\admin\usb1-disk1\xampp\"
13:19:49 [main] Checking for prerequisites
13:19:49 [main] All prerequisites found
13:19:49 [main] Initializing Modules
13:19:49 [Apache] Problem detected!
13:19:49 [Apache] Port 80 in use by "c:\xampp\apache\bin\httpd.exe" with PID 4888!
13:19:49 [Apache] Apache WILL NOT start without the configured ports free!
13:19:49 [Apache] You need to uninstall/disable/reconfigure the blocking application
13:19:49 [Apache] or reconfigure Apache and the Control Panel to listen on a different port
13:19:49 [Apache] Problem detected!
13:19:49 [Apache] Port 443 in use by "c:\xampp\apache\bin\httpd.exe" with PID 4888!
13:19:49 [Apache] Apache WILL NOT start without the configured ports free!
13:19:49 [Apache] You need to uninstall/disable/reconfigure the blocking application
13:19:49 [Apache] or reconfigure Apache and the Control Panel to listen on a different port
13:19:49 [mysql] Problem detected!
13:19:49 [mysql] Port 3306 in use by "c:\xampp\mysql\bin\mysqld.exe"!
13:19:49 [mysql] MySQL WILL NOT start without the configured ports free!
13:19:49 [mysql] You need to uninstall/disable/reconfigure the blocking application
13:19:49 [mysql] or reconfigure MySQL and the Control Panel to listen on a different port
13:19:49 [main] Starting Check-Timer
13:19:49 [main] Control Panel Ready
dpuk44
 
Posts: 8
Joined: 14. May 2015 20:02
Operating System: Windows 7

Re: Portable XAMPP

Postby dpuk44 » 21. May 2015 13:27

I actually tried to run the control-panel from the hard drive from a laptop that dosnt have xampp install and I get the following error message when trying to start apache?

8:22:02 AM [main] Initializing Control Panel
8:22:02 AM [main] Windows Version: Windows 8 64-bit
8:22:02 AM [main] XAMPP Version: 5.6.8
8:22:02 AM [main] Control Panel Version: 3.2.1 [ Compiled: May 7th 2013 ]
8:22:02 AM [main] You are not running with administrator rights! This will work for
8:22:02 AM [main] most application stuff but whenever you do something with services
8:22:02 AM [main] there will be a security dialogue or things will break! So think
8:22:02 AM [main] about running this application with administrator rights!
8:22:02 AM [main] XAMPP Installation Directory: "\\nus2000\admin\usb1-disk1\xampp\"
8:22:02 AM [main] Checking for prerequisites
8:22:03 AM [main] All prerequisites found
8:22:03 AM [main] Initializing Modules
8:22:03 AM [main] Starting Check-Timer
8:22:03 AM [main] Control Panel Ready
8:22:11 AM [Apache] Attempting to start Apache app...
8:22:11 AM [Apache] Status change detected: running
8:22:14 AM [Apache] Status change detected: stopped
8:22:14 AM [Apache] Error: Apache shutdown unexpectedly.
8:22:14 AM [Apache] This may be due to a blocked port, missing dependencies,
8:22:14 AM [Apache] improper privileges, a crash, or a shutdown by another method.
8:22:14 AM [Apache] Press the Logs button to view error logs and check
8:22:14 AM [Apache] the Windows Event Viewer for more clues
8:22:14 AM [Apache] If you need more help, copy and post this
8:22:14 AM [Apache] entire log window on the forums
dpuk44
 
Posts: 8
Joined: 14. May 2015 20:02
Operating System: Windows 7

Re: Portable XAMPP

Postby Nobbie » 21. May 2015 14:14

dpuk44 wrote:and I am now getting this when I start the control panel

13:19:49 [main] Initializing Control Panel
13:19:49 [main] Windows Version: Windows 7 Home Premium SP1 64-bit
13:19:49 [main] XAMPP Version: 5.6.8
13:19:49 [main] Control Panel Version: 3.2.1 [ Compiled: May 7th 2013 ]
13:19:49 [main] You are not running with administrator rights! This will work for
13:19:49 [main] most application stuff but whenever you do something with services
13:19:49 [main] there will be a security dialogue or things will break! So think
13:19:49 [main] about running this application with administrator rights!
13:19:49 [main] XAMPP Installation Directory: "\\nus2000\admin\usb1-disk1\xampp\"
13:19:49 [main] Checking for prerequisites
13:19:49 [main] All prerequisites found
13:19:49 [main] Initializing Modules
13:19:49 [Apache] Problem detected!
13:19:49 [Apache] Port 80 in use by "c:\xampp\apache\bin\httpd.exe" with PID 4888!
13:19:49 [Apache] Apache WILL NOT start without the configured ports free!
13:19:49 [Apache] You need to uninstall/disable/reconfigure the blocking application
13:19:49 [Apache] or reconfigure Apache and the Control Panel to listen on a different port
13:19:49 [Apache] Problem detected!
13:19:49 [Apache] Port 443 in use by "c:\xampp\apache\bin\httpd.exe" with PID 4888!
13:19:49 [Apache] Apache WILL NOT start without the configured ports free!
13:19:49 [Apache] You need to uninstall/disable/reconfigure the blocking application
13:19:49 [Apache] or reconfigure Apache and the Control Panel to listen on a different port
13:19:49 [mysql] Problem detected!
13:19:49 [mysql] Port 3306 in use by "c:\xampp\mysql\bin\mysqld.exe"!
13:19:49 [mysql] MySQL WILL NOT start without the configured ports free!
13:19:49 [mysql] You need to uninstall/disable/reconfigure the blocking application
13:19:49 [mysql] or reconfigure MySQL and the Control Panel to listen on a different port
13:19:49 [main] Starting Check-Timer
13:19:49 [main] Control Panel Ready


This clearly says, that Apache & MySQL are already running. Seems your PC is starting everything on startup as a Service.
Nobbie
 
Posts: 8758
Joined: 09. March 2008 13:04

Re: Portable XAMPP

Postby mark.mcdonald » 21. May 2015 14:25

dpuk44 wrote:13:19:49 [Apache] Problem detected!
13:19:49 [Apache] Port 80 in use by "c:\xampp\apache\bin\httpd.exe" with PID 4888!
13:19:49 [Apache] Port 443 in use by "c:\xampp\apache\bin\httpd.exe" with PID 4888!


Stop every instance of xampp. Your local xampp is already running. As Nobbie said its probably running as a service. Go to Windows -> Services and stop apache and mysql from starting up automatically (right click the service, go to properties and set to manual).
Restart the computer to make sure they shut off and don't turn back on. (Check your services to make sure they didn't start again).
Start Control panel from your external drive and start apache and mysql. This will work as long as you have stopped everything else (making sure you local copy is stopped).
mark.mcdonald
 
Posts: 160
Joined: 13. March 2015 15:48
Location: Edmonton
Operating System: Windows Server 2012 R2

Re: Portable XAMPP

Postby dpuk44 » 22. May 2015 12:04

Thanks for your help guys!

I am now getting this

11:57:47 [main] Initializing Control Panel
11:57:47 [main] Windows Version: Windows 7 Home Premium SP1 64-bit
11:57:47 [main] XAMPP Version: 5.6.8
11:57:47 [main] Control Panel Version: 3.2.1 [ Compiled: May 7th 2013 ]
11:57:47 [main] Running with Administrator rights - good!
11:57:47 [main] XAMPP Installation Directory: "\\nus2000\admin\usb1-disk1\xampp\"
11:57:47 [main] Checking for prerequisites
11:57:47 [main] All prerequisites found
11:57:47 [main] Initializing Modules
11:57:47 [main] Starting Check-Timer
11:57:47 [main] Control Panel Ready
11:57:53 [Apache] Attempting to start Apache app...
11:57:54 [Apache] Status change detected: running
11:57:55 [Apache] Status change detected: stopped
11:57:55 [Apache] Error: Apache shutdown unexpectedly.
11:57:55 [Apache] This may be due to a blocked port, missing dependencies,
11:57:55 [Apache] improper privileges, a crash, or a shutdown by another method.
11:57:55 [Apache] Press the Logs button to view error logs and check
11:57:55 [Apache] the Windows Event Viewer for more clues
11:57:55 [Apache] If you need more help, copy and post this
11:57:55 [Apache] entire log window on the forums
11:58:11 [mysql] Attempting to start MySQL app...
11:58:16 [mysql] Status change detected: running
11:58:17 [mysql] Status change detected: stopped
11:58:17 [mysql] Error: MySQL shutdown unexpectedly.
11:58:17 [mysql] This may be due to a blocked port, missing dependencies,
11:58:17 [mysql] improper privileges, a crash, or a shutdown by another method.
11:58:17 [mysql] Press the Logs button to view error logs and check
11:58:17 [mysql] the Windows Event Viewer for more clues
11:58:17 [mysql] If you need more help, copy and post this
11:58:17 [mysql] entire log window on the forums
dpuk44
 
Posts: 8
Joined: 14. May 2015 20:02
Operating System: Windows 7

Re: Portable XAMPP

Postby mark.mcdonald » 22. May 2015 15:20

dpuk44 wrote:11:57:55 [Apache] Press the Logs button to view error logs and check
11:57:55 [Apache] the Windows Event Viewer for more clues
11:57:55 [Apache] If you need more help, copy and post this
11:57:55 [Apache] entire log window on the forums

11:58:17 [mysql] Press the Logs button to view error logs and check
11:58:17 [mysql] the Windows Event Viewer for more clues
11:58:17 [mysql] If you need more help, copy and post this
11:58:17 [mysql] entire log window on the forums

What are the logs now for Apache and MySQL? Post the logs here. Please begin to read these messages as they can help you as we are trying. I'm 98% sure this will tell you your ports are still in use by either your local installation or potentially running side by side copies of your external xampp installation. Are you running more than one xampp control panel? Do you have a mysql installation separately from xampp (I doubt this is the case)? Have you rebooted your machine? Have you checked your windows services to see if apache and mysql are installed and running as a service (they should not be running if you did this from our previous messages.)? Do you have skype running? Please tell us in detail what you have done, where you have looked to prevent these ports from being in use, example: "I have gone to c:\xampp and made sure the control panel was not running by double clicking the xampp_stop.exe, I also double clicked the apache_stop.bat and mysql_stop.bat to make sure. I have navigated to the control panel in windows, searched for administrative tools, double clicked on services, and (did/did not) see (Apache2.4/mysql) as a listed service. (If saw them as a service then I right clicked on the service and went to the properties, set the drop down menu to under "Startup Type" to "Manual". I also right clicked the service and selected stop. I refreshed the services page to make sure the service was not running). I checked control panel and navigated to "Programs and Services" to make sure I did not have anything resembling MySQL/Community... installed. In the bottom right hand corner of my desktop where all the icons are I could not see anything resembling a xampp control panel icon running. At this point I assume all instances of xampp are stopped. I went to my external drive and tried starting xampp_start.exe/xampp control panel. I got (green lights/error messages). (I went to my external drive xampp folder, navigated to xampp->apache->logs->error.log and saw that my ports are in use by my local installation "C:\xampp\...". Where else would they be running/called from?)
mark.mcdonald
 
Posts: 160
Joined: 13. March 2015 15:48
Location: Edmonton
Operating System: Windows Server 2012 R2

Re: Portable XAMPP

Postby dpuk44 » 23. May 2015 00:50

Thanks, sorry and I appreciate all your help! OK to make this even simpler I am now on a machine that doesn't have XAMPP installed locally. I reinstalled XAMPP from the .exe file onto my external hard drive. My external hard drive is connected to my router via a NAS adapter. From my machine I go to windows explorer->network and open up my the XAMPP folder. I then right click on xampp-control and click run as administrator. There is a green tick against Apache and MySQL. I click start on Apache and it shows this:

7:46:00 PM [main] Initializing Control Panel
7:46:00 PM [main] Windows Version: Windows 8 64-bit
7:46:00 PM [main] XAMPP Version: 5.6.8
7:46:00 PM [main] Control Panel Version: 3.2.1 [ Compiled: May 7th 2013 ]
7:46:00 PM [main] Running with Administrator rights - good!
7:46:00 PM [main] XAMPP Installation Directory: "\\nus2000\admin\usb1-disk1\xampp\"
7:46:00 PM [main] Checking for prerequisites
7:46:00 PM [main] All prerequisites found
7:46:00 PM [main] Initializing Modules
7:46:01 PM [main] Starting Check-Timer
7:46:01 PM [main] Control Panel Ready
7:46:10 PM [Apache] Attempting to start Apache service...

That's it. Nothing further happens. Skype isn't open and when I click logs->Apache(error.log) the file is empty. I didn't realize how difficult this would be and I just cant get my head around it.

Now when I go to services->Apache2.4 and I click start, it says windows could not start apache2.4 service on local computer, Error 5. Access is denied.

It would appear privileges is the issue here an not ports?
dpuk44
 
Posts: 8
Joined: 14. May 2015 20:02
Operating System: Windows 7


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 42 guests