xammp crashes on win 7

Problems with the Windows version of XAMPP, questions, comments, and anything related.

xammp crashes on win 7

Postby dylan18 » 20. May 2015 16:18

had it working early today but now xammp won't load apache nor mysql. here's my control log
8:14:26 AM [main] Initializing Control Panel
8:14:26 AM [main] Windows Version: Windows 7 Home Premium SP1 64-bit
8:14:26 AM [main] XAMPP Version: 5.6.8
8:14:26 AM [main] Control Panel Version: 3.2.1 [ Compiled: May 7th 2013 ]
8:14:26 AM [main] Running with Administrator rights - good!
8:14:26 AM [main] XAMPP Installation Directory: "c:\xammp\"
8:14:26 AM [main] Checking for prerequisites
8:14:26 AM [main] All prerequisites found
8:14:26 AM [main] Initializing Modules
8:14:26 AM [main] Starting Check-Timer
8:14:26 AM [main] Control Panel Ready
8:14:29 AM [Apache] Attempting to start Apache app...
8:14:46 AM [Apache] Attempting to start Apache app...
8:14:47 AM [Apache] Status change detected: running
8:14:47 AM [Apache] Status change detected: stopped
8:14:47 AM [Apache] Error: Apache shutdown unexpectedly.
8:14:47 AM [Apache] This may be due to a blocked port, missing dependencies,
8:14:47 AM [Apache] improper privileges, a crash, or a shutdown by another method.
8:14:47 AM [Apache] Press the Logs button to view error logs and check
8:14:47 AM [Apache] the Windows Event Viewer for more clues
8:14:47 AM [Apache] If you need more help, copy and post this
8:14:47 AM [Apache] entire log window on the forums
8:16:57 AM [Apache] Attempting to start Apache app...
8:16:57 AM [Apache] Status change detected: running
8:16:58 AM [Apache] Status change detected: stopped
8:16:58 AM [Apache] Error: Apache shutdown unexpectedly.
8:16:58 AM [Apache] This may be due to a blocked port, missing dependencies,
8:16:58 AM [Apache] improper privileges, a crash, or a shutdown by another method.
8:16:58 AM [Apache] Press the Logs button to view error logs and check
8:16:58 AM [Apache] the Windows Event Viewer for more clues
8:16:58 AM [Apache] If you need more help, copy and post this
8:16:58 AM [Apache] entire log window on the forums
8:17:02 AM [main] Deinitializing Modules
8:17:02 AM [main] Deinitializing Control Panel

8:17:14 AM [main] Initializing Control Panel
8:17:14 AM [main] Windows Version: Windows 7 Home Premium SP1 64-bit
8:17:14 AM [main] XAMPP Version: 5.6.8
8:17:14 AM [main] Control Panel Version: 3.2.1 [ Compiled: May 7th 2013 ]
8:17:14 AM [main] Running with Administrator rights - good!
8:17:14 AM [main] XAMPP Installation Directory: "c:\xammp\"
8:17:14 AM [main] Checking for prerequisites
8:17:14 AM [main] All prerequisites found
8:17:14 AM [main] Initializing Modules
8:17:14 AM [main] Starting Check-Timer
8:17:14 AM [main] Control Panel Ready
8:17:28 AM [Apache] Attempting to start Apache app...
8:17:29 AM [Apache] Status change detected: running
8:17:29 AM [Apache] Status change detected: stopped
8:17:29 AM [Apache] Error: Apache shutdown unexpectedly.
8:17:29 AM [Apache] This may be due to a blocked port, missing dependencies,
8:17:29 AM [Apache] improper privileges, a crash, or a shutdown by another method.
8:17:29 AM [Apache] Press the Logs button to view error logs and check
8:17:29 AM [Apache] the Windows Event Viewer for more clues
8:17:29 AM [Apache] If you need more help, copy and post this
8:17:29 AM [Apache] entire log window on the forums
8:17:33 AM [mysql] Attempting to start MySQL app...
8:17:33 AM [mysql] Status change detected: running
8:17:34 AM [mysql] Status change detected: stopped
8:17:34 AM [mysql] Error: MySQL shutdown unexpectedly.
8:17:34 AM [mysql] This may be due to a blocked port, missing dependencies,
8:17:34 AM [mysql] improper privileges, a crash, or a shutdown by another method.
8:17:34 AM [mysql] Press the Logs button to view error logs and check
8:17:34 AM [mysql] the Windows Event Viewer for more clues
8:17:34 AM [mysql] If you need more help, copy and post this
8:17:34 AM [mysql] entire log window on the forums
8:17:37 AM [main] Deinitializing Modules
8:17:37 AM [main] Deinitializing Control Panel

9:06:22 AM [main] Initializing Control Panel
9:06:22 AM [main] Windows Version: Windows 7 Home Premium SP1 64-bit
9:06:22 AM [main] XAMPP Version: 5.6.8
9:06:22 AM [main] Control Panel Version: 3.2.1 [ Compiled: May 7th 2013 ]
9:06:22 AM [main] Running with Administrator rights - good!
9:06:22 AM [main] XAMPP Installation Directory: "c:\xammp\"
9:06:22 AM [main] Checking for prerequisites
9:06:22 AM [main] All prerequisites found
9:06:22 AM [main] Initializing Modules
9:06:22 AM [main] Starting Check-Timer
9:06:22 AM [main] Control Panel Ready
9:06:26 AM [Apache] Attempting to start Apache app...
9:06:26 AM [Apache] Status change detected: running
9:06:26 AM [Apache] Status change detected: stopped
9:06:26 AM [Apache] Error: Apache shutdown unexpectedly.
9:06:26 AM [Apache] This may be due to a blocked port, missing dependencies,
9:06:26 AM [Apache] improper privileges, a crash, or a shutdown by another method.
9:06:26 AM [Apache] Press the Logs button to view error logs and check
9:06:26 AM [Apache] the Windows Event Viewer for more clues
9:06:26 AM [Apache] If you need more help, copy and post this
9:06:26 AM [Apache] entire log window on the forums
9:06:32 AM [mysql] Attempting to start MySQL app...
9:06:32 AM [mysql] Status change detected: running
9:06:32 AM [mysql] Status change detected: stopped
9:06:32 AM [mysql] Error: MySQL shutdown unexpectedly.
9:06:32 AM [mysql] This may be due to a blocked port, missing dependencies,
9:06:32 AM [mysql] improper privileges, a crash, or a shutdown by another method.
9:06:32 AM [mysql] Press the Logs button to view error logs and check
9:06:32 AM [mysql] the Windows Event Viewer for more clues
9:06:32 AM [mysql] If you need more help, copy and post this
9:06:32 AM [mysql] entire log window on the forums
9:06:36 AM [main] Deinitializing Modules
9:06:36 AM [main] Deinitializing Control Panel

9:41:20 AM [main] Initializing Control Panel
9:41:20 AM [main] Windows Version: Windows 7 Home Premium SP1 64-bit
9:41:20 AM [main] XAMPP Version: 5.6.8
9:41:20 AM [main] Control Panel Version: 3.2.1 [ Compiled: May 7th 2013 ]
9:41:20 AM [main] Running with Administrator rights - good!
9:41:20 AM [main] XAMPP Installation Directory: "c:\xammp\"
9:41:20 AM [main] Checking for prerequisites
9:41:20 AM [main] All prerequisites found
9:41:20 AM [main] Initializing Modules
9:41:20 AM [main] Starting Check-Timer
9:41:20 AM [main] Control Panel Ready
9:41:24 AM [Apache] Attempting to start Apache app...
9:41:25 AM [Apache] Status change detected: running
9:41:25 AM [Apache] Status change detected: stopped
9:41:25 AM [Apache] Error: Apache shutdown unexpectedly.
9:41:25 AM [Apache] This may be due to a blocked port, missing dependencies,
9:41:25 AM [Apache] improper privileges, a crash, or a shutdown by another method.
9:41:25 AM [Apache] Press the Logs button to view error logs and check
9:41:25 AM [Apache] the Windows Event Viewer for more clues
9:41:25 AM [Apache] If you need more help, copy and post this
9:41:25 AM [Apache] entire log window on the forums
9:41:58 AM [mysql] Attempting to start MySQL app...
9:41:58 AM [mysql] Status change detected: running
9:41:58 AM [mysql] Status change detected: stopped
9:41:58 AM [mysql] Error: MySQL shutdown unexpectedly.
9:41:58 AM [mysql] This may be due to a blocked port, missing dependencies,
9:41:58 AM [mysql] improper privileges, a crash, or a shutdown by another method.
9:41:58 AM [mysql] Press the Logs button to view error logs and check
9:41:58 AM [mysql] the Windows Event Viewer for more clues
9:41:58 AM [mysql] If you need more help, copy and post this
9:41:58 AM [mysql] entire log window on the forums
9:43:54 AM [main] Deinitializing Modules
9:43:54 AM [main] Deinitializing Control Panel

9:44:29 AM [main] Initializing Control Panel
9:44:29 AM [main] Windows Version: Windows 7 Home Premium SP1 64-bit
9:44:29 AM [main] XAMPP Version: 5.6.8
9:44:29 AM [main] Control Panel Version: 3.2.1 [ Compiled: May 7th 2013 ]
9:44:29 AM [main] Running with Administrator rights - good!
9:44:29 AM [main] XAMPP Installation Directory: "c:\xammp\"
9:44:29 AM [main] Checking for prerequisites
9:44:29 AM [main] All prerequisites found
9:44:29 AM [main] Initializing Modules
9:44:29 AM [main] Starting Check-Timer
9:44:29 AM [main] Control Panel Ready
9:44:34 AM [Apache] Attempting to start Apache app...
9:44:34 AM [Apache] Status change detected: running
9:44:35 AM [Apache] Status change detected: stopped
9:44:35 AM [Apache] Error: Apache shutdown unexpectedly.
9:44:35 AM [Apache] This may be due to a blocked port, missing dependencies,
9:44:35 AM [Apache] improper privileges, a crash, or a shutdown by another method.
9:44:35 AM [Apache] Press the Logs button to view error logs and check
9:44:35 AM [Apache] the Windows Event Viewer for more clues
9:44:35 AM [Apache] If you need more help, copy and post this
9:44:35 AM [Apache] entire log window on the forums
9:44:39 AM [main] Deinitializing Modules
9:44:39 AM [main] Deinitializing Control Panel

10:10:23 AM [main] Initializing Control Panel
10:10:23 AM [main] Windows Version: Windows 7 Home Premium SP1 64-bit
10:10:23 AM [main] XAMPP Version: 5.6.8
10:10:23 AM [main] Control Panel Version: 3.2.1 [ Compiled: May 7th 2013 ]
10:10:23 AM [main] Running with Administrator rights - good!
10:10:23 AM [main] XAMPP Installation Directory: "c:\xammp\"
10:10:23 AM [main] Checking for prerequisites
10:10:23 AM [main] All prerequisites found
10:10:23 AM [main] Initializing Modules
10:10:23 AM [Apache] Problem detected!
10:10:23 AM [Apache] Port 80 in use by "C:\Program Files (x86)\Skype\Phone\Skype.exe" with PID 7324!
10:10:23 AM [Apache] Apache WILL NOT start without the configured ports free!
10:10:23 AM [Apache] You need to uninstall/disable/reconfigure the blocking application
10:10:23 AM [Apache] or reconfigure Apache and the Control Panel to listen on a different port
10:10:23 AM [Apache] Problem detected!
10:10:23 AM [Apache] Port 443 in use by "C:\Program Files (x86)\Skype\Phone\Skype.exe" with PID 7324!
10:10:23 AM [Apache] Apache WILL NOT start without the configured ports free!
10:10:23 AM [Apache] You need to uninstall/disable/reconfigure the blocking application
10:10:23 AM [Apache] or reconfigure Apache and the Control Panel to listen on a different port
10:10:23 AM [main] Starting Check-Timer
10:10:23 AM [main] Control Panel Ready
10:10:30 AM [Apache] Problem detected!
10:10:30 AM [Apache] Port 80 in use by "C:\Program Files (x86)\Skype\Phone\Skype.exe" with PID 7324!
10:10:30 AM [Apache] Apache WILL NOT start without the configured ports free!
10:10:30 AM [Apache] You need to uninstall/disable/reconfigure the blocking application
10:10:30 AM [Apache] or reconfigure Apache and the Control Panel to listen on a different port
10:10:30 AM [Apache] Problem detected!
10:10:30 AM [Apache] Port 443 in use by "C:\Program Files (x86)\Skype\Phone\Skype.exe" with PID 7324!
10:10:30 AM [Apache] Apache WILL NOT start without the configured ports free!
10:10:30 AM [Apache] You need to uninstall/disable/reconfigure the blocking application
10:10:30 AM [Apache] or reconfigure Apache and the Control Panel to listen on a different port
10:10:30 AM [Apache] Attempting to start Apache app...
10:10:30 AM [Apache] Status change detected: running
10:10:31 AM [Apache] Status change detected: stopped
10:10:31 AM [Apache] Error: Apache shutdown unexpectedly.
10:10:31 AM [Apache] This may be due to a blocked port, missing dependencies,
10:10:31 AM [Apache] improper privileges, a crash, or a shutdown by another method.
10:10:31 AM [Apache] Press the Logs button to view error logs and check
10:10:31 AM [Apache] the Windows Event Viewer for more clues
10:10:31 AM [Apache] If you need more help, copy and post this
10:10:31 AM [Apache] entire log window on the forums
10:10:35 AM [main] Deinitializing Modules
10:10:35 AM [main] Deinitializing Control Panel

any clues? any suggestions to get me going would be helpful. thanks. so while reviewing log i see skype was interfering. so how can i change port for xammp, please.
dylan18
 
Posts: 1
Joined: 20. May 2015 16:03
Operating System: win7

Re: xammp crashes on win 7

Postby mark.mcdonald » 20. May 2015 16:31

mark.mcdonald
 
Posts: 160
Joined: 13. March 2015 15:48
Location: Edmonton
Operating System: Windows Server 2012 R2


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 72 guests