Page 1 of 1

Administrator rights

PostPosted: 11. May 2015 13:42
by Tigers!
I am trying to get started and having Apache/SQL issues.
The first error message I get on XAMPP Control Panel v3.2.1 is
quote][9:49:49 PM [main] Initializing Control Panel
9:49:49 PM [main] Windows Version: Windows 8 64-bit
9:49:49 PM [main] XAMPP Version: 5.6.3
9:49:49 PM [main] Control Panel Version: 3.2.1 [ Compiled: May 7th 2013 ]
9:49:49 PM [main] You are not running with administrator rights! This will work for
9:49:49 PM [main] most application stuff but whenever you do something with services
9:49:49 PM [main] there will be a security dialogue or things will break! So think
9:49:49 PM [main] about running this application with administrator rights![/quote]
Searching on these fora I found that I should
To solve that issue you have to restart your control panel with elevated administrator rights:
•rightclick your xampp-control.exe file
•choose "run as Administrator"
•if UAC is enabled you need to confirm that you really want to run as Administrator
•if you are not logged in as Administrator on your Windows system you need to type in the credentials of an administrator


Question: Where is xampp-control.exe? I cannot find it under c:\xampp folder

Re: Administrator rights

PostPosted: 11. May 2015 14:06
by Nobbie
Simply click on the Xampp Icon which is installed by Xampp. That is xampp-control.exe (i think its stored in c:/xampp/bin). Right click on that orange icon and choose "Run as administrator..."

Re: Administrator rights

PostPosted: 11. May 2015 14:23
by Tigers!
Thanks Nobbie
Now I can it and see more error messages :( :?

Re: Administrator rights

PostPosted: 11. May 2015 15:36
by Altrea
Tigers! wrote:I cannot find it under c:\xampp folder

But it is there.

Tigers! wrote:Now I can it and see more error messages :( :?

Maybe you want to tell us which messages you see now?

Re: Administrator rights

PostPosted: 12. May 2015 11:47
by Tigers!
After removing my 2nd XAMPP installation and restarting I get the following messages.
8:40:06 PM [main] Initializing Control Panel
8:40:06 PM [main] Windows Version: Windows 8 64-bit
8:40:06 PM [main] XAMPP Version: 5.6.3
8:40:06 PM [main] Control Panel Version: 3.2.1 [ Compiled: May 7th 2013 ]
8:40:06 PM [main] Running with Administrator rights - good!
8:40:06 PM [main] XAMPP Installation Directory: "c:\xampp\"
8:40:06 PM [main] Checking for prerequisites
8:40:06 PM [main] All prerequisites found
8:40:06 PM [main] Initializing Modules
8:40:06 PM [main] The FileZilla module is disabled
8:40:06 PM [main] The Mercury module is disabled
8:40:06 PM [main] Enabling autostart for module "Apache"
8:40:06 PM [main] Enabling autostart for module "MySQL"
8:40:06 PM [main] Enabling autostart for module "Tomcat"
8:40:06 PM [main] Starting Check-Timer
8:40:06 PM [main] Control Panel Ready
8:40:07 PM [Apache] Autostart active: starting...
8:40:07 PM [Apache] Attempting to start Apache app...
8:40:07 PM [mysql] Autostart active: starting...
8:40:07 PM [mysql] Attempting to start MySQL app...
8:40:07 PM [Tomcat] Autostart active: starting...
8:40:07 PM [Tomcat] Attempting to start Tomcat app...
8:40:08 PM [mysql] Status change detected: running
8:40:08 PM [Apache] Status change detected: running
8:40:09 PM [Tomcat] Tomcat Started/Stopped with errors, return code: 1
8:40:09 PM [Tomcat] Make sure you have Java JDK or JRE installed and the required ports are free
8:40:09 PM [Tomcat] Check the "/xampp/tomcat/logs" folder for more information
8:40:36 PM [main] Executing "c:\xampp\tomcat\logs"
8:41:28 PM [Tomcat] Installing service...
8:41:28 PM [Tomcat] Service was NOT (un)installed!
8:41:57 PM [Tomcat] Attempting to start Tomcat app...
8:41:57 PM [Tomcat] Tomcat Started/Stopped with errors, return code: 1
8:41:57 PM [Tomcat] Make sure you have Java JDK or JRE installed and the required ports are free
8:41:57 PM [Tomcat] Check the "/xampp/tomcat/logs" folder for more information
8:42:07 PM [main] Executing "c:\xampp\tomcat\logs"


I have not installed Filezilla as I have it installed and running separately. I did not have Tomcat installed as I was not certain I needed it (silly me). I have tried to install/run without success and the log file is a null file.
I cannot seem to get Mercury going. I will need to trawl through the notes.

Re: Administrator rights

PostPosted: 12. May 2015 11:49
by Tigers!
After a quick browse I note that Mercury is an e-mail client. I already have Outlook on my lap top. Do I need Mercury?

Re: Administrator rights

PostPosted: 12. May 2015 13:02
by Nobbie
Tigers! wrote:After a quick browse I note that Mercury is an e-mail client. I already have Outlook on my lap top. Do I need Mercury?


Mercury is an Email Server, Outlook is a client. You dont need Mercury as long as you will not run an Email server. Anyway, it is very sophisticated task to setup an Email server, also most Emails from private SMTP Servers are blocked by the major Email Services (like GMX etc.). I dont think you need Mercury.