How to solve port 80 in use message ?

Problems with the Windows version of XAMPP, questions, comments, and anything related.

How to solve port 80 in use message ?

Postby Chocolade130972 » 09. May 2015 21:21

I have xampp version 3.2.1

When running the control panel i'm getting this message in the log window:

23:07:49 [main] Initializing Control Panel
23:07:49 [main] Windows Version: Windows 8 Pro 64-bit
23:07:49 [main] XAMPP Version: 5.5.19
23:07:49 [main] Control Panel Version: 3.2.1 [ Compiled: May 7th 2013 ]
23:07:49 [main] Running with Administrator rights - good!
23:07:49 [main] XAMPP Installation Directory: "c:\xampp\"
23:07:49 [main] Checking for prerequisites
23:07:52 [main] All prerequisites found
23:07:52 [main] Initializing Modules
23:07:52 [Apache] Problem detected!
23:07:52 [Apache] Port 80 in use by "Unable to open process" with PID 4!
23:07:52 [Apache] Apache WILL NOT start without the configured ports free!
23:07:52 [Apache] You need to uninstall/disable/reconfigure the blocking application
23:07:52 [Apache] or reconfigure Apache and the Control Panel to listen on a different port
23:07:52 [filezilla] Problem detected!
23:07:52 [filezilla] Port 21 in use by "C:\WINDOWS\system32\svchost.exe -k ftpsvc"!
23:07:52 [filezilla] FileZilla WILL NOT start without the configured ports free!
23:07:52 [filezilla] You need to uninstall/disable/reconfigure the blocking application
23:07:52 [filezilla] or reconfigure FileZilla and the Control Panel to listen on a different port
23:07:52 [main] Starting Check-Timer
23:07:52 [main] Control Panel Ready



I already changed the prot number in the apache confige after clicked on Config > httpd.conf
There in the opened file i change the line Listen 8080 it was Listen 80 i changed it to 8080

But still each time i'm running the cmapp control panel i'm getting message error in red.
But also when running starting the apache it's running fine:

23:08:23 [Apache] Attempting to start Apache app...
23:08:25 [Apache] Status change detected: running

And i see near the apache PID(s) 13888 and 14300 Port(s) 443, 8080

The question is: How to solve the error ? FileZilla is not running now but still i'm getting the error.
Chocolade130972
 
Posts: 1
Joined: 09. May 2015 21:14
Operating System: windows 8.1 pro

Re: How to solve port 80 in use message ?

Postby Altrea » 09. May 2015 22:36

We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8294
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 66 guests