[HELP] HTTPS isnt working

Problems with the Windows version of XAMPP, questions, comments, and anything related.

[HELP] HTTPS isnt working

Postby bernardwi » 06. May 2015 08:36

Hi there,

Im using CodeIgniter in xampp. And i want make http:// into http://

I already tried so many way and follow all tutorial about this. But no one is working.

Also i tried self sign certificate to test it in my local but it doesn't work too.

I'd like to get some help here. Someone help me to solve this problem please, at least i want in my local working.
bernardwi
 
Posts: 3
Joined: 06. May 2015 08:28
Operating System: Windows 7

Re: [HELP] HTTPS isnt working

Postby Altrea » 06. May 2015 14:00

Hi,

bernardwi wrote:And i want make http:// into http://

:?: :?:

bernardwi wrote:I already tried so many way and follow all tutorial about this. But no one is working.

Also i tried self sign certificate to test it in my local but it doesn't work too.

Not working is never a qualified error report.


bernardwi wrote:I'd like to get some help here. Someone help me to solve this problem please

Help us helping you. Explain what you tried, which tutorials you already tried and why you think it is not working.
full error messages are always preferable. More information is always more information.

best wishes,
Altrea
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8299
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: [HELP] HTTPS isnt working

Postby bernardwi » 07. May 2015 07:49

I'm really sorry if u dont understand.

Right now im using CodeIgniter in xampp
I put my ci folder in xampp/htdocs/myproject
I want to use ssl for this

Ex : usually i open in my local on browsing using address http://localhost/myproject. If i use ssl on that it should be https://localhost/myproject. Am i right about that?

But seems the ssl isnt working at all.

Altrea wrote:
bernardwi wrote:I already tried so many way and follow all tutorial about this. But no one is working.

Also i tried self sign certificate to test it in my local but it doesn't work too.

Not working is never a qualified error report.


I'm not saying qualified error, i'm just asking for help why ssl isn't working in my local

The way i create self sign certificate by using makecert.bat in xampp.

Regards
bernardwi
 
Posts: 3
Joined: 06. May 2015 08:28
Operating System: Windows 7

Re: [HELP] HTTPS isnt working

Postby Nobbie » 07. May 2015 12:30

bernardwi wrote: i'm just asking for help why ssl isn't working in my local


Because something is wrong and the error message tells you what.
Nobbie
 
Posts: 8780
Joined: 09. March 2008 13:04

Re: [HELP] HTTPS isnt working

Postby Altrea » 07. May 2015 21:22

bernardwi wrote:But seems the ssl isnt working at all.

I see! The good thing is there is only one single reason for this: Something is wrong.

Altrea wrote:I'm not saying qualified error, i'm just asking for help why ssl isn't working in my local

Okay. Well without having any detailed information about what the problem is and what you have done exactly it is impossible for us to help you solving this.
Thats like you are going to the doctor and just saying something hurts you, but you won't tell him where it hurts or how it feals.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8299
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: [HELP] HTTPS isnt working

Postby bernardwi » 08. May 2015 05:53

Ok here's the things that i already do:
1. Generating key.
On cmd i generating .key with using command "openssl genrsa -out server.key 2048"
2. Generating csr
On cmd i generating .csr with using command "openssl req -new -key server.key -out server.csr"
3. Remove Passphrase from Key
On cmd i removing passphrase from key "openssl rsa -in server.key -out server-2.key"
4. Generating a Self-Signed Certificate
On cmd i generating self sign ceritificat using command "openssl x509 -req -days 365 -in server.csr -signkey server-2.key -out server.crt"
5. I copy file and put on folder in xampp
I copy server-2.key to xampp/apache/conf/ssl.key
I copy server.csr to xampp/apache/conf/ssl.csr
I copy server.crt to xampp/apache/conf/ssl.crt
6. Changing on httpd-ssl.conf
On xampp/apache/conf/extra/httpd-ssl.conf i change :
SSLCertificateFile "conf/ssl.crt/server.crt"
SSLCertificateKeyFile "conf/ssl.key/server2.key"
Thats all instruction that i follow. Is there any missing or something?

I save my project on xampp/htdocs/gema
When i open in my browser and open https://localhost/gema. The css doesnt work at all. And it like this Image


Hope this will explain that i do

Regards
bernardwi
 
Posts: 3
Joined: 06. May 2015 08:28
Operating System: Windows 7

Re: [HELP] HTTPS isnt working

Postby gsmith » 09. May 2015 00:57

SSL is working, you are seeing some of your page. The problem most likely is in your theme or CodeIgniter itself, someone didn't think that anyone would want to use SSL so things have been hard coded to http:// only. I've seen this before.

View Source in your browser. You mentioned your CSS is not showing up, well, in your view source I would bet the link tags to your css files are beginning with http://.

Firefox is then blocking these, it says so plainly.
gsmith
 
Posts: 196
Joined: 29. November 2013 18:04
Location: San Diego
XAMPP version: 0.0.0
Operating System: Win XP to 2012R2/VS 6,9,11,14

Re: [HELP] HTTPS isnt working

Postby Nobbie » 09. May 2015 10:08

It might be a good idea to click on that "Options" Button as well as to click on that "Learn more..." link. Maybe some usefull hints will appear.
Nobbie
 
Posts: 8780
Joined: 09. March 2008 13:04


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 45 guests