Get Apache to run on Port 80 in XAMPP in Win8-8.1 it works

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Get Apache to run on Port 80 in XAMPP in Win8-8.1 it works

Postby TonyMen » 10. April 2015 11:03

How to get Apache to run on Port 80 in XAMPP (it works)

After much googleing
I found the the NT Kernel was still listening on port 80 ( this is fixed in win 8 and 8.1) Now there is a way
around it.

I NOW HAVE APACHE LISTENING ON PORT 80. See how below.

I have found a process called "NT Kernel & System" is using port 80. It's a system process (Thats why Apache wont load.)I has previously deactivated my IIS as many people said that would cure the problem (It did not) so I was pretty frustrated how to use that Port 80.

After hours of Googeling I found the answer thought it may help others.IE.

Stop the World Wide Web Publishing Service.
On the Start menu, point to Settings, click Control Panel, double-click Administrative Tools, and then double-click Component Services.
In the console tree, click Services (Local).
In the details pane, right-click World Wide Web Publishing Service and then right click "select properties" and select "disable".Then in the right column click "MORE ACTIONS" and select "properties" then in "START UP TYPE" SELECT "DISABLED".

Now "localhost" when entered in browser goes straight to http://localhost/xampp/splash.php

Hope That Helps.
Last edited by TonyMen on 10. April 2015 11:15, edited 1 time in total.
TonyMen
 
Posts: 9
Joined: 08. April 2015 10:13
Operating System: win 8.1 64 bit

Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 73 guests